aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-05-18 01:23:12 +0800
committerpav <pav@FreeBSD.org>2010-05-18 01:23:12 +0800
commitc6526441f8adb4298bbe5febd03c3be36379f94d (patch)
treefdd1ac9f793eb4443117f1a28b410ab0127c7e73 /graphics
parenta93ab46d92e78359988da86717c91f2d0fff070d (diff)
downloadfreebsd-ports-gnome-c6526441f8adb4298bbe5febd03c3be36379f94d.tar.gz
freebsd-ports-gnome-c6526441f8adb4298bbe5febd03c3be36379f94d.tar.zst
freebsd-ports-gnome-c6526441f8adb4298bbe5febd03c3be36379f94d.zip
- Fix build on 6.X
- Install docs PR: ports/146667 Submitted by: Andras Horvath <han@log69.com> (maintainer)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/aaphoto/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/graphics/aaphoto/Makefile b/graphics/aaphoto/Makefile
index f5bc00962070..6244e9dc190e 100644
--- a/graphics/aaphoto/Makefile
+++ b/graphics/aaphoto/Makefile
@@ -7,6 +7,7 @@
PORTNAME= aaphoto
PORTVERSION= 0.37
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://log69.com/downloads/
DISTNAME= ${PORTNAME}_sources_v${PORTVERSION}
@@ -25,10 +26,26 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_FILES= bin/aaphoto
+PORTDOCS= AUTHORS ChangeLog COPYING COPYRIGHT INSTALL LICENSE \
+ NEWS README TODO
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+CFLAGS+= -fno-openmp -Wno-unknown-pragmas -U__OPENMP__
+.endif
do-install:
.for FILE in aaphoto
${INSTALL_PROGRAM} ${WRKSRC}/${FILE} ${PREFIX}/bin
.endfor
-.include <bsd.port.mk>
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>