aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2009-04-12 04:41:16 +0800
committergahr <gahr@FreeBSD.org>2009-04-12 04:41:16 +0800
commitc6d1426269e558c8df6a475a031f80d51627b0e7 (patch)
treea8bb8bd44f075908577eec733c5ec59f48e438ea /graphics
parent424e19b646418671bf5c1e80c9ed1fd6c1ea96c9 (diff)
downloadfreebsd-ports-gnome-c6d1426269e558c8df6a475a031f80d51627b0e7.tar.gz
freebsd-ports-gnome-c6d1426269e558c8df6a475a031f80d51627b0e7.tar.zst
freebsd-ports-gnome-c6d1426269e558c8df6a475a031f80d51627b0e7.zip
- Fix build
- Fix PORTDOCS/EXAMPLESDIR mismatch
Diffstat (limited to 'graphics')
-rw-r--r--graphics/robot/Makefile2
-rw-r--r--graphics/robot/files/patch-ARK_arckplot.c56
-rw-r--r--graphics/robot/files/patch-Robot+main.c31
-rw-r--r--graphics/robot/files/patch-Robot+subroutines.f32
-rw-r--r--graphics/robot/files/patch-Robot_fitter.c11
-rw-r--r--graphics/robot/files/patch-Robot_history.c29
-rw-r--r--graphics/robot/files/patch-Robot_rfits.c10
-rw-r--r--graphics/robot/files/patch-Robot_subroutines3.f11
-rw-r--r--graphics/robot/pkg-plist36
9 files changed, 195 insertions, 23 deletions
diff --git a/graphics/robot/Makefile b/graphics/robot/Makefile
index 0eea4b1a659d..191c6662c4b5 100644
--- a/graphics/robot/Makefile
+++ b/graphics/robot/Makefile
@@ -42,6 +42,8 @@ do-install:
@${GZIP_CMD} ${DOCSDIR}/RobotManual.ps
@${REINPLACE_CMD} -e 's+/usr/bin+${PREFIX}/bin+ ' \
${WRKSRC}/Demos/*.rob
+.endif
+.ifndef NOPORTDOCS
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/Demos/*.rob ${EXAMPLESDIR}
.endif
diff --git a/graphics/robot/files/patch-ARK_arckplot.c b/graphics/robot/files/patch-ARK_arckplot.c
new file mode 100644
index 000000000000..0ee33d6e156b
--- /dev/null
+++ b/graphics/robot/files/patch-ARK_arckplot.c
@@ -0,0 +1,56 @@
+--- ARK/arkcplot.c.orig 2009-04-11 21:58:56.000000000 +0200
++++ ARK/arkcplot.c 2009-04-11 22:00:06.000000000 +0200
+@@ -3472,7 +3472,7 @@
+ * no point in plotting blanks */
+
+ length = MIN( *n, non_z_length(text));
+- text[length] = (char) NULL;
++ text[length] = 0;
+ /* find length of string */
+ /* XQueryTextExtents(dpy, cur_font->fid, text, length,
+ &direction, &ascent, &descent, &overall); */
+@@ -3519,7 +3519,7 @@
+ * no point in plotting blanks */
+
+ length = MIN( *n, non_z_length(text));
+- text[length] = (char) NULL;
++ text[length] = 0;
+ /* find length of string */
+ /* XQueryTextExtents(dpy, cur_font->fid, text, length,
+ &direction, &ascent, &descent, &overall); */
+@@ -4376,7 +4376,7 @@
+ symbol_size symbol_size rlineto\n\
+ symbol_size neg_symbol_size rlineto\n\
+ neg_symbol_size neg_symbol_size rlineto\n\
+-neg_symbol_size symbol_size rlineto\n\
++neg_symbol_size symbol_size rlineto\n\
+ stroke\n} bind def\n");
+
+ fprintf(fp,
+@@ -5431,7 +5431,7 @@
+ slen = strlen(text);
+ for (i = 0; i < slen; i++){
+ if(text[i] == ']'){
+- text[i] = (char) NULL;
++ text[i] = 0;
+ break;
+ }
+ }
+@@ -5905,7 +5905,7 @@
+ slen = strlen(text);
+ for (i = 0; i < slen; i++){
+ if(text[i] == '}'){
+- text[i] = (char) NULL;
++ text[i] = 0;
+ break;
+ }
+ }
+@@ -6090,7 +6090,7 @@
+ char buff[2];
+
+ strncpy(buff, ch, 1);
+- buff[1] = (char) NULL;
++ buff[1] = 0;
+
+ if(cur_font == NULL){
+ printf("Robot ERROR: NULL font in chchk!!\n");
diff --git a/graphics/robot/files/patch-Robot+main.c b/graphics/robot/files/patch-Robot+main.c
index 1707e5ea22b0..ad741e5fd73b 100644
--- a/graphics/robot/files/patch-Robot+main.c
+++ b/graphics/robot/files/patch-Robot+main.c
@@ -1,5 +1,5 @@
---- Robot/main.c.orig Tue May 3 17:14:51 2005
-+++ Robot/main.c Wed Dec 28 17:02:15 2005
+--- Robot/main.c.orig 2005-05-03 17:14:51.000000000 +0200
++++ Robot/main.c 2009-04-11 21:57:57.000000000 +0200
@@ -561,19 +561,19 @@
|| streq(argv[i], "--help") ){
printf("Robot version %-1.2f patch %d\n\n",
@@ -33,3 +33,30 @@
fstop_();
}
+@@ -2130,7 +2130,7 @@
+ /* remove trailing blanks */
+ for (i = 0; i < strlen(instruction); i++){
+ if(instruction[i] == ' ')
+- instruction[i] = (char) NULL;}
++ instruction[i] = 0;}
+ activate(instruction);
+ }
+
+@@ -3063,7 +3063,7 @@
+
+
+ strncpy(direc, dir, *n);
+- direc[*n] = (char) NULL;
++ direc[*n] = 0;
+
+ /* null directory path is assumed to be cd to home */
+
+@@ -3915,7 +3915,7 @@
+ && strlen(sys_buffer) > 4)
+ sys_buffer[strlen(sys_buffer) - strlen(".rob")]
+
+- = (char) NULL;
++ = 0;
+
+ /* Only add a .ps if there isn't one there to start with */
+ if(!taileq(sys_buffer, ".ps")) strcat(sys_buffer, ".ps");
diff --git a/graphics/robot/files/patch-Robot+subroutines.f b/graphics/robot/files/patch-Robot+subroutines.f
index c3af831ce228..730a595830b5 100644
--- a/graphics/robot/files/patch-Robot+subroutines.f
+++ b/graphics/robot/files/patch-Robot+subroutines.f
@@ -1,6 +1,32 @@
---- Robot/subroutines.f~ Wed May 4 00:14:51 2005
-+++ Robot/subroutines.f Wed Jan 17 17:55:55 2007
-@@ -760,7 +760,7 @@
+--- Robot/subroutines.f.orig 2005-05-03 17:14:51.000000000 +0200
++++ Robot/subroutines.f 2009-04-11 21:54:31.000000000 +0200
+@@ -51,13 +51,15 @@
+ subroutine setchars()
+ include 'typecom'
+ include 'charcom'
++ CHARACTER :: tab
++ tab = '\t'
+
+ ispace = ichar(' ')
+ ibang = ichar('!')
+ ihash = ichar('#')
+ c itab = ichar(' ')
+ c some versions of g77 get this wrong so use different coding
+- itab = ichar('\t')
++ itab = ichar(tab)
+ ilb = ichar('(')
+ irb = ichar(')')
+ ilab = ichar('<')
+@@ -699,7 +701,7 @@
+ integer npts, ntime
+
+ if(npts .le. 2)then
+- write(tstring,'(a, i, a)')
++ write(tstring,'(a, i5, a)')
+ + '***There are only ',NPTS,' points in the data set***'
+ call totext(tstring)
+ call xtext('I will not smooth that few data points')
+@@ -760,7 +762,7 @@
if(nharm .lt. 0)then
write(tstring, *)hharm, ' harmonics specified'
call xtext(tstring)
diff --git a/graphics/robot/files/patch-Robot_fitter.c b/graphics/robot/files/patch-Robot_fitter.c
new file mode 100644
index 000000000000..69879e1e5299
--- /dev/null
+++ b/graphics/robot/files/patch-Robot_fitter.c
@@ -0,0 +1,11 @@
+--- Robot/fitter.c.orig 2009-04-11 22:10:28.000000000 +0200
++++ Robot/fitter.c 2009-04-11 22:10:41.000000000 +0200
+@@ -486,7 +486,7 @@
+ getamod_(&i, &length, temp_name);
+ strncpy(model_name, temp_name, length);
+
+- model_name[length] = (char) NULL;
++ model_name[length] = 0;
+
+
+ add_named_model(model_name);
diff --git a/graphics/robot/files/patch-Robot_history.c b/graphics/robot/files/patch-Robot_history.c
new file mode 100644
index 000000000000..31d81658e72a
--- /dev/null
+++ b/graphics/robot/files/patch-Robot_history.c
@@ -0,0 +1,29 @@
+--- Robot/history.c.orig 2009-04-11 22:11:08.000000000 +0200
++++ Robot/history.c 2009-04-11 22:11:30.000000000 +0200
+@@ -248,7 +248,7 @@
+ if (text[i] == '^') {
+ index = i;
+ strncpy(htext1, text + 1, index - 1);
+- htext1[index - 1] = (char) NULL;
++ htext1[index - 1] = 0;
+ break;
+ }
+ }
+@@ -258,7 +258,7 @@
+ }
+ strcpy(htext2, text + index + 1);
+ if (htext2[strlen(htext2) - 1] == '^') {
+- htext2[strlen(htext2) - 1] = (char) NULL;
++ htext2[strlen(htext2) - 1] = 0;
+ }
+ /* now try to find it in the previous string */
+ sprintf(htext3, "%s",
+@@ -271,7 +271,7 @@
+ /* think we found the string */
+ if (i > 0) {
+ strncpy(htext4, htext3, i);
+- htext4[i] = (char) NULL;
++ htext4[i] = 0;
+ }
+ else{
+ strcpy(htext4, "");
diff --git a/graphics/robot/files/patch-Robot_rfits.c b/graphics/robot/files/patch-Robot_rfits.c
new file mode 100644
index 000000000000..eac89651c8ef
--- /dev/null
+++ b/graphics/robot/files/patch-Robot_rfits.c
@@ -0,0 +1,10 @@
+--- Robot/rfitsc.c.orig 2009-04-11 22:08:21.000000000 +0200
++++ Robot/rfitsc.c 2009-04-11 22:09:22.000000000 +0200
+@@ -2,6 +2,7 @@
+ #include <fcntl.h>
+ #include <sys/file.h>
+ #include <unistd.h>
++#include <stdlib.h>
+
+ #define BLOCK 2880
+
diff --git a/graphics/robot/files/patch-Robot_subroutines3.f b/graphics/robot/files/patch-Robot_subroutines3.f
new file mode 100644
index 000000000000..577d223f21d2
--- /dev/null
+++ b/graphics/robot/files/patch-Robot_subroutines3.f
@@ -0,0 +1,11 @@
+--- Robot/subroutines3.f.orig 2009-04-11 21:56:19.000000000 +0200
++++ Robot/subroutines3.f 2009-04-11 21:56:43.000000000 +0200
+@@ -1608,7 +1608,7 @@
+ end if
+ return
+ C ERROR MESSAGES
+-992 write(tstring,'(a, i)')'ERROR: THERE IS TOO MUCH DATA IN UNIT', IFIL
++992 write(tstring,'(a, i5)')'ERROR: THERE IS TOO MUCH DATA IN UNIT', IFIL
+ call totext(tstring)
+ write(tstring,*)'A MAXIMUM OF',MSIZ,' POINTS IS ALLOWED'
+ call totext(tstring)
diff --git a/graphics/robot/pkg-plist b/graphics/robot/pkg-plist
index a4add66a2ac9..fb7ff7a97a02 100644
--- a/graphics/robot/pkg-plist
+++ b/graphics/robot/pkg-plist
@@ -1,22 +1,22 @@
bin/robot
lib/help/robot.info
%%PORTDOCS%%%%DOCSDIR%%/RobotManual.ps.gz
-%%PORTDOCS%%%%EXAMPLESDIR%%/3d_demo.rob
-%%PORTDOCS%%%%EXAMPLESDIR%%/anime_demo.rob
-%%PORTDOCS%%%%EXAMPLESDIR%%/axes_demo.rob
-%%PORTDOCS%%%%EXAMPLESDIR%%/color_demo.rob
-%%PORTDOCS%%%%EXAMPLESDIR%%/fit1_demo.rob
-%%PORTDOCS%%%%EXAMPLESDIR%%/fit1b_demo.rob
-%%PORTDOCS%%%%EXAMPLESDIR%%/fit2_demo.rob
-%%PORTDOCS%%%%EXAMPLESDIR%%/fit3_demo.rob
-%%PORTDOCS%%%%EXAMPLESDIR%%/font_demo.rob
-%%PORTDOCS%%%%EXAMPLESDIR%%/insert_demo.rob
-%%PORTDOCS%%%%EXAMPLESDIR%%/japan_demo.rob
-%%PORTDOCS%%%%EXAMPLESDIR%%/logplot_demo.rob
-%%PORTDOCS%%%%EXAMPLESDIR%%/mix_demo.rob
-%%PORTDOCS%%%%EXAMPLESDIR%%/simple_demo.rob
-%%PORTDOCS%%%%EXAMPLESDIR%%/sinplot_demo.rob
-%%PORTDOCS%%%%EXAMPLESDIR%%/style_demo.rob
-%%PORTDOCS%%%%EXAMPLESDIR%%/title_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/3d_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/anime_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/axes_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/color_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fit1_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fit1b_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fit2_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fit3_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/font_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/insert_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/japan_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/logplot_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mix_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sinplot_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/style_demo.rob
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/title_demo.rob
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%