aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-03-25 11:55:58 +0800
committermiwi <miwi@FreeBSD.org>2012-03-25 11:55:58 +0800
commitd580ba780da1fbb255743a1456c23da130bb5aca (patch)
treeb0dce2418acc85d78278b5274379088b07fec6d0 /graphics
parent7a2899a075c3523fb0cd72eb5246a75b7de3f0d5 (diff)
downloadfreebsd-ports-gnome-d580ba780da1fbb255743a1456c23da130bb5aca.tar.gz
freebsd-ports-gnome-d580ba780da1fbb255743a1456c23da130bb5aca.tar.zst
freebsd-ports-gnome-d580ba780da1fbb255743a1456c23da130bb5aca.zip
- Add LICENSE
- Add MAKE_JOBS_SAFE - Add PNG support PR: 166038 Submitted by: Ports Fury Feature safe: yes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/podofo/Makefile48
-rw-r--r--graphics/podofo/files/patch-CMakeLists.txt77
-rw-r--r--graphics/podofo/pkg-plist184
3 files changed, 189 insertions, 120 deletions
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
index 34f55df74606..f602733c3e46 100644
--- a/graphics/podofo/Makefile
+++ b/graphics/podofo/Makefile
@@ -7,44 +7,58 @@
PORTNAME= podofo
PORTVERSION= 0.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics print
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
MAINTAINER= ports@FreeBSD.org
COMMENT= PDF manipulation library and tools
+LICENSE= GPLv2 LGPL21
+LICENSE_COMB= multi
+
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
OPTIONS= JPEG "Enable JPEG support" on \
TIFF "Enable TIFF support" on \
+ PNG "Enable PNG support" on \
IMPOSE "Build impose tool (needs Lua)" off
USE_CMAKE= yes
-USE_LDCONFIG= yes
-CMAKE_ARGS+= -DPODOFO_BUILD_SHARED:BOOL=TRUE \
+CMAKE_ARGS= -DPODOFO_BUILD_SHARED:BOOL=TRUE \
-DPODOFO_BUILD_STATIC:BOOL=FALSE
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
-.include <bsd.port.pre.mk>
+MAN1= podofobox.1 podofocountpages.1 podofocrop.1 \
+ podofoencrypt.1 podofoimg2pdf.1 podofoimgextract.1 \
+ podofoimpose.1 podofoincrementalupdates.1 podofomerge.1 \
+ podofopages.1 podofopdfinfo.1 podofotxt2pdf.1 \
+ podofotxtextract.1 podofouncompress.1 podofoxmp.1
-MAN1= podofobox.1 podofoxmp.1 podofouncompress.1 podofomerge.1 \
- podofoimgextract.1 podofoimg2pdf.1 podofotxtextract.1 \
- podofoencrypt.1 podofocrop.1 podofopdfinfo.1 podofoimpose.1 \
- podofoincrementalupdates.1 podofocountpages.1 podofopages.1 \
- podofotxt2pdf.1
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_JPEG) || exists(${LOCALBASE}/lib/libjpeg.so)
-LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
+.if !defined(WITHOUT_JPEG)
+LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
+CMAKE_ARGS+= -DWANT_LIBJPEG:BOOL=TRUE
.endif
-.if !defined(WITHOUT_TIFF) || exists(${LOCALBASE}/lib/libtiff.so)
-LIB_DEPENDS+= tiff:${PORTSDIR}/graphics/tiff
+
+.if !defined(WITHOUT_TIFF)
+LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
+CMAKE_ARGS+= -DWANT_TIFF:BOOL=TRUE
.endif
-.if defined(WITH_IMPOSE) || exists(${LOCALBASE}/lib/lua51/liblua.so)
+
+.if !defined(WITHOUT_PNG)
+LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
+CMAKE_ARGS+= -DWANT_PNG:BOOL=TRUE
+.endif
+
+.if defined(WITH_IMPOSE)
USE_LUA= 5.1
+CMAKE_ARGS+= -DWANT_LUA:BOOL=TRUE
CPPFLAGS+= -I${LUA_INCDIR}
LDFLAGS+= -L${LUA_LIBDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/podofo/files/patch-CMakeLists.txt b/graphics/podofo/files/patch-CMakeLists.txt
index 1189f6af9847..b1913cf18fa2 100644
--- a/graphics/podofo/files/patch-CMakeLists.txt
+++ b/graphics/podofo/files/patch-CMakeLists.txt
@@ -1,6 +1,69 @@
---- CMakeLists.txt.orig 2011-04-26 20:02:47.000000000 +0200
-+++ CMakeLists.txt 2011-12-02 18:44:04.974966708 +0100
-@@ -485,7 +485,7 @@
+--- CMakeLists.txt.orig 2011-04-27 03:02:47.000000000 +0900
++++ CMakeLists.txt 2012-03-03 04:27:15.000000000 +0900
+@@ -309,6 +309,7 @@
+ FIND_PACKAGE(ZLIB REQUIRED)
+ MESSAGE("Found zlib headers in ${ZLIB_INCLUDE_DIR}, library at ${ZLIB_LIBRARIES}")
+
++IF(WANT_LIBJPEG)
+ FIND_PACKAGE(LIBJPEG)
+
+ IF(LIBJPEG_FOUND)
+@@ -318,7 +319,9 @@
+ ELSE(LIBJPEG_FOUND)
+ MESSAGE("Libjpeg not found. JPEG support will be disabled")
+ ENDIF(LIBJPEG_FOUND)
++ENDIF(WANT_LIBJPEG)
+
++IF(WANT_TIFF)
+ FIND_PACKAGE(TIFF)
+
+ IF(TIFF_FOUND)
+@@ -328,7 +331,9 @@
+ ELSE(TIFF_FOUND)
+ MESSAGE("Libtiff not found. TIFF support will be disabled")
+ ENDIF(TIFF_FOUND)
++ENDIF(WANT_TIFF)
+
++IF(WANT_PNG)
+ FIND_PACKAGE(PNG)
+
+ IF(PNG_FOUND)
+@@ -338,8 +343,10 @@
+ ELSE(PNG_FOUND)
+ MESSAGE("LibPng not found. PNG support will be disabled")
+ ENDIF(PNG_FOUND)
++ENDIF(WANT_PNG)
+
+
++IF(WANT_CppUnit)
+ FIND_PACKAGE(CppUnit)
+
+ IF(CppUnit_FOUND)
+@@ -348,6 +355,7 @@
+ ELSE(CppUnit_FOUND)
+ MESSAGE("Cppunit not found. No unit tests will be built.")
+ ENDIF(CppUnit_FOUND)
++ENDIF(WANT_CppUnit)
+
+ FIND_PACKAGE(OpenSSL)
+
+@@ -407,6 +415,7 @@
+ ENDIF(NOT WIN32)
+ ENDIF(DEFINED JPEG_RUNTIME_COMPATIBLE)
+
++IF(WANT_LUA)
+ FIND_PACKAGE(LUA)
+ IF(LUA_FOUND)
+ # If we have lua, we can build podofoimpose.
+@@ -418,6 +427,7 @@
+ ELSE(LUA_FOUND)
+ MESSAGE("Lua not found - PoDoFoImpose and PoDoFoColor will be built without Lua support")
+ ENDIF(LUA_FOUND)
++ENDIF(WANT_LUA)
+
+
+ # Check if we should build a multithreaded version of PoDoFo
+@@ -485,7 +495,7 @@
#
# Setup directories we will need
#
@@ -9,11 +72,3 @@
# Create the config file. It'll be appended to as the subdirs run though
# then dependency information will be written to it at the end of the
-@@ -503,7 +503,6 @@
- IF(NOT PODOFO_BUILD_LIB_ONLY)
- ADD_SUBDIRECTORY(test)
- ADD_SUBDIRECTORY(tools)
--ADD_SUBDIRECTORY(examples)
- ADD_SUBDIRECTORY(debian)
- ENDIF(NOT PODOFO_BUILD_LIB_ONLY)
-
diff --git a/graphics/podofo/pkg-plist b/graphics/podofo/pkg-plist
index 97b4b54b8bd0..aa483ddea87c 100644
--- a/graphics/podofo/pkg-plist
+++ b/graphics/podofo/pkg-plist
@@ -15,111 +15,111 @@ bin/podofotxt2pdf
bin/podofotxtextract
bin/podofouncompress
bin/podofoxmp
-include/podofo/doc/PdfDifferenceEncoding.h
-include/podofo/doc/PdfFontTTFSubset.h
-include/podofo/doc/PdfFontFactoryBase14Data.h
-include/podofo/doc/PdfAnnotation.h
-include/podofo/doc/PdfHintStream.h
-include/podofo/doc/PdfFunction.h
-include/podofo/doc/PdfXObject.h
-include/podofo/doc/PdfInfo.h
-include/podofo/doc/PdfPagesTreeCache.h
-include/podofo/doc/PdfFontFactory.h
-include/podofo/doc/PdfImage.h
-include/podofo/doc/PdfFileSpec.h
-include/podofo/doc/PdfDestination.h
-include/podofo/doc/PdfEncodingObjectFactory.h
-include/podofo/doc/PdfSignOutputDevice.h
-include/podofo/doc/PdfShadingPattern.h
-include/podofo/doc/PdfDocument.h
-include/podofo/doc/PdfIdentityEncoding.h
-include/podofo/doc/PdfField.h
-include/podofo/doc/PdfFontCache.h
-include/podofo/doc/PdfPage.h
-include/podofo/doc/PdfNamesTree.h
-include/podofo/doc/PdfPagesTree.h
-include/podofo/doc/PdfAcroForm.h
-include/podofo/doc/PdfFontMetricsObject.h
-include/podofo/doc/PdfFontMetrics.h
-include/podofo/doc/PdfPainterMM.h
-include/podofo/doc/PdfTable.h
-include/podofo/doc/PdfSignatureField.h
-include/podofo/doc/PdfElement.h
-include/podofo/doc/PdfFontCID.h
-include/podofo/doc/PdfFontTrueType.h
-include/podofo/doc/PdfOutlines.h
-include/podofo/doc/PdfFontMetricsBase14.h
-include/podofo/doc/PdfFontType1Base14.h
-include/podofo/doc/PdfExtGState.h
-include/podofo/doc/PdfFontMetricsFreetype.h
-include/podofo/doc/PdfStreamedDocument.h
-include/podofo/doc/PdfFont.h
-include/podofo/doc/PdfFontType1.h
-include/podofo/doc/PdfFontSimple.h
-include/podofo/doc/PdfAction.h
-include/podofo/doc/PdfMemDocument.h
-include/podofo/doc/PdfContents.h
-include/podofo/doc/PdfPainter.h
+include/podofo/base/Pdf3rdPtyForwardDecl.h
+include/podofo/base/PdfArray.h
+include/podofo/base/PdfCanvas.h
+include/podofo/base/PdfColor.h
+include/podofo/base/PdfCompilerCompat.h
include/podofo/base/PdfCompilerCompatPrivate.h
-include/podofo/base/PdfFiltersPrivate.h
-include/podofo/base/PdfOutputDevice.h
-include/podofo/base/PdfRect.h
-include/podofo/base/PdfObject.h
+include/podofo/base/PdfContentsTokenizer.h
+include/podofo/base/PdfData.h
+include/podofo/base/PdfDataType.h
+include/podofo/base/PdfDate.h
+include/podofo/base/PdfDefines.h
+include/podofo/base/PdfDefinesPrivate.h
+include/podofo/base/PdfDictionary.h
+include/podofo/base/PdfEncoding.h
include/podofo/base/PdfEncodingFactory.h
include/podofo/base/PdfEncrypt.h
-include/podofo/base/PdfWriter.h
include/podofo/base/PdfError.h
-include/podofo/base/PdfArray.h
-include/podofo/base/PdfMemoryManagement.h
+include/podofo/base/PdfFileStream.h
+include/podofo/base/PdfFilter.h
+include/podofo/base/PdfFiltersPrivate.h
+include/podofo/base/PdfImmediateWriter.h
+include/podofo/base/PdfInputDevice.h
+include/podofo/base/PdfInputStream.h
include/podofo/base/PdfLocale.h
-include/podofo/base/PdfCompilerCompat.h
+include/podofo/base/PdfMemStream.h
+include/podofo/base/PdfMemoryManagement.h
+include/podofo/base/PdfName.h
+include/podofo/base/PdfObject.h
+include/podofo/base/PdfObjectStreamParserObject.h
+include/podofo/base/PdfOutputDevice.h
include/podofo/base/PdfOutputStream.h
-include/podofo/base/PdfColor.h
-include/podofo/base/PdfContentsTokenizer.h
-include/podofo/base/PdfFilter.h
-include/podofo/base/PdfDefines.h
-include/podofo/base/podofo_config.h
-include/podofo/base/PdfTokenizer.h
-include/podofo/base/podofoapi.h
-include/podofo/base/PdfVecObjects.h
+include/podofo/base/PdfParser.h
+include/podofo/base/PdfParserObject.h
+include/podofo/base/PdfRect.h
include/podofo/base/PdfRefCountedBuffer.h
-include/podofo/base/PdfData.h
+include/podofo/base/PdfRefCountedInputDevice.h
include/podofo/base/PdfReference.h
-include/podofo/base/PdfXRef.h
-include/podofo/base/PdfCanvas.h
-include/podofo/base/PdfObjectStreamParserObject.h
-include/podofo/base/PdfDate.h
-include/podofo/base/PdfInputDevice.h
-include/podofo/base/PdfDataType.h
+include/podofo/base/PdfRijndael.h
+include/podofo/base/PdfStream.h
+include/podofo/base/PdfString.h
+include/podofo/base/PdfTokenizer.h
+include/podofo/base/PdfVariant.h
+include/podofo/base/PdfVecObjects.h
include/podofo/base/PdfVersion.h
-include/podofo/base/PdfXRefStreamParserObject.h
-include/podofo/base/PdfImmediateWriter.h
-include/podofo/base/PdfDictionary.h
-include/podofo/base/PdfParser.h
+include/podofo/base/PdfWriter.h
+include/podofo/base/PdfXRef.h
include/podofo/base/PdfXRefStream.h
-include/podofo/base/PdfDefinesPrivate.h
-include/podofo/base/util/PdfMutexWrapper.h
-include/podofo/base/util/PdfMutexImpl_win32.h
-include/podofo/base/util/PdfMutexImpl_pthread.h
-include/podofo/base/util/PdfMutexImpl_noop.h
+include/podofo/base/PdfXRefStreamParserObject.h
+include/podofo/base/podofo_config.h
+include/podofo/base/podofoapi.h
include/podofo/base/util/PdfMutex.h
-include/podofo/base/PdfName.h
-include/podofo/base/Pdf3rdPtyForwardDecl.h
-include/podofo/base/PdfRefCountedInputDevice.h
-include/podofo/base/PdfInputStream.h
-include/podofo/base/PdfString.h
-include/podofo/base/PdfVariant.h
-include/podofo/base/PdfEncoding.h
-include/podofo/base/PdfParserObject.h
-include/podofo/base/PdfRijndael.h
-include/podofo/base/PdfMemStream.h
-include/podofo/base/PdfFileStream.h
-include/podofo/base/PdfStream.h
-include/podofo/podofo.h
+include/podofo/base/util/PdfMutexImpl_noop.h
+include/podofo/base/util/PdfMutexImpl_pthread.h
+include/podofo/base/util/PdfMutexImpl_win32.h
+include/podofo/base/util/PdfMutexWrapper.h
+include/podofo/doc/PdfAcroForm.h
+include/podofo/doc/PdfAction.h
+include/podofo/doc/PdfAnnotation.h
+include/podofo/doc/PdfContents.h
+include/podofo/doc/PdfDestination.h
+include/podofo/doc/PdfDifferenceEncoding.h
+include/podofo/doc/PdfDocument.h
+include/podofo/doc/PdfElement.h
+include/podofo/doc/PdfEncodingObjectFactory.h
+include/podofo/doc/PdfExtGState.h
+include/podofo/doc/PdfField.h
+include/podofo/doc/PdfFileSpec.h
+include/podofo/doc/PdfFont.h
+include/podofo/doc/PdfFontCID.h
+include/podofo/doc/PdfFontCache.h
+include/podofo/doc/PdfFontFactory.h
+include/podofo/doc/PdfFontFactoryBase14Data.h
+include/podofo/doc/PdfFontMetrics.h
+include/podofo/doc/PdfFontMetricsBase14.h
+include/podofo/doc/PdfFontMetricsFreetype.h
+include/podofo/doc/PdfFontMetricsObject.h
+include/podofo/doc/PdfFontSimple.h
+include/podofo/doc/PdfFontTTFSubset.h
+include/podofo/doc/PdfFontTrueType.h
+include/podofo/doc/PdfFontType1.h
+include/podofo/doc/PdfFontType1Base14.h
+include/podofo/doc/PdfFunction.h
+include/podofo/doc/PdfHintStream.h
+include/podofo/doc/PdfIdentityEncoding.h
+include/podofo/doc/PdfImage.h
+include/podofo/doc/PdfInfo.h
+include/podofo/doc/PdfMemDocument.h
+include/podofo/doc/PdfNamesTree.h
+include/podofo/doc/PdfOutlines.h
+include/podofo/doc/PdfPage.h
+include/podofo/doc/PdfPagesTree.h
+include/podofo/doc/PdfPagesTreeCache.h
+include/podofo/doc/PdfPainter.h
+include/podofo/doc/PdfPainterMM.h
+include/podofo/doc/PdfShadingPattern.h
+include/podofo/doc/PdfSignOutputDevice.h
+include/podofo/doc/PdfSignatureField.h
+include/podofo/doc/PdfStreamedDocument.h
+include/podofo/doc/PdfTable.h
+include/podofo/doc/PdfXObject.h
include/podofo/podofo-base.h
-lib/libpodofo.so.0
+include/podofo/podofo.h
lib/libpodofo.so
+lib/libpodofo.so.0
+@dirrm include/podofo/doc
@dirrm include/podofo/base/util
@dirrm include/podofo/base
-@dirrm include/podofo/doc
@dirrm include/podofo