aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-08-13 00:00:47 +0800
committerarved <arved@FreeBSD.org>2004-08-13 00:00:47 +0800
commitd647677211fba54e6f0b392f5607ae7d8c85b98f (patch)
treeac8060f9c34839635d5cf79a32170d93807e965a /graphics
parent1a26d29c753f76ba0f74661edb6650ca3a7001e4 (diff)
downloadfreebsd-ports-gnome-d647677211fba54e6f0b392f5607ae7d8c85b98f.tar.gz
freebsd-ports-gnome-d647677211fba54e6f0b392f5607ae7d8c85b98f.tar.zst
freebsd-ports-gnome-d647677211fba54e6f0b392f5607ae7d8c85b98f.zip
Add p5-Graph-ReadWrite, reads and writes various graph formats
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-Graph-ReadWrite/Makefile29
-rw-r--r--graphics/p5-Graph-ReadWrite/distinfo2
-rw-r--r--graphics/p5-Graph-ReadWrite/pkg-descr6
-rw-r--r--graphics/p5-Graph-ReadWrite/pkg-plist14
5 files changed, 52 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 2ac2c7c8165b..870560ea23a1 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -302,6 +302,7 @@
SUBDIR += p5-GD-Graph
SUBDIR += p5-GD-Graph3d
SUBDIR += p5-GD-TextUtil
+ SUBDIR += p5-Graph-ReadWrite
SUBDIR += p5-GraphViz
SUBDIR += p5-GraphViz-Data-Structure
SUBDIR += p5-Graphics-ColorNames
diff --git a/graphics/p5-Graph-ReadWrite/Makefile b/graphics/p5-Graph-ReadWrite/Makefile
new file mode 100644
index 000000000000..c6163fd17285
--- /dev/null
+++ b/graphics/p5-Graph-ReadWrite/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Graph-ReadWrite
+# Date created: 2004-08-12
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= Graph-ReadWrite
+PORTVERSION= 1.07
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Graph
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Reading and Writing a variety of graph file formats
+
+BUILD_DEPENDS= ${SITE_PERL}/Graph/Base.pm:${PORTSDIR}/math/p5-Graph \
+ ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ ${SITE_PERL}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Graph::Reader.3 Graph::Writer::HTK.3 Graph::Writer::daVinci.3 \
+ Graph::Writer::XML.3 Graph::Writer::Dot.3 Graph::Reader::HTK.3 \
+ Graph::Reader::XML.3 Graph::Writer::VCG.3 Graph::Reader::Dot.3 \
+ Graph::Writer.3
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Graph-ReadWrite/distinfo b/graphics/p5-Graph-ReadWrite/distinfo
new file mode 100644
index 000000000000..3005885daabe
--- /dev/null
+++ b/graphics/p5-Graph-ReadWrite/distinfo
@@ -0,0 +1,2 @@
+MD5 (Graph-ReadWrite-1.07.tar.gz) = 2817c72f8157b837b1b3c28a8cbb5b55
+SIZE (Graph-ReadWrite-1.07.tar.gz) = 22335
diff --git a/graphics/p5-Graph-ReadWrite/pkg-descr b/graphics/p5-Graph-ReadWrite/pkg-descr
new file mode 100644
index 000000000000..8a8a588fdb8e
--- /dev/null
+++ b/graphics/p5-Graph-ReadWrite/pkg-descr
@@ -0,0 +1,6 @@
+This is a collection of perl classes for reading and writing
+directed graphs in a variety of file formats. The graphs are
+represented in Perl using Jarkko Hietaniemi's Graph classes.
+
+Author: Neil Bowers <neil@bowers.com>
+WWW: http://search.cpan.org/~neilb/Graph-ReadWrite/
diff --git a/graphics/p5-Graph-ReadWrite/pkg-plist b/graphics/p5-Graph-ReadWrite/pkg-plist
new file mode 100644
index 000000000000..6a45e26aa349
--- /dev/null
+++ b/graphics/p5-Graph-ReadWrite/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/Graph/Reader.pm
+%%SITE_PERL%%/Graph/Writer.pm
+%%SITE_PERL%%/Graph/Reader/HTK.pm
+%%SITE_PERL%%/Graph/Reader/XML.pm
+%%SITE_PERL%%/Graph/Reader/Dot.pm
+%%SITE_PERL%%/Graph/Writer/HTK.pm
+%%SITE_PERL%%/Graph/Writer/daVinci.pm
+%%SITE_PERL%%/Graph/Writer/XML.pm
+%%SITE_PERL%%/Graph/Writer/Dot.pm
+%%SITE_PERL%%/Graph/Writer/VCG.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graph-ReadWrite/.packlist
+@dirrm %%SITE_PERL%%/Graph/Reader/
+@dirrm %%SITE_PERL%%/Graph/Writer/
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Graph-ReadWrite