aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2012-12-18 21:28:14 +0800
committerjhale <jhale@FreeBSD.org>2012-12-18 21:28:14 +0800
commitdd221d63be7f2c642d62c872f0227edbba1df1ff (patch)
treecfb1726429d10e8b146ae5360ed3a72227c6f7da /graphics
parentbcc0d26896cf3287346a06a684c4789d3fd216dc (diff)
downloadfreebsd-ports-gnome-dd221d63be7f2c642d62c872f0227edbba1df1ff.tar.gz
freebsd-ports-gnome-dd221d63be7f2c642d62c872f0227edbba1df1ff.tar.zst
freebsd-ports-gnome-dd221d63be7f2c642d62c872f0227edbba1df1ff.zip
- USE_DOS2UNIX and remove ^M from patches
- Use PORTDOCS macro; don't install useless Install.txt or redundant license.txt - Bump PORTREVISION since installed files have changed - Improve COMMENT - Simplify do-install target - Convert to new options framework - Whitespace cleanup - Add additional WWW - Pass maintainership to submitter PR: ports/173537 Submitted by: nemysis <nemysis@gmx.ch>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/autoq3d/Makefile43
-rw-r--r--graphics/autoq3d/files/patch-AutoQ3D.pro20
-rw-r--r--graphics/autoq3d/files/patch-src__cmds__cmds.cpp30
-rw-r--r--graphics/autoq3d/files/patch-src__fgui__cadform.cpp48
-rw-r--r--graphics/autoq3d/files/patch-src__fgui__glapparea.cpp21
-rw-r--r--graphics/autoq3d/pkg-descr1
-rw-r--r--graphics/autoq3d/pkg-plist5
7 files changed, 79 insertions, 89 deletions
diff --git a/graphics/autoq3d/Makefile b/graphics/autoq3d/Makefile
index fe49e0469349..375b392e9196 100644
--- a/graphics/autoq3d/Makefile
+++ b/graphics/autoq3d/Makefile
@@ -1,36 +1,36 @@
-# New ports collection makefile for: autoq3d
-# Date created: 28 Jul 2007
-# Whom: Yinghong.Liu <relaxbsd@gmail.com>
-#
+# Created by: Yinghong.Liu <relaxbsd@gmail.com>
# $FreeBSD$
-#
PORTNAME= autoq3d
-DISTVERSION= 1.40
-PORTREVISION= 2
+PORTVERSION= 1.40
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/AutoQ3D%20${PORTVERSION}
DISTNAME= AutoQ3DCommunity${PORTVERSION:C/\./-/}qt4source
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Complete QT quick 3D model editor program
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Qt4 quick 3D model editor
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
+USE_DOS2UNIX= yes
USE_GL= glu
USE_ZIP= yes
USE_QT4= corelib gui opengl \
moc_build qmake_build
MAKE_JOBS_SAFE= yes
-DESKTOP_ENTRIES= "AutoQ3D" \
- "A complete QT quick 3d model editor program" \
- "AutoQ3D" \
- "AutoQ3D" \
- "Qt;KDE;Graphics;" \
- "false"
+PORTDOCS= 3DQformat.txt ChangeLog.txt
+DESKTOP_ENTRIES="AutoQ3D" \
+ "${COMMENT}" \
+ "AutoQ3D" \
+ "AutoQ3D" \
+ "Qt;KDE;Graphics;" \
+ false
+
+.include <bsd.port.options.mk>
post-patch:
.for file in src/main.cpp src/fgui/cadform.cpp src/dialogs/prgsettings.cpp
@${REINPLACE_CMD} -e \
@@ -38,20 +38,15 @@ post-patch:
.endfor
do-configure:
- @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS})
+ @(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS})
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/AutoQ3D ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/*.htm ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/*.qm ${DATADIR}
- @${MKDIR} ${DATADIR}/images
- ${INSTALL_DATA} ${WRKSRC}/images/*.png ${DATADIR}/images
- @${MKDIR} ${PREFIX}/share/pixmaps
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "images *.htm *.qm" ${DATADIR})
${INSTALL_DATA} ${WRKSRC}/AutoQ3D.png ${PREFIX}/share/pixmaps
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/*.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/graphics/autoq3d/files/patch-AutoQ3D.pro b/graphics/autoq3d/files/patch-AutoQ3D.pro
index d2e6e510229d..942b031fd272 100644
--- a/graphics/autoq3d/files/patch-AutoQ3D.pro
+++ b/graphics/autoq3d/files/patch-AutoQ3D.pro
@@ -1,10 +1,10 @@
---- AutoQ3D.pro~ 2012-05-19 22:52:00.000000000 -0300
-+++ AutoQ3D.pro 2012-05-19 22:56:52.000000000 -0300
-@@ -8,6 +8,7 @@
- win32:LIBS+= -L$(QTDIR)/plugins/imageformats -lqjpeg4
-
- QT += opengl
-+LIBS += -lGLU
- DEPENDPATH += . \
- src \
- src/cmds \
+--- ./AutoQ3D.pro.orig 2012-12-02 18:48:47.000000000 -0500
++++ ./AutoQ3D.pro 2012-12-02 18:48:47.000000000 -0500
+@@ -8,6 +8,7 @@
+ win32:LIBS+= -L$(QTDIR)/plugins/imageformats -lqjpeg4
+
+ QT += opengl
++LIBS += -lGLU
+ DEPENDPATH += . \
+ src \
+ src/cmds \
diff --git a/graphics/autoq3d/files/patch-src__cmds__cmds.cpp b/graphics/autoq3d/files/patch-src__cmds__cmds.cpp
index cfd790860944..44d75cac7ca2 100644
--- a/graphics/autoq3d/files/patch-src__cmds__cmds.cpp
+++ b/graphics/autoq3d/files/patch-src__cmds__cmds.cpp
@@ -1,15 +1,15 @@
---- src/cmds/cmds.cpp~ 2012-05-19 22:44:14.000000000 -0300
-+++ src/cmds/cmds.cpp 2012-05-19 22:44:25.000000000 -0300
-@@ -89,9 +89,9 @@
-
-
- QPalette newPalette = QPalette();
-- newPalette.setColor(QPalette::Background, QColor::QColor(170,170,255));
-- newPalette.setColor(QPalette::Foreground, QColor::QColor(0,0,0));
-- newPalette.setColor(QPalette::Base, QColor::QColor(170,170,255));
-+ newPalette.setColor(QPalette::Background, QColor(170,170,255));
-+ newPalette.setColor(QPalette::Foreground, QColor(0,0,0));
-+ newPalette.setColor(QPalette::Base, QColor(170,170,255));
-
- setPalette(newPalette);
-
+--- ./src/cmds/cmds.cpp.orig 2012-12-02 18:48:47.000000000 -0500
++++ ./src/cmds/cmds.cpp 2012-12-02 18:54:38.000000000 -0500
+@@ -89,9 +89,9 @@
+
+
+ QPalette newPalette = QPalette();
+- newPalette.setColor(QPalette::Background, QColor::QColor(170,170,255));
+- newPalette.setColor(QPalette::Foreground, QColor::QColor(0,0,0));
+- newPalette.setColor(QPalette::Base, QColor::QColor(170,170,255));
++ newPalette.setColor(QPalette::Background, QColor(170,170,255));
++ newPalette.setColor(QPalette::Foreground, QColor(0,0,0));
++ newPalette.setColor(QPalette::Base, QColor(170,170,255));
+
+ setPalette(newPalette);
+
diff --git a/graphics/autoq3d/files/patch-src__fgui__cadform.cpp b/graphics/autoq3d/files/patch-src__fgui__cadform.cpp
index 41676125a38c..59266b9ccf8a 100644
--- a/graphics/autoq3d/files/patch-src__fgui__cadform.cpp
+++ b/graphics/autoq3d/files/patch-src__fgui__cadform.cpp
@@ -1,24 +1,24 @@
---- src/fgui/cadform.cpp~ 2012-05-19 22:45:11.000000000 -0300
-+++ src/fgui/cadform.cpp 2012-05-19 22:46:08.000000000 -0300
-@@ -475,9 +475,9 @@
-
-
- QPalette newPalette = palette();
-- newPalette.setColor(QPalette::Background, QColor::QColor(170,170,255));
-- newPalette.setColor(QPalette::Foreground, QColor::QColor(0,0,0));
-- newPalette.setColor(QPalette::Base, QColor::QColor(170,170,255));
-+ newPalette.setColor(QPalette::Background, QColor(170,170,255));
-+ newPalette.setColor(QPalette::Foreground, QColor(0,0,0));
-+ newPalette.setColor(QPalette::Base, QColor(170,170,255));
-
-
-
-@@ -800,7 +800,7 @@
- w->GLThisArea->cscalari=hcmd->cscalari;
- w->GLThisArea->View=View;
-
-- w->setWindowTitle(QString::QString(tr("ViewPort-%1")).arg(numDoc++));w->setWindowIcon( QPixmap(ProgramPath+"images/document.png") );
-+ w->setWindowTitle(QString(tr("ViewPort-%1")).arg(numDoc++));w->setWindowIcon( QPixmap(ProgramPath+"images/document.png") );
- w->show();
- QWidgetList windoL=ws->windowList(QWorkspace::CreationOrder);
- if ( windoL.count()==1){
+--- ./src/fgui/cadform.cpp.orig 2012-12-02 18:48:47.000000000 -0500
++++ ./src/fgui/cadform.cpp 2012-12-02 18:51:14.000000000 -0500
+@@ -475,9 +475,9 @@
+
+
+ QPalette newPalette = palette();
+- newPalette.setColor(QPalette::Background, QColor::QColor(170,170,255));
+- newPalette.setColor(QPalette::Foreground, QColor::QColor(0,0,0));
+- newPalette.setColor(QPalette::Base, QColor::QColor(170,170,255));
++ newPalette.setColor(QPalette::Background, QColor(170,170,255));
++ newPalette.setColor(QPalette::Foreground, QColor(0,0,0));
++ newPalette.setColor(QPalette::Base, QColor(170,170,255));
+
+
+
+@@ -800,7 +800,7 @@
+ w->GLThisArea->cscalari=hcmd->cscalari;
+ w->GLThisArea->View=View;
+
+- w->setWindowTitle(QString::QString(tr("ViewPort-%1")).arg(numDoc++));w->setWindowIcon( QPixmap(ProgramPath+"images/document.png") );
++ w->setWindowTitle(QString(tr("ViewPort-%1")).arg(numDoc++));w->setWindowIcon( QPixmap(ProgramPath+"images/document.png") );
+ w->show();
+ QWidgetList windoL=ws->windowList(QWorkspace::CreationOrder);
+ if ( windoL.count()==1){
diff --git a/graphics/autoq3d/files/patch-src__fgui__glapparea.cpp b/graphics/autoq3d/files/patch-src__fgui__glapparea.cpp
index 50ca56b1787e..e6907fc87cbc 100644
--- a/graphics/autoq3d/files/patch-src__fgui__glapparea.cpp
+++ b/graphics/autoq3d/files/patch-src__fgui__glapparea.cpp
@@ -1,11 +1,10 @@
---- src/fgui/glapparea.cpp~ 2012-05-19 22:54:35.000000000 -0300
-+++ src/fgui/glapparea.cpp 2012-05-19 22:54:50.000000000 -0300
-@@ -24,6 +24,8 @@
- #include <qtimer.h>
- #include <math.h>
-
-+#include <GL/glu.h>
-+
-
- GLAppArea::GLAppArea( QWidget* parent,QStringList* strlista)
- : QGLWidget( parent)
+--- ./src/fgui/glapparea.cpp.orig 2012-12-02 18:48:47.000000000 -0500
++++ ./src/fgui/glapparea.cpp 2012-12-02 18:58:20.000000000 -0500
+@@ -23,6 +23,7 @@
+ #include <qimage.h>
+ #include <qtimer.h>
+ #include <math.h>
++#include <GL/glu.h>
+
+
+ GLAppArea::GLAppArea( QWidget* parent,QStringList* strlista)
diff --git a/graphics/autoq3d/pkg-descr b/graphics/autoq3d/pkg-descr
index f7b525e26d81..d82a2eaa4712 100644
--- a/graphics/autoq3d/pkg-descr
+++ b/graphics/autoq3d/pkg-descr
@@ -2,3 +2,4 @@ AutoQ3D Community is the open source software project of
this 3D modeling application.
WWW: http://www.autoq3d.com/
+ http://sourceforge.net/projects/autoq3d/
diff --git a/graphics/autoq3d/pkg-plist b/graphics/autoq3d/pkg-plist
index 3d64b78ee85f..03f1248b5acb 100644
--- a/graphics/autoq3d/pkg-plist
+++ b/graphics/autoq3d/pkg-plist
@@ -52,11 +52,6 @@ bin/AutoQ3D
%%DATADIR%%/lan_sp.qm
%%DATADIR%%/qref.htm
%%DATADIR%%/qref_sp.htm
-%%PORTDOCS%%%%DOCSDIR%%/3DQformat.txt
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.txt
-%%PORTDOCS%%%%DOCSDIR%%/Install.txt
-%%PORTDOCS%%%%DOCSDIR%%/license.txt
share/pixmaps/AutoQ3D.png
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%