aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2011-06-22 03:20:02 +0800
committerjohans <johans@FreeBSD.org>2011-06-22 03:20:02 +0800
commitdd8af96ddf4aa943d71a0f2cee7a5e4e0f1c1a31 (patch)
treecd2a9579e6c852b3c9b18b0dd6b1beb487c0e7ed /graphics
parentdf787d18c1199e8708c1a5f2a9c0e5fba4c73d1b (diff)
downloadfreebsd-ports-gnome-dd8af96ddf4aa943d71a0f2cee7a5e4e0f1c1a31.tar.gz
freebsd-ports-gnome-dd8af96ddf4aa943d71a0f2cee7a5e4e0f1c1a31.tar.zst
freebsd-ports-gnome-dd8af96ddf4aa943d71a0f2cee7a5e4e0f1c1a31.zip
Fix C error (missing return value). Fixes compilation with clang.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/xpaint/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/graphics/xpaint/Makefile b/graphics/xpaint/Makefile
index b597e2d55201..8d4e060edbba 100644
--- a/graphics/xpaint/Makefile
+++ b/graphics/xpaint/Makefile
@@ -33,6 +33,8 @@ post-patch:
's|@PREFIX@|${PREFIX}|g ; \
s|@XPMDIR@|${LOCALBASE}|g ; \
s|@LOCALBASE@|${LOCALBASE}|g' ${WRKSRC}/Local.config
+ @${REINPLACE_CMD} -e '/if (!image)/s/return;/return -1;/' \
+ ${WRKSRC}/rw/readWriteTGA.c
pre-configure:
@cd ${WRKSRC} && ${SH} ./configure xaw3dxft.a