aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-07-10 10:28:51 +0800
committerdanfe <danfe@FreeBSD.org>2013-07-10 10:28:51 +0800
commitdf95a0e603fcb60a1b745db00c22a08d1ce09a03 (patch)
tree233163e30a3bdaee86989aaa95b2cc5907e9336a /graphics
parent93d49c10171e4e8476cfaf579fd939595ad97476 (diff)
downloadfreebsd-ports-gnome-df95a0e603fcb60a1b745db00c22a08d1ce09a03.tar.gz
freebsd-ports-gnome-df95a0e603fcb60a1b745db00c22a08d1ce09a03.tar.zst
freebsd-ports-gnome-df95a0e603fcb60a1b745db00c22a08d1ce09a03.zip
- Drop the article from COMMENT line
- Define LICENSE (GPLv2) - Convert USE_GMAKE to USES (gmake) - Drop MAKE_JOBS_SAFE, it will soon be the default - Provide better description for AALIB option - Do not conditionally depend on graphics/jpeg; does not make sense as libgphoto2 always depends on it - Convert two ${PORT_OPTIONS:M...} into smart syntax - Do not use .for loop when installing just one file
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gphoto2/Makefile42
1 files changed, 17 insertions, 25 deletions
diff --git a/graphics/gphoto2/Makefile b/graphics/gphoto2/Makefile
index f50b7da60bf4..6fea07c9c9ee 100644
--- a/graphics/gphoto2/Makefile
+++ b/graphics/gphoto2/Makefile
@@ -7,53 +7,45 @@ CATEGORIES= graphics
MASTER_SITES= SF/gphoto/gphoto/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A command-line frontend to libgphoto2
+COMMENT= Command-line frontend to libgphoto2
+
+LICENSE= GPLv2
LIB_DEPENDS= popt:${PORTSDIR}/devel/popt \
gphoto2:${PORTSDIR}/graphics/libgphoto2
-USES= pkgconfig
+USES= gmake pkgconfig
USE_BZIP2= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-cdk
-MAKE_JOBS_SAFE= yes
-
-MAN1= gphoto2.1
+# XXX: do we still need to pass PTHREAD_* stuff here?
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+MAN1= ${PORTNAME}.1
+
OPTIONS_DEFINE= AALIB DOCS NLS
OPTIONS_DEFAULT= AALIB
-AALIB_DESC= Command line capture preview (aalib)
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
+AALIB_DESC= Text mode capture preview support
-.if ${PORT_OPTIONS:MAALIB}
-LIB_DEPENDS+= aa:${PORTSDIR}/graphics/aalib \
- jpeg:${PORTSDIR}/graphics/jpeg
-.else
-CONFIGURE_ARGS+=--without-aalib --without-jpeg
-.endif
+AALIB_LIB_DEPENDS= aa:${PORTSDIR}/graphics/aalib
+AALIB_CONFIGURE_ARGS= --without-aalib
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+NLS_USES= gettext
+NLS_CONFIGURE_OFF= --disable-nls
+
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREADS_LIBS:S/"//g}|g ; \
- s|-g -Wall||g' ${WRKSRC}/configure
+ s|-g -Wall||g' ${WRKSRC}/configure
post-install:
.if ${PORT_OPTIONS:MDOCS}
-.for file in NEWS
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${DOCSDIR}
.endif
.include <bsd.port.mk>