aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-02-02 02:06:53 +0800
committerpav <pav@FreeBSD.org>2004-02-02 02:06:53 +0800
commitec1ccec80a5db69858a776a30a257a80f2e031d2 (patch)
tree9876838cd053af6692c782be5b02056a75542987 /graphics
parent77f9161c256e2fba6188e1f272508689ad0cbb2e (diff)
downloadfreebsd-ports-gnome-ec1ccec80a5db69858a776a30a257a80f2e031d2.tar.gz
freebsd-ports-gnome-ec1ccec80a5db69858a776a30a257a80f2e031d2.tar.zst
freebsd-ports-gnome-ec1ccec80a5db69858a776a30a257a80f2e031d2.zip
- Update to 0.5.0
PR: ports/62159 Submitted by: Ports Fury
Diffstat (limited to 'graphics')
-rw-r--r--graphics/osgedit/Makefile21
-rw-r--r--graphics/osgedit/distinfo4
-rw-r--r--graphics/osgedit/files/patch-Makefile.in28
-rw-r--r--graphics/osgedit/files/patch-po::Makefile.in.in11
-rw-r--r--graphics/osgedit/files/patch-src::editable::entities::edgeode.cc8
5 files changed, 24 insertions, 48 deletions
diff --git a/graphics/osgedit/Makefile b/graphics/osgedit/Makefile
index 0d0bb3eeb001..00d0a3dda81d 100644
--- a/graphics/osgedit/Makefile
+++ b/graphics/osgedit/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= osgedit
-PORTVERSION= 0.4.1
+PORTVERSION= 0.5.0
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,16 +16,23 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An open editor for an open scenegraph
BUILD_DEPENDS= ${X11BASE}/lib/libosg.so:${PORTSDIR}/graphics/osg
-LIB_DEPENDS= gtkgl-2.0.1:${PORTSDIR}/x11-toolkits/gtkglarea2 \
- intl.5:${PORTSDIR}/devel/gettext-old \
- iconv.3:${PORTSDIR}/converters/libiconv
+LIB_DEPENDS= gtkglext-x11-1.0.2:${PORTSDIR}/x11-toolkits/gtkglext
RUN_DEPENDS= ${X11BASE}/lib/libosg.so:${PORTSDIR}/graphics/osg
USE_X_PREFIX= yes
-USE_GNOME= libgnomeui
+USE_GNOME= gnomehack gnomeprefix gnometarget libgnomeui
+USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-USE_GMAKE= yes
+CONFIGURE_ARGS= --enable-gtkglext
+
+CFLAGS+= -O0
+
+post-patch:
+.for file in src/gui/interface.cc
+ @cd ${WRKSRC} && ${MV} ${file} ${file}.pre_conv \
+ && ${TR} -d '\015' < ${file}.pre_conv > ${file} || ${TRUE}
+.endfor
.include <bsd.port.mk>
diff --git a/graphics/osgedit/distinfo b/graphics/osgedit/distinfo
index 017324685cc8..38b0ad041f59 100644
--- a/graphics/osgedit/distinfo
+++ b/graphics/osgedit/distinfo
@@ -1,2 +1,2 @@
-MD5 (osgedit-0.4.1.tar.gz) = aa9fce7244beb5d3652aa5c4d0ff9544
-SIZE (osgedit-0.4.1.tar.gz) = 311740
+MD5 (osgedit-0.5.0.tar.gz) = 3d1cd2c850a2ca1d1dd56aa40d639165
+SIZE (osgedit-0.5.0.tar.gz) = 394484
diff --git a/graphics/osgedit/files/patch-Makefile.in b/graphics/osgedit/files/patch-Makefile.in
deleted file mode 100644
index 4634cacbaefa..000000000000
--- a/graphics/osgedit/files/patch-Makefile.in
+++ /dev/null
@@ -1,28 +0,0 @@
---- Makefile.in.orig Wed Jul 16 02:27:40 2003
-+++ Makefile.in Sun Sep 7 03:04:13 2003
-@@ -88,10 +88,10 @@
-
-
- icon_DATA = osgedit.png
--icondir = $(DESTDIR)$(datadir)/pixmaps
-+icondir = $(DESTDIR)$(datadir)/gnome/pixmaps
-
- util_DATA = osgedit.desktop
--utildir = $(DESTDIR)$(datadir)/applications
-+utildir = $(DESTDIR)$(datadir)/gnome/applications
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = config.h
-@@ -425,10 +425,10 @@
- install-data-local:
- @$(NORMAL_INSTALL)
- if test -d $(srcdir)/pixmaps; then \
-- $(mkinstalldirs) $(DESTDIR)$(datadir)/pixmaps/$(PACKAGE); \
-+ $(mkinstalldirs) $(DESTDIR)$(datadir)/gnome/pixmaps/$(PACKAGE); \
- for pixmap in $(srcdir)/pixmaps/*; do \
- if test -f $$pixmap; then \
-- $(INSTALL_DATA) $$pixmap $(DESTDIR)$(datadir)/pixmaps/$(PACKAGE); \
-+ $(INSTALL_DATA) $$pixmap $(DESTDIR)$(datadir)/gnome/pixmaps/$(PACKAGE); \
- fi \
- done \
- fi
diff --git a/graphics/osgedit/files/patch-po::Makefile.in.in b/graphics/osgedit/files/patch-po::Makefile.in.in
deleted file mode 100644
index c58deed8235f..000000000000
--- a/graphics/osgedit/files/patch-po::Makefile.in.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- po/Makefile.in.in.orig Sat Sep 6 17:12:03 2003
-+++ po/Makefile.in.in Sat Sep 6 17:12:18 2003
-@@ -27,7 +27,7 @@
- exec_prefix = @exec_prefix@
- datadir = @datadir@
- libdir = @libdir@
--localedir = $(libdir)/locale
-+localedir = $(datadir)/locale
- gnulocaledir = $(datadir)/locale
- gettextsrcdir = $(datadir)/glib-2.0/gettext/po
- subdir = po
diff --git a/graphics/osgedit/files/patch-src::editable::entities::edgeode.cc b/graphics/osgedit/files/patch-src::editable::entities::edgeode.cc
new file mode 100644
index 000000000000..0d5c0c90dcc9
--- /dev/null
+++ b/graphics/osgedit/files/patch-src::editable::entities::edgeode.cc
@@ -0,0 +1,8 @@
+--- src/editable/entities/edgeode.cc.orig Fri Oct 31 08:32:03 2003
++++ src/editable/entities/edgeode.cc Sat Jan 31 12:44:22 2004
+@@ -1,3 +1,5 @@
++#include <stdio.h>
++
+ #include <editable/entityfactory.h>
+ #include "edgeometry.h"
+ #include "edgeode.h"