aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-03-07 04:48:53 +0800
committermarcus <marcus@FreeBSD.org>2005-03-07 04:48:53 +0800
commitec85234d16e5e2d9aa7889f151ce6d12abefc14c (patch)
tree883ba0123e7a871209362daa3db1c9726ecd78d9 /graphics
parent936c5137cb94db952e8046d5053ab0003d2f2e2f (diff)
downloadfreebsd-ports-gnome-ec85234d16e5e2d9aa7889f151ce6d12abefc14c.tar.gz
freebsd-ports-gnome-ec85234d16e5e2d9aa7889f151ce6d12abefc14c.tar.zst
freebsd-ports-gnome-ec85234d16e5e2d9aa7889f151ce6d12abefc14c.zip
Add GIMP_THREAD_LIBS to GTK_LIBS so that all plug-ins get some thread lovin'.
This fixes some missing pthread symbols, and allows the new GTK+ file chooser to work in certain plug-ins (e.g. print).
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gimp-app/Makefile2
-rw-r--r--graphics/gimp-app/files/patch-configure14
-rw-r--r--graphics/gimp/Makefile2
-rw-r--r--graphics/gimp/files/patch-configure14
-rw-r--r--graphics/gimpshop/Makefile2
-rw-r--r--graphics/gimpshop/files/patch-configure14
6 files changed, 36 insertions, 12 deletions
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index 9b6f16a6fd02..5d9946ae998d 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gimp
PORTVERSION= 2.2.4
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
diff --git a/graphics/gimp-app/files/patch-configure b/graphics/gimp-app/files/patch-configure
index 6dab9ee3a629..da42f67f8ca6 100644
--- a/graphics/gimp-app/files/patch-configure
+++ b/graphics/gimp-app/files/patch-configure
@@ -1,6 +1,14 @@
---- configure.orig Sun Nov 21 08:44:04 2004
-+++ configure Sun Nov 21 08:46:24 2004
-@@ -33676,9 +33676,9 @@
+--- configure.orig Sun Mar 6 15:30:12 2005
++++ configure Sun Mar 6 15:33:57 2005
+@@ -25925,6 +25925,7 @@
+ if test "x$enable_gtktest" = "xyes" ; then
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
++ GTK_LIBS="$GIMP_THREAD_LIBS $GTK_LIBS"
+ CFLAGS="$CFLAGS $GTK_CFLAGS"
+ LIBS="$GTK_LIBS $LIBS"
+ rm -f conf.gtktest
+@@ -33865,9 +33866,9 @@
fi
fi;
diff --git a/graphics/gimp/Makefile b/graphics/gimp/Makefile
index 9b6f16a6fd02..5d9946ae998d 100644
--- a/graphics/gimp/Makefile
+++ b/graphics/gimp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gimp
PORTVERSION= 2.2.4
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
diff --git a/graphics/gimp/files/patch-configure b/graphics/gimp/files/patch-configure
index 6dab9ee3a629..da42f67f8ca6 100644
--- a/graphics/gimp/files/patch-configure
+++ b/graphics/gimp/files/patch-configure
@@ -1,6 +1,14 @@
---- configure.orig Sun Nov 21 08:44:04 2004
-+++ configure Sun Nov 21 08:46:24 2004
-@@ -33676,9 +33676,9 @@
+--- configure.orig Sun Mar 6 15:30:12 2005
++++ configure Sun Mar 6 15:33:57 2005
+@@ -25925,6 +25925,7 @@
+ if test "x$enable_gtktest" = "xyes" ; then
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
++ GTK_LIBS="$GIMP_THREAD_LIBS $GTK_LIBS"
+ CFLAGS="$CFLAGS $GTK_CFLAGS"
+ LIBS="$GTK_LIBS $LIBS"
+ rm -f conf.gtktest
+@@ -33865,9 +33866,9 @@
fi
fi;
diff --git a/graphics/gimpshop/Makefile b/graphics/gimpshop/Makefile
index 9b6f16a6fd02..5d9946ae998d 100644
--- a/graphics/gimpshop/Makefile
+++ b/graphics/gimpshop/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gimp
PORTVERSION= 2.2.4
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
diff --git a/graphics/gimpshop/files/patch-configure b/graphics/gimpshop/files/patch-configure
index 6dab9ee3a629..da42f67f8ca6 100644
--- a/graphics/gimpshop/files/patch-configure
+++ b/graphics/gimpshop/files/patch-configure
@@ -1,6 +1,14 @@
---- configure.orig Sun Nov 21 08:44:04 2004
-+++ configure Sun Nov 21 08:46:24 2004
-@@ -33676,9 +33676,9 @@
+--- configure.orig Sun Mar 6 15:30:12 2005
++++ configure Sun Mar 6 15:33:57 2005
+@@ -25925,6 +25925,7 @@
+ if test "x$enable_gtktest" = "xyes" ; then
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
++ GTK_LIBS="$GIMP_THREAD_LIBS $GTK_LIBS"
+ CFLAGS="$CFLAGS $GTK_CFLAGS"
+ LIBS="$GTK_LIBS $LIBS"
+ rm -f conf.gtktest
+@@ -33865,9 +33866,9 @@
fi
fi;