aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-02-15 12:46:46 +0800
committerrm <rm@FreeBSD.org>2012-02-15 12:46:46 +0800
commitefb3d42ba9e9035cd204f4ba18341986a139c4b4 (patch)
treefcba5995d19a2ef5b19c5b3193b95b035489bea0 /graphics
parent918312551bc28a7aa797fe47eff0c7c60036ad58 (diff)
downloadfreebsd-ports-gnome-efb3d42ba9e9035cd204f4ba18341986a139c4b4.tar.gz
freebsd-ports-gnome-efb3d42ba9e9035cd204f4ba18341986a139c4b4.tar.zst
freebsd-ports-gnome-efb3d42ba9e9035cd204f4ba18341986a139c4b4.zip
- update to 1.5.0.9
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gimp-gmic-plugin/Makefile19
-rw-r--r--graphics/gimp-gmic-plugin/distinfo4
-rw-r--r--graphics/gimp-gmic-plugin/files/patch-Makefile (renamed from graphics/gimp-gmic-plugin/files/patch-src_Makefile)43
-rw-r--r--graphics/gimp-gmic-plugin/files/patch-configure113
4 files changed, 32 insertions, 147 deletions
diff --git a/graphics/gimp-gmic-plugin/Makefile b/graphics/gimp-gmic-plugin/Makefile
index 0eb6de658d89..c2c5b42e801d 100644
--- a/graphics/gimp-gmic-plugin/Makefile
+++ b/graphics/gimp-gmic-plugin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gmic
-PORTVERSION= 1.5.0.6
+PORTVERSION= 1.5.0.9
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME} \
SF/${PORTNAME}/old
@@ -26,9 +26,8 @@ LIB_DEPENDS= GraphicsMagick++.6:${PORTSDIR}/graphics/GraphicsMagick13 \
OPTIONS= BASH "Install programmable completions for Bash" off
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
-GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gtk20
USE_XORG= x11 xext xrandr
@@ -56,19 +55,15 @@ PLIST_SUB+= BASH="@comment "
post-patch:
@${REINPLACE_CMD} -e 's#/usr/X11R6#${PREFIX}#g' \
-e 's/-lcv -lhighgui/-lopencv_legacy/g' \
- ${WRKSRC}/src/Makefile
-# GMIC is broken with OpenCV 2.3.1, so disable it for now
-# @${REINPLACE_CMD} -e 's/-lcv/-lopencv_legacy/g' \
-# -e 's/-lhighgui/-lopencv_legacy/g' \
-# ${WRKSRC}/configure
+ ${WRKSRC}/Makefile
do-install:
@${MKDIR} ${PREFIX}/${PLUGIN_DIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/src/gmic_gimp ${PREFIX}/${PLUGIN_DIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/src/gmic ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/man/gmic.1.gz ${MAN1PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/gmic_gimp ${PREFIX}/${PLUGIN_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/gmic ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/../man/gmic.1.gz ${MAN1PREFIX}/man/man1
.if defined(WITH_BASH)
- ${INSTALL_SCRIPT} ${WRKSRC}/src/gmic_bashcompletion.sh \
+ ${INSTALL_SCRIPT} ${WRKSRC}/gmic_bashcompletion.sh \
${PREFIX}/etc/bash_completion.d/gmic_bashcompletion.sh
.endif
diff --git a/graphics/gimp-gmic-plugin/distinfo b/graphics/gimp-gmic-plugin/distinfo
index 48eb45f68c44..1b83a8f21dbc 100644
--- a/graphics/gimp-gmic-plugin/distinfo
+++ b/graphics/gimp-gmic-plugin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gmic_1.5.0.6.tar.gz) = 6eb4370242637854f806bb8fb9b69781e2f75d066e795cad8b450b9ce5154c68
-SIZE (gmic_1.5.0.6.tar.gz) = 1219169
+SHA256 (gmic_1.5.0.9.tar.gz) = d647a64bd25bf4146d1c755aa2d26f129605e03b3072dca2dc2e6ec5e38ed3b0
+SIZE (gmic_1.5.0.9.tar.gz) = 1196717
diff --git a/graphics/gimp-gmic-plugin/files/patch-src_Makefile b/graphics/gimp-gmic-plugin/files/patch-Makefile
index adda83806ee8..733852f54a83 100644
--- a/graphics/gimp-gmic-plugin/files/patch-src_Makefile
+++ b/graphics/gimp-gmic-plugin/files/patch-Makefile
@@ -1,7 +1,5 @@
-$FreeBSD$
-
---- src/Makefile.orig 2011-08-23 18:18:27.000000000 +0400
-+++ src/Makefile 2011-08-30 22:32:02.000000000 +0400
+--- Makefile.orig 2012-01-20 17:27:10.000000000 +0400
++++ Makefile 2012-02-14 22:26:16.000000000 +0400
@@ -56,7 +56,7 @@
USR = /opt/local
else
@@ -11,32 +9,36 @@ $FreeBSD$
endif
ifeq ($(OS),MINGW32_NT-5.1)
EXE = .exe
-@@ -112,7 +112,7 @@
-
- # Flags to enable fast display, using XShm.
+@@ -118,7 +118,7 @@
+ # This requires the presence of the X11 extension include and library files.
+ # (package 'libx11-dev' on Debian).
XSHM_CFLAGS = -Dcimg_use_xshm
-XSHM_LDFLAGS = -L$(USR)/X11R6/lib -lXext
+XSHM_LDFLAGS = -L/usr/X11R6/lib -lXext
# Flags to enable image display, using GDI32.
- GDI32_CFLAGS = -Dcimg_display=2 -Dcimg_appname=\\\"gmic\\\"
-@@ -142,15 +142,6 @@
- ZLIB_CFLAGS = -Dcimg_use_zlib
- ZLIB_LDFLAGS = -lz
-
--# Flags to enable native support of webcams, using the OpenCV library.
+ # This requires the presence of the GDI32 include and library files.
+@@ -164,13 +164,13 @@
+ # Flags to enable native support of webcams, using the OpenCV library.
+ # This requires the presence of the OpenCV include and library files.
+ # (package 'libcv3-2-dev' on Debian).
-OPENCV_CFLAGS = -Dcimg_use_opencv -I$(USR)/include/opencv
-ifeq ($(OS),Darwin)
-OPENCV_LDFLAGS = -lopencv_core -lopencv_highgui # Use this for OpenCV 2.2.0 !
-else
-OPENCV_LDFLAGS = -lcv -lhighgui
--# OPENCV_LDFLAGS = -lopencv_core -lopencv_highgui # Use this for OpenCV 2.2.0 !
++#OPENCV_CFLAGS = -Dcimg_use_opencv -I$(USR)/include/opencv
++#ifeq ($(OS),Darwin)
++#OPENCV_LDFLAGS = -lopencv_core -lopencv_highgui # Use this for OpenCV 2.2.0 !
++#else
++#OPENCV_LDFLAGS = -lcv -lhighgui
+ # OPENCV_LDFLAGS = -lopencv_core -lopencv_highgui # Use this for OpenCV 2.2.0 !
-endif
--
++#endif
+
# Flags to enable native support of most classical image file formats, using the GraphicsMagick++ library.
- MAGICK_CFLAGS = -Dcimg_use_magick -I$(USR)/include/GraphicsMagick
- ifeq ($(OS),Darwin)
-@@ -236,6 +227,14 @@
+ # This requires the presence of the GraphicsMagick++ include and library files.
+@@ -271,6 +271,14 @@
$(MAKE) gimp
$(MAKE) lib
else
@@ -51,7 +53,7 @@ $FreeBSD$
ifeq ($(OS),Darwin)
@echo "**"
@echo "** MacOSX configuration"
-@@ -252,9 +251,10 @@
+@@ -287,9 +295,10 @@
$(MAKE) gimp
endif
endif
@@ -63,7 +65,7 @@ $FreeBSD$
lib:
$(MAKE) "CFLAGS=$(STD_LIB_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS+=$(STD_LIB_LDFLAGS)" gmic_lib
-@@ -269,6 +269,9 @@
+@@ -304,6 +313,9 @@
linux:
$(MAKE) "CFLAGS=$(STD_UNIX_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS=$(STD_UNIX_LDFLAGS)" "STRIP_EXE=1" gmic_gmic
@@ -72,3 +74,4 @@ $FreeBSD$
+
custom:
$(MAKE) "CFLAGS=$(CUST_UNIX_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS=$(CUST_UNIX_LDFLAGS)" "STRIP_EXE=1" gmic_gmic
+
diff --git a/graphics/gimp-gmic-plugin/files/patch-configure b/graphics/gimp-gmic-plugin/files/patch-configure
deleted file mode 100644
index c6baff451417..000000000000
--- a/graphics/gimp-gmic-plugin/files/patch-configure
+++ /dev/null
@@ -1,113 +0,0 @@
-$FreeBSD$
-
-Unfortunately we can't do the usual patch configure.ac and run autoconf -- the
-tarball doesn't contain the autotools sources ><
-
---- configure.orig 2011-08-23 18:18:22.000000000 +0400
-+++ configure 2011-08-30 22:27:42.000000000 +0400
-@@ -5104,105 +5104,6 @@
-
- fi
-
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for cvSobel in -lcv" >&5
--$as_echo_n "checking for cvSobel in -lcv... " >&6; }
--if test "${ac_cv_lib_cv_cvSobel+set}" = set; then :
-- $as_echo_n "(cached) " >&6
--else
-- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lcv $LIBS"
--cat confdefs.h - <<_ACEOF >conftest.$ac_ext
--/* end confdefs.h. */
--
--/* Override any GCC internal prototype to avoid an error.
-- Use char because int might match the return type of a GCC
-- builtin and then its argument prototype would still apply. */
--#ifdef __cplusplus
--extern "C"
--#endif
--char cvSobel ();
--int
--main ()
--{
--return cvSobel ();
-- ;
-- return 0;
--}
--_ACEOF
--if ac_fn_c_try_link "$LINENO"; then :
-- ac_cv_lib_cv_cvSobel=yes
--else
-- ac_cv_lib_cv_cvSobel=no
--fi
--rm -f core conftest.err conftest.$ac_objext \
-- conftest$ac_exeext conftest.$ac_ext
--LIBS=$ac_check_lib_save_LIBS
--fi
--{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_cv_cvSobel" >&5
--$as_echo "$ac_cv_lib_cv_cvSobel" >&6; }
--if test "x$ac_cv_lib_cv_cvSobel" = x""yes; then :
-- cat >>confdefs.h <<_ACEOF
--#define HAVE_LIBCV 1
--_ACEOF
--
-- LIBS="-lcv $LIBS"
--
--else
--
-- echo "***"
-- echo "** Fatal Error : Header or library files for 'OpenCV (core)' are missing but are mandatory to compile G'MIC. **"
-- echo "***"
-- exit -1
--
--fi
--
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for main in -lhighgui" >&5
--$as_echo_n "checking for main in -lhighgui... " >&6; }
--if test "${ac_cv_lib_highgui_main+set}" = set; then :
-- $as_echo_n "(cached) " >&6
--else
-- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lhighgui $LIBS"
--cat confdefs.h - <<_ACEOF >conftest.$ac_ext
--/* end confdefs.h. */
--
--
--int
--main ()
--{
--return main ();
-- ;
-- return 0;
--}
--_ACEOF
--if ac_fn_c_try_link "$LINENO"; then :
-- ac_cv_lib_highgui_main=yes
--else
-- ac_cv_lib_highgui_main=no
--fi
--rm -f core conftest.err conftest.$ac_objext \
-- conftest$ac_exeext conftest.$ac_ext
--LIBS=$ac_check_lib_save_LIBS
--fi
--{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_highgui_main" >&5
--$as_echo "$ac_cv_lib_highgui_main" >&6; }
--if test "x$ac_cv_lib_highgui_main" = x""yes; then :
-- cat >>confdefs.h <<_ACEOF
--#define HAVE_LIBHIGHGUI 1
--_ACEOF
--
-- LIBS="-lhighgui $LIBS"
--
--else
--
-- echo "***"
-- echo "** Fatal Error : Header or library files for 'OpenCV (highgui)' are missing but are mandatory to compile G'MIC. **"
-- echo "***"
-- exit -1
--
--fi
--
--
- # Checks for header files.
- ac_ext=c
- ac_cpp='$CPP $CPPFLAGS'