aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorgblach <gblach@FreeBSD.org>2013-10-06 22:48:21 +0800
committergblach <gblach@FreeBSD.org>2013-10-06 22:48:21 +0800
commitf3644736316a098e34ee1c42c9ad2903a9a5e05f (patch)
treed887de7498ac4f768aeb2617b778c6a8fd573400 /graphics
parente65168fa0208ef6b6d0a6a40b51a057ae3a88c41 (diff)
downloadfreebsd-ports-gnome-f3644736316a098e34ee1c42c9ad2903a9a5e05f.tar.gz
freebsd-ports-gnome-f3644736316a098e34ee1c42c9ad2903a9a5e05f.tar.zst
freebsd-ports-gnome-f3644736316a098e34ee1c42c9ad2903a9a5e05f.zip
- Convert to new LIB_DEPENDS syntax
- Support staging Approved by: crees, tabthorpe (mentors, implicit)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/evas-core/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/graphics/evas-core/Makefile b/graphics/evas-core/Makefile
index 5318157bd72a..811185c3a7a5 100644
--- a/graphics/evas-core/Makefile
+++ b/graphics/evas-core/Makefile
@@ -14,7 +14,7 @@ COMMENT= A hardware accelerated canvas API (core library)
LICENSE= BSD
-LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
DIST_SUBDIR= e17
USE_BZIP2= yes
@@ -26,7 +26,6 @@ USE_LDCONFIG= yes
DATADIR= ${PREFIX}/share/evas
EXAMPLESDIR= ${PREFIX}/share/examples/evas
-NO_STAGE= yes
.include "Makefile.inc"
OPTIONS_DEFINE= EET FONTCONFIG FRIBIDI
@@ -36,14 +35,14 @@ EET_DESC= EET font loader
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MFONTCONFIG}
-LIB_DEPENDS+= fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS+= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
CONFIGURE_ARGS+=--enable-fontconfig
.else
CONFIGURE_ARGS+=--disable-fontconfig
.endif
.if ${PORT_OPTIONS:MFRIBIDI}
-LIB_DEPENDS+= fribidi:${PORTSDIR}/converters/fribidi
+LIB_DEPENDS+= libfribidi.so:${PORTSDIR}/converters/fribidi
CONFIGURE_ARGS+=--enable-fribidi
.else
CONFIGURE_ARGS+=--disable-fribidi
@@ -66,9 +65,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|= \$$(datadir)/\$$(PACKAGE)/examples|= $$(datadir)/examples/$$(PACKAGE)|' \
${WRKSRC}/src/examples/Makefile.in
-post-install:
-.if empty(PORT_OPTIONS:MEXAMPLES)
- @${RMDIR} ${EXAMPLESDIR}
-.endif
-
.include <bsd.port.mk>