aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-10-13 16:04:48 +0800
committerpav <pav@FreeBSD.org>2004-10-13 16:04:48 +0800
commitf399eeced5089a14405d8deffe372c2c88900dad (patch)
tree8297ef81cb552be46de42da48d4c095e63ec2abf /graphics
parent0389f311de8a23d5a80e31bae525ac981ec041f1 (diff)
downloadfreebsd-ports-gnome-f399eeced5089a14405d8deffe372c2c88900dad.tar.gz
freebsd-ports-gnome-f399eeced5089a14405d8deffe372c2c88900dad.tar.zst
freebsd-ports-gnome-f399eeced5089a14405d8deffe372c2c88900dad.zip
Add exiv2, Exif and Iptc metadata manipulation library and tool.
PR: ports/72060 Submitted by: Michael Johnson <ahze@ahze.net>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/exiv2/Makefile44
-rw-r--r--graphics/exiv2/distinfo2
-rw-r--r--graphics/exiv2/pkg-descr3
4 files changed, 50 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index bd93f5a51918..553cefe16b05 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -80,6 +80,7 @@
SUBDIR += evolvotron
SUBDIR += exifprobe
SUBDIR += exiftags
+ SUBDIR += exiv2
SUBDIR += fbm
SUBDIR += feh
SUBDIR += figurine
diff --git a/graphics/exiv2/Makefile b/graphics/exiv2/Makefile
new file mode 100644
index 000000000000..00fdcce7f657
--- /dev/null
+++ b/graphics/exiv2/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: exiv2
+# Date created: 2004-09-24
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= exiv2
+PORTVERSION= 0.5
+CATEGORIES= graphics
+MASTER_SITES= http://home.arcor.de/ahuggel/exiv2/
+
+MAINTAINER= ahze@ahze.net
+COMMENT= Exif and Iptc metadata manipulation library and tools
+
+.if defined(PORTDOCS)
+BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
+.endif
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+PORTDOCS= *
+PLIST_FILES= bin/exiv2 \
+ lib/libexiv2.so
+
+.if defined(PORTDOCS)
+ALLTARGET= all doc
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.4
+.endif
+
+post-install:
+.if defined(PORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/html/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/exiv2/distinfo b/graphics/exiv2/distinfo
new file mode 100644
index 000000000000..61d11aa1d17d
--- /dev/null
+++ b/graphics/exiv2/distinfo
@@ -0,0 +1,2 @@
+MD5 (exiv2-0.5.tar.gz) = e9362bc1b9e5cea5b095a99af08613ee
+SIZE (exiv2-0.5.tar.gz) = 645739
diff --git a/graphics/exiv2/pkg-descr b/graphics/exiv2/pkg-descr
new file mode 100644
index 000000000000..9f5b0e3ec17c
--- /dev/null
+++ b/graphics/exiv2/pkg-descr
@@ -0,0 +1,3 @@
+Exif and Iptc metadata manipulation library and tools
+
+WWW: http://home.arcor.de/ahuggel/exiv2/