aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-01-02 07:44:27 +0800
committernemysis <nemysis@FreeBSD.org>2014-01-02 07:44:27 +0800
commitf7a7a2f4ca4c8caea2eab77ca46f97496b691b9b (patch)
tree2d04038c7077bf82e79f4df0fd251219a51b5334 /graphics
parent1241c87daf87f6a35afd879a3b9ba95708e356d5 (diff)
downloadfreebsd-ports-gnome-f7a7a2f4ca4c8caea2eab77ca46f97496b691b9b.tar.gz
freebsd-ports-gnome-f7a7a2f4ca4c8caea2eab77ca46f97496b691b9b.tar.zst
freebsd-ports-gnome-f7a7a2f4ca4c8caea2eab77ca46f97496b691b9b.zip
- Change Makefile header
- Support STAGEDIR - Add DOCS Option Approved by: pawel / wg (mentors, implicit)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cbview/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/graphics/cbview/Makefile b/graphics/cbview/Makefile
index 63656b5be682..9ccd87dfa54c 100644
--- a/graphics/cbview/Makefile
+++ b/graphics/cbview/Makefile
@@ -1,3 +1,4 @@
+# Created by: Mezz <mezz@FreeBSD.org>
# $FreeBSD$
PORTNAME= cbview
@@ -23,19 +24,16 @@ PLIST_FILES= bin/${PORTNAME}
PORTDOCS= Changes README TODO
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin/perl -w|${PERL}|' \
${WRKSRC}/${PORTNAME}
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>