aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-10-17 18:29:21 +0800
committerstas <stas@FreeBSD.org>2009-10-17 18:29:21 +0800
commitf86393d51332c545ba98b17dda6788ae7efa5c57 (patch)
tree04ad095efb6bd5c86fc61e62af3873c575a48d3f /graphics
parentbf6726ad3e5e2ae55d743de6e4d7642e710fa087 (diff)
downloadfreebsd-ports-gnome-f86393d51332c545ba98b17dda6788ae7efa5c57.tar.gz
freebsd-ports-gnome-f86393d51332c545ba98b17dda6788ae7efa5c57.tar.zst
freebsd-ports-gnome-f86393d51332c545ba98b17dda6788ae7efa5c57.zip
- Add graphics/podofo, a PDF manipulation library.
WWW: http://podofo.sourceforge.net
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/podofo/Makefile41
-rw-r--r--graphics/podofo/distinfo3
-rw-r--r--graphics/podofo/files/patch-cmake_modules_FindLua51.cmake20
-rw-r--r--graphics/podofo/pkg-descr5
-rw-r--r--graphics/podofo/pkg-plist92
6 files changed, 162 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 05f89b9058d3..6d5b08331c3f 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -698,6 +698,7 @@
SUBDIR += pngquant
SUBDIR += pngrewrite
SUBDIR += pngwriter
+ SUBDIR += podofo
SUBDIR += poppler
SUBDIR += poppler-data
SUBDIR += poppler-gtk
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
new file mode 100644
index 000000000000..2d0eb1b4a023
--- /dev/null
+++ b/graphics/podofo/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: podofo
+# Date created: 10/17/2009
+# Whom: stas
+#
+# $FreeBSD$
+#
+
+PORTNAME= podofo
+PORTVERSION= 0.7.0
+CATEGORIES= graphics print
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= PDF manipulation library and tools
+
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
+ fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+
+OPTIONS= JPEG "Enable JPEG support" on \
+ TIFF "Enable TIFF support" on \
+ IMPOSE "Build impose tool (needs Lua)" off
+
+#USE_GETTEXT= yes
+USE_CMAKE= yes
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_JPEG) || exists(${LOCALBASE}/lib/libjpeg.so)
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
+.endif
+.if !defined(WITHOUT_TIFF) || exists(${LOCALBASE}/lib/libtiff.so)
+LIB_DEPENDS+= tiff:${PORTSDIR}/graphics/tiff
+.endif
+.if defined(WITH_IMPOSE) || exists(${LOCALBASE}/lib/lua51/liblua.so)
+USE_LUA= 5.1
+CPPFLAGS+= -I${LUA_INCDIR}
+LDFLAGS+= -L${LUA_LIBDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/podofo/distinfo b/graphics/podofo/distinfo
new file mode 100644
index 000000000000..b4b7b9c0796f
--- /dev/null
+++ b/graphics/podofo/distinfo
@@ -0,0 +1,3 @@
+MD5 (podofo-0.7.0.tar.gz) = b9623fd9279fca49f7cdd5c1fed182b1
+SHA256 (podofo-0.7.0.tar.gz) = 1e57e0b2c0039519e9542302f358bf8d9b8de69ad9b19a030123802d1b2dedc2
+SIZE (podofo-0.7.0.tar.gz) = 1117023
diff --git a/graphics/podofo/files/patch-cmake_modules_FindLua51.cmake b/graphics/podofo/files/patch-cmake_modules_FindLua51.cmake
new file mode 100644
index 000000000000..6fa9ed25edb3
--- /dev/null
+++ b/graphics/podofo/files/patch-cmake_modules_FindLua51.cmake
@@ -0,0 +1,20 @@
+--- cmake/modules/FindLua51.cmake.orig 2009-10-17 13:51:12.000000000 +0400
++++ cmake/modules/FindLua51.cmake 2009-10-17 13:51:39.000000000 +0400
+@@ -33,7 +33,7 @@
+ )
+
+ FIND_LIBRARY(LUA_LIBRARY
+- NAMES lua51 lua5.1 lua
++ NAMES lua51 lua5.1 lua-5.1 lua
+ PATHS
+ $ENV{LUA_DIR}
+ NO_DEFAULT_PATH
+@@ -41,7 +41,7 @@
+ )
+
+ FIND_LIBRARY(LUA_LIBRARY
+- NAMES lua51 lua5.1 lua
++ NAMES lua51 lua5.1 lua-5.1 lua
+ PATHS
+ ~/Library/Frameworks
+ /Library/Frameworks
diff --git a/graphics/podofo/pkg-descr b/graphics/podofo/pkg-descr
new file mode 100644
index 000000000000..ca3f97cf5fbe
--- /dev/null
+++ b/graphics/podofo/pkg-descr
@@ -0,0 +1,5 @@
+PoDoFo is a library to work with the PDF file format. The name comes
+from the first letter of PDF (Portable Document Format). A few tools
+to work with PDF files are already included in the PoDoFo package.
+
+WWW: http://podofo.sourceforge.net
diff --git a/graphics/podofo/pkg-plist b/graphics/podofo/pkg-plist
new file mode 100644
index 000000000000..5107c717172e
--- /dev/null
+++ b/graphics/podofo/pkg-plist
@@ -0,0 +1,92 @@
+bin/podofoencrypt
+bin/podofoimgextract
+bin/podofoimpose
+bin/podofomerge
+bin/podofopdfinfo
+bin/podofotxt2pdf
+bin/podofotxtextract
+bin/podofouncompress
+include/podofo/Pdf3rdPtyForwardDecl.h
+include/podofo/PdfAcroForm.h
+include/podofo/PdfAction.h
+include/podofo/PdfAnnotation.h
+include/podofo/PdfArray.h
+include/podofo/PdfCanvas.h
+include/podofo/PdfColor.h
+include/podofo/PdfContents.h
+include/podofo/PdfContentsTokenizer.h
+include/podofo/PdfData.h
+include/podofo/PdfDataType.h
+include/podofo/PdfDate.h
+include/podofo/PdfDefines.h
+include/podofo/PdfDestination.h
+include/podofo/PdfDictionary.h
+include/podofo/PdfDifferenceEncoding.h
+include/podofo/PdfDocument.h
+include/podofo/PdfElement.h
+include/podofo/PdfEncoding.h
+include/podofo/PdfEncodingFactory.h
+include/podofo/PdfEncrypt.h
+include/podofo/PdfError.h
+include/podofo/PdfExtGState.h
+include/podofo/PdfField.h
+include/podofo/PdfFileSpec.h
+include/podofo/PdfFileStream.h
+include/podofo/PdfFilter.h
+include/podofo/PdfFiltersPrivate.h
+include/podofo/PdfFont.h
+include/podofo/PdfFontCID.h
+include/podofo/PdfFontCache.h
+include/podofo/PdfFontFactory.h
+include/podofo/PdfFontMetrics.h
+include/podofo/PdfFontSimple.h
+include/podofo/PdfFontTTFSubset.h
+include/podofo/PdfFontTrueType.h
+include/podofo/PdfFontType1.h
+include/podofo/PdfFunction.h
+include/podofo/PdfHintStream.h
+include/podofo/PdfImage.h
+include/podofo/PdfImmediateWriter.h
+include/podofo/PdfInfo.h
+include/podofo/PdfInputDevice.h
+include/podofo/PdfInputStream.h
+include/podofo/PdfLocale.h
+include/podofo/PdfMemDocument.h
+include/podofo/PdfMemStream.h
+include/podofo/PdfName.h
+include/podofo/PdfNamesTree.h
+include/podofo/PdfObject.h
+include/podofo/PdfOutlines.h
+include/podofo/PdfOutputDevice.h
+include/podofo/PdfOutputStream.h
+include/podofo/PdfPage.h
+include/podofo/PdfPagesTree.h
+include/podofo/PdfPainter.h
+include/podofo/PdfPainterMM.h
+include/podofo/PdfParser.h
+include/podofo/PdfParserObject.h
+include/podofo/PdfRect.h
+include/podofo/PdfRefCountedBuffer.h
+include/podofo/PdfRefCountedInputDevice.h
+include/podofo/PdfReference.h
+include/podofo/PdfRijndael.h
+include/podofo/PdfShadingPattern.h
+include/podofo/PdfStream.h
+include/podofo/PdfStreamedDocument.h
+include/podofo/PdfString.h
+include/podofo/PdfTable.h
+include/podofo/PdfTokenizer.h
+include/podofo/PdfVariant.h
+include/podofo/PdfVecObjects.h
+include/podofo/PdfVersion.h
+include/podofo/PdfWriter.h
+include/podofo/PdfXObject.h
+include/podofo/PdfXRef.h
+include/podofo/PdfXRefStream.h
+include/podofo/podofo.h
+include/podofo/podofoapi.h
+include/podofo/util/PdfMutex.h
+include/podofo/util/PdfMutexWrapper.h
+lib/libpodofo.a
+@dirrm include/podofo/util
+@dirrm include/podofo