aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorrnoland <rnoland@FreeBSD.org>2009-01-25 05:45:05 +0800
committerrnoland <rnoland@FreeBSD.org>2009-01-25 05:45:05 +0800
commit1ac88e4489070408fdf01944c50f1ced7f7e975e (patch)
treefef0e57659f5ec309fc0bbda7630d031083fba86 /graphics
parent51fbfd14fa11172e6575ca13f4204412fd53ab8c (diff)
downloadfreebsd-ports-gnome-1ac88e4489070408fdf01944c50f1ced7f7e975e.tar.gz
freebsd-ports-gnome-1ac88e4489070408fdf01944c50f1ced7f7e975e.tar.zst
freebsd-ports-gnome-1ac88e4489070408fdf01944c50f1ced7f7e975e.zip
Add dependency on dri2proto to the rest of the mesa ports
Approved by: garga (mentor, implicit)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libGL/Makefile2
-rw-r--r--graphics/libGLU/Makefile2
-rw-r--r--graphics/libGLw/Makefile2
-rw-r--r--graphics/libglut/Makefile2
-rw-r--r--graphics/mesa-demos/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/graphics/libGL/Makefile b/graphics/libGL/Makefile
index 2caa24c4735e..1bd2a9165574 100644
--- a/graphics/libGL/Makefile
+++ b/graphics/libGL/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS+= makedepend:${PORTSDIR}/devel/makedepend
LIB_DEPENDS+= drm:${PORTSDIR}/graphics/libdrm \
expat.6:${PORTSDIR}/textproc/expat2
-USE_XORG= glproto x11 xext xxf86vm xdamage xfixes
+USE_XORG= glproto x11 xext xxf86vm xdamage xfixes dri2proto
do-install:
${RM} ${WRKSRC}/include/GL/glu*.h
diff --git a/graphics/libGLU/Makefile b/graphics/libGLU/Makefile
index dace0ab723c7..b39ab7574fe5 100644
--- a/graphics/libGLU/Makefile
+++ b/graphics/libGLU/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= graphics
COMMENT= OpenGL utility library
USE_GL= gl
-USE_XORG= glproto x11 xext xxf86vm xdamage xfixes
+USE_XORG= glproto x11 xext xxf86vm xdamage xfixes dri2proto
do-install:
cd ${WRKSRC}/src/glu; ${GMAKE} install
diff --git a/graphics/libGLw/Makefile b/graphics/libGLw/Makefile
index b08d22647935..fa52387467da 100644
--- a/graphics/libGLw/Makefile
+++ b/graphics/libGLw/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS+= makedepend:${PORTSDIR}/devel/makedepend
LIB_DEPENDS+= Xm.3:${PORTSDIR}/x11-toolkits/open-motif
USE_GL= gl
-USE_XORG= glproto xt x11 xext xxf86vm xdamage xfixes
+USE_XORG= glproto xt x11 xext xxf86vm xdamage xfixes dri2proto
do-install:
cd ${WRKSRC}/src/glw; ${GMAKE} install
diff --git a/graphics/libglut/Makefile b/graphics/libglut/Makefile
index e56f68625fe2..987b0ae8d374 100644
--- a/graphics/libglut/Makefile
+++ b/graphics/libglut/Makefile
@@ -14,7 +14,7 @@ COMMENT= OpenGL utility toolkit
USE_LDCONFIG= yes
USE_GL= glu
-USE_XORG= glproto x11 xext xxf86vm xdamage xfixes xi xmu
+USE_XORG= glproto x11 xext xxf86vm xdamage xfixes xi xmu dri2proto
do-install:
cd ${WRKSRC}/src/glut/glx; ${GMAKE} install
diff --git a/graphics/mesa-demos/Makefile b/graphics/mesa-demos/Makefile
index 518a4261e661..15d98a8a17e8 100644
--- a/graphics/mesa-demos/Makefile
+++ b/graphics/mesa-demos/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= araujo@FreeBSD.org
COMMENT= OpenGL demos distributed with Mesa
USE_GL= glu glut
-USE_XORG= glproto x11 xext xxf86vm xdamage xfixes
+USE_XORG= glproto x11 xext xxf86vm xdamage xfixes dri2proto
DATADIR= ${PREFIX}/share/${PKGNAMEPREFIX}${PORTNAME}