aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-03-08 10:33:18 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-03-08 10:33:18 +0800
commit2aeed9645daffb5d14c00dc44af2715fdd786684 (patch)
tree9bdc5e8845d349f3eecbc732d596bd62dd79ebda /graphics
parent48b5543ddd3dd29023d25de0eb903e6bb8a7d61c (diff)
downloadfreebsd-ports-gnome-2aeed9645daffb5d14c00dc44af2715fdd786684.tar.gz
freebsd-ports-gnome-2aeed9645daffb5d14c00dc44af2715fdd786684.tar.zst
freebsd-ports-gnome-2aeed9645daffb5d14c00dc44af2715fdd786684.zip
- Simplify MASTER_SITES
- Clarify LICENSE - Add LICENSE_FILE - Fix whitespace - Strip binary
Diffstat (limited to 'graphics')
-rw-r--r--graphics/camera/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/graphics/camera/Makefile b/graphics/camera/Makefile
index 7f576349bfd4..fc750c7dc399 100644
--- a/graphics/camera/Makefile
+++ b/graphics/camera/Makefile
@@ -3,20 +3,21 @@
PORTNAME= camera
PORTVERSION= 0.8
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics gnustep
MASTER_SITES= http://download.gna.org/gsimageapps/ \
- ${MASTER_SITE_GNUSTEP_CH}
+ GNUSTEP_CH
DISTNAME= Camera-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GNUstep application for digital still cameras
-LICENSE= GPLv2
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/Documentation/COPYING
LIB_DEPENDS= libgphoto2_port.so:${PORTSDIR}/graphics/libgphoto2
-USES= tar:bzip2
+USES= tar:bzip2
USE_GNUSTEP= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
@@ -28,4 +29,7 @@ post-patch:
${REINPLACE_CMD} 's|^GNUSTEP_INSTALLATION_DIR|#GNUSTEP_INSTALLATION_DIR|' \
${WRKSRC}/GNUmakefile
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Applications/Camera.app/Camera
+
.include <bsd.port.mk>