aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorwoodsb02 <woodsb02@FreeBSD.org>2016-05-19 00:23:35 +0800
committerwoodsb02 <woodsb02@FreeBSD.org>2016-05-19 00:23:35 +0800
commit32c1275b373c0b28bd9870c1ab458b37b9dd04ec (patch)
tree05b69b94aa3202b159944156e15d2fcee4a489f7 /graphics
parentfb35750953e2fc68bb5d80dfc22b1628772b6716 (diff)
downloadfreebsd-ports-gnome-32c1275b373c0b28bd9870c1ab458b37b9dd04ec.tar.gz
freebsd-ports-gnome-32c1275b373c0b28bd9870c1ab458b37b9dd04ec.tar.zst
freebsd-ports-gnome-32c1275b373c0b28bd9870c1ab458b37b9dd04ec.zip
Create new port graphics/py3-pillow:
- This is a variant of graphics/py-pillow for Python 3.x. A separate port is needed until the ports tree gets VARIANTS support. The science/gramps port will soon be updated to a version which only supports python3, and it depends on py-pillow with python3. To allow people to only use packages directly (and not ports), the package building infrastructure needs to build 2 packages: py-pillow with python2 and py-pillow with python3. Since the ports tree doesn't yet have VARIANTS support, this is not yet possible without making a separate py3-pillow port. - Ensure graphics/py-pillow does not clobber USES and TKINTER_xxx_DEPENDS variables in slave port - Remove duplicate USES= line in graphics/py-pillow PR: 207040 Approved by: mat, adamw (mentors), koobs (maintainer) Differential Revision: https://reviews.freebsd.org/D6433
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-pillow/Makefile7
-rw-r--r--graphics/py3-pillow/Makefile11
3 files changed, 15 insertions, 4 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 90a6e6041f6e..9906bb7b5e99 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -881,6 +881,7 @@
SUBDIR += py-wand
SUBDIR += py-webcolors
SUBDIR += py3-cairo
+ SUBDIR += py3-pillow
SUBDIR += pygts
SUBDIR += pymorph
SUBDIR += pysvg
diff --git a/graphics/py-pillow/Makefile b/graphics/py-pillow/Makefile
index 940c3edba2b3..4f74ac22711f 100644
--- a/graphics/py-pillow/Makefile
+++ b/graphics/py-pillow/Makefile
@@ -41,8 +41,8 @@ TIFF_VARS= PYDISTUTILS_BUILDARGS+=--enable-tiff
TIFF_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-tiff
TKINTER_USES= tk
-TKINTER_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter
-TKINTER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter
+TKINTER_BUILD_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter
+TKINTER_RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter
TKINTER_VARS= PYDISTUTILS_BUILDARGS+="--enable-tcl --enable-tk --include-dirs=${TCL_INCLUDEDIR}:${TK_INCLUDEDIR}"
TKINTER_VARS_OFF= PYDISTUTILS_BUILDARGS+="--disable-tcl --disable-tk"
@@ -50,9 +50,8 @@ WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
WEBP_VARS= PYDISTUTILS_BUILDARGS+=--enable-webp
WEBP_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-webp
-USES= cpe python
+USES?= cpe python
USE_GITHUB= yes
-USES= python
USE_PYTHON= autoplist concurrent distutils
GH_ACCOUNT= python-${PORTNAME}
diff --git a/graphics/py3-pillow/Makefile b/graphics/py3-pillow/Makefile
new file mode 100644
index 000000000000..d95a17090886
--- /dev/null
+++ b/graphics/py3-pillow/Makefile
@@ -0,0 +1,11 @@
+# Created by: Ben Woods <woodsb02@FreeBSD.org>
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-pillow
+
+TKINTER_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/${PYTHON_PKGNAMEPREFIX}tkinter
+TKINTER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/${PYTHON_PKGNAMEPREFIX}tkinter
+
+USES= cpe python:3.2+
+
+.include "${MASTERDIR}/Makefile"