aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2010-08-06 03:03:52 +0800
committerosa <osa@FreeBSD.org>2010-08-06 03:03:52 +0800
commit359086187ec4946efe6e41ff267f64b9ab0d8f46 (patch)
tree8293e9c58cb19d91a98aa17b3f2aa27d248eab8c /graphics
parent52c91b8f7f2d9edf5e558046138c6061862abd1c (diff)
downloadfreebsd-ports-gnome-359086187ec4946efe6e41ff267f64b9ab0d8f46.tar.gz
freebsd-ports-gnome-359086187ec4946efe6e41ff267f64b9ab0d8f46.tar.zst
freebsd-ports-gnome-359086187ec4946efe6e41ff267f64b9ab0d8f46.zip
1) Fix build with threads;
2) ECW support now requires threads; 3) Build with internal libtiff by default (supports BigTiff); Do not bump PORTREVISION. Submitted by: glebius (maintainer)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gdal/Makefile28
1 files changed, 17 insertions, 11 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index 2784a1b18851..62d320eebf29 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -31,7 +31,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
OPTIONS= CFITSIO "FITS support" off \
CURL "Curl support" off \
- ECW "ECW & JPEG2000 support" off \
+ ECW "ECW & JPEG2000 support (THREAD required)" off \
EXPAT "Expat support" off \
GEOS "GEOS support" off \
GEOTIFF "GeoTIFF support" on \
@@ -52,8 +52,8 @@ OPTIONS= CFITSIO "FITS support" off \
PYTHON "Python support" on \
RUBY "Ruby support" off \
SQLITE "SQLite support" off \
- THREAD "Thread support" off\
- TIFF "TIFF support" on \
+ THREAD "Thread support" off \
+ TIFF "External libtiff" off \
XERCES "Xerces support" off
.include <bsd.port.pre.mk>
@@ -72,13 +72,6 @@ CONFIGURE_ARGS+= --with-curl=${LOCALBASE}/bin/curl-config
CONFIGURE_ARGS+= --with-curl=no
.endif
-.if defined(WITH_ECW)
-LIB_DEPENDS+= NCSEcw.0:${PORTSDIR}/graphics/libecwj2
-CONFIGURE_ARGS+= --with-ecw=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --with-ecw=no
-.endif
-
.if defined(WITH_EXPAT)
LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
CONFIGURE_ARGS+= --with-expat=${LOCALBASE} \
@@ -218,13 +211,26 @@ CONFIGURE_ARGS+= --with-sqlite=no
.endif
.if !defined(WITHOUT_THREAD)
-CONFIGURE_ARGS+= --with-threads=${PTHREAD_LIBS}
+CONFIGURE_ARGS+= --with-threads=yes
CONFIGURE_ENV+= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"
+.if defined(WITH_ECW)
+LIB_DEPENDS+= NCSEcw.0:${PORTSDIR}/graphics/libecwj2
+CONFIGURE_ARGS+= --with-ecw=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --with-ecw=no
+.endif
+.else
+CONFIGURE_ARGS+= --with-threads=no
+.if defined(WITH_ECW)
+IGNORE= THREAD option required. Please 'make config' again
+.endif
.endif
.if !defined(WITHOUT_TIFF)
LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
CONFIGURE_ARGS+= --with-libtiff=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --with-libtiff=internal
.endif
.if defined(WITH_XERCES)