aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-07-19 19:04:13 +0800
committermat <mat@FreeBSD.org>2016-07-19 19:04:13 +0800
commit363acdd313a37f491e4b2d6b9a807df489cfc5d9 (patch)
treebe6eebf3e77ddf9fcf383081091d8b8b336dd71c /graphics
parent64a47229a8791073130cac02039b944cc8102750 (diff)
downloadfreebsd-ports-gnome-363acdd313a37f491e4b2d6b9a807df489cfc5d9.tar.gz
freebsd-ports-gnome-363acdd313a37f491e4b2d6b9a807df489cfc5d9.tar.zst
freebsd-ports-gnome-363acdd313a37f491e4b2d6b9a807df489cfc5d9.zip
When there is a do-install target, do not use a post-install target, do
everything at once. Sometime, rename post-install into a options helper target. I did not fix ports that were such a mess that I could not figure out what they really wanted to do. I also did not change ports that had some version of an auto-plist code in post-install, for the same reason. With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'graphics')
-rw-r--r--graphics/SciPlot/Makefile4
-rw-r--r--graphics/argyllcms/Makefile2
-rw-r--r--graphics/gimpfx-foundry/Makefile2
-rw-r--r--graphics/libgltext/Makefile6
-rw-r--r--graphics/mapserver/Makefile1
-rw-r--r--graphics/openjump/Makefile1
-rw-r--r--graphics/optipng/Makefile1
-rw-r--r--graphics/ruby-image_size/Makefile2
8 files changed, 7 insertions, 12 deletions
diff --git a/graphics/SciPlot/Makefile b/graphics/SciPlot/Makefile
index 4c1f6fd49b53..d8f1be45e452 100644
--- a/graphics/SciPlot/Makefile
+++ b/graphics/SciPlot/Makefile
@@ -34,9 +34,11 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${LIBNAME}.so.0 ${STAGEDIR}${PREFIX}/lib
${LN} -sf ${LIBNAME}.so.0 ${STAGEDIR}${PREFIX}/lib/${LIBNAME}.so
-post-install:
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${EXDATA:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_PROGRAM} ${EXBINS:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
diff --git a/graphics/argyllcms/Makefile b/graphics/argyllcms/Makefile
index c2fe55c70130..65d1394d1135 100644
--- a/graphics/argyllcms/Makefile
+++ b/graphics/argyllcms/Makefile
@@ -35,8 +35,6 @@ do-install:
jam -q -fJambase -j${MAKE_JOBS_NUMBER} install
@${MV} ${STAGEDIR}${PREFIX}/bin/License.txt \
${STAGEDIR}${PREFIX}/share/argyll/
-
-post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
.include <bsd.port.mk>
diff --git a/graphics/gimpfx-foundry/Makefile b/graphics/gimpfx-foundry/Makefile
index fbac1559503b..39d9fe958085 100644
--- a/graphics/gimpfx-foundry/Makefile
+++ b/graphics/gimpfx-foundry/Makefile
@@ -27,7 +27,7 @@ do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/share/gimp/scripts/
${INSTALL_DATA} ${WRKSRC}/*.scm ${STAGEDIR}${PREFIX}/share/gimp/scripts/
-post-install:
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/release-notes.txt ${STAGEDIR}${DOCSDIR}
diff --git a/graphics/libgltext/Makefile b/graphics/libgltext/Makefile
index 73856300d059..08fb5bb5154d 100644
--- a/graphics/libgltext/Makefile
+++ b/graphics/libgltext/Makefile
@@ -27,7 +27,6 @@ EXAMPLES_DESC= Compile examples, need libglut
.if ${PORT_OPTIONS:MEXAMPLES}
USE_GL+= glut
USE_XORG= xmu
-FLAG_EXAMPLES= true
PLIST_SUB+= EXAMPLES=""
.else
PLIST_SUB+= EXAMPLES="@comment "
@@ -45,13 +44,13 @@ do-install:
@cd ${STAGEDIR}${PREFIX}/lib && \
${LN} -s ${PORTNAME}.so.0 ${PORTNAME}.so
-post-install:
+post-install-DOCS-on:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/doc/tutorial.txt ${STAGEDIR}${DOCSDIR}
.endif
-.if defined(FLAG_EXAMPLES)
+post-install-EXAMPLES-on:
.for DIRE in alpha fps simple sizes
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/${DIRE}
@cd ${WRKSRC}/examples && \
@@ -60,6 +59,5 @@ post-install:
@${ECHO_MSG} ""
@${ECHO_MSG} " Examples source and binary on ${STAGEDIR}${EXAMPLESDIR}"
@${ECHO_MSG} ""
-.endif
.include <bsd.port.mk>
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index 02cbe9d0de3f..ed167da594e3 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -199,7 +199,6 @@ do-install:
(cd ${BUILD_WRKSRC}/mapscript/python && ${CP} mapscript.py _mapscript.so ${STAGEDIR}${PYTHON_SITELIBDIR}/)
.endif
-post-install:
@${LN} -s ${PREFIX}/lib/libmapserver.so.7.0.1 ${STAGEDIR}${PREFIX}/lib/libmapserver.so.2
@${LN} -s ${PREFIX}/lib/libmapserver.so.2 ${STAGEDIR}${PREFIX}/lib/libmapserver.so
diff --git a/graphics/openjump/Makefile b/graphics/openjump/Makefile
index 0bb5a630801a..7beb9e55ad77 100644
--- a/graphics/openjump/Makefile
+++ b/graphics/openjump/Makefile
@@ -66,7 +66,6 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/bin/log4j.xml ${TARGET_DIR}/bin/
${INSTALL_DATA} ${WRKSRC}/readme.txt ${TARGET_DIR}/bin/
-post-install:
@${ECHO_MSG} "---> Installing documentation"
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Changes.txt ${STAGEDIR}${DOCSDIR}
diff --git a/graphics/optipng/Makefile b/graphics/optipng/Makefile
index 736fb4667fa8..a896e7829d8a 100644
--- a/graphics/optipng/Makefile
+++ b/graphics/optipng/Makefile
@@ -36,7 +36,6 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/optipng/optipng ${STAGEDIR}${PREFIX}/bin/
${INSTALL_MAN} ${WRKSRC}/src/optipng/man/optipng.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/
-post-install:
${INSTALL} -d ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${STAGEDIR}${DOCSDIR}/
diff --git a/graphics/ruby-image_size/Makefile b/graphics/ruby-image_size/Makefile
index 52a60c5a281a..bba09d889414 100644
--- a/graphics/ruby-image_size/Makefile
+++ b/graphics/ruby-image_size/Makefile
@@ -32,7 +32,7 @@ do-install:
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}/
${INSTALL_DATA} ${WRKSRC}/lib/image_size.rb ${STAGEDIR}${RUBY_SITELIBDIR}/
-post-install:
+post-install-DOCS-on::
${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}/ja
.for f in ${DOCS_EN}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/