aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2006-05-25 12:00:57 +0800
committersem <sem@FreeBSD.org>2006-05-25 12:00:57 +0800
commit3915d32f883a431bb0538317c2f8de5bc873f8fd (patch)
tree34b5014b035fb5573ec8acd1cb5426f124ca3402 /graphics
parent78084bf6e0889cb6177273ae95dbd3028c5962c9 (diff)
downloadfreebsd-ports-gnome-3915d32f883a431bb0538317c2f8de5bc873f8fd.tar.gz
freebsd-ports-gnome-3915d32f883a431bb0538317c2f8de5bc873f8fd.tar.zst
freebsd-ports-gnome-3915d32f883a431bb0538317c2f8de5bc873f8fd.zip
GREYCstoration is a Gimp plugin using the algorithm written by David Tschumperle
from GREYC laboratory (at Caen in France). WWW: http://www.haypocalc.com/wiki/GREYCstoration_in_english PR: ports/94124 Submitted by: Elisey O. Savateev <b3k@mail.ru>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/gimp-greycstoration/Makefile34
-rw-r--r--graphics/gimp-greycstoration/distinfo3
-rw-r--r--graphics/gimp-greycstoration/pkg-descr7
-rw-r--r--graphics/gimp-greycstoration/pkg-plist2
5 files changed, 47 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index aac504675e53..3e6efedb2b81 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -157,6 +157,7 @@
SUBDIR += giftrans
SUBDIR += gimageview
SUBDIR += gimp
+ SUBDIR += gimp-greycstoration
SUBDIR += gimp-help
SUBDIR += gimp-manual-html
SUBDIR += gimp-manual-pdf
diff --git a/graphics/gimp-greycstoration/Makefile b/graphics/gimp-greycstoration/Makefile
new file mode 100644
index 000000000000..f69c40f93675
--- /dev/null
+++ b/graphics/gimp-greycstoration/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: gimp-greycstoration
+# Date created: 6 March 2006
+# Whom: Elisey Savateev <b3k@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= greycstoration
+PORTVERSION= 0.2.0
+CATEGORIES= graphics
+MASTER_SITES= http://www.haypocalc.com/perso/prog/greycstoration/ \
+ http://bio3k.softboard.ru/uploads/arch/
+PKGNAMEPREFIX= gimp-
+
+MAINTAINER= b3k@mail.ru
+COMMENT= Gimp plugin used for noise reduction
+
+BUILD_DEPENDS= gimp:${PORTSDIR}/graphics/gimp \
+ ${SITE_PERL}/mach/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+
+# Redifine this if you need
+PLUGIN_DIR?= libexec/gimp/2.2/plug-ins
+
+PLIST_SUB= PLUGIN_DIR=${PLUGIN_DIR}
+
+post-extract:
+ @${REINPLACE_CMD} -e 's|$$(GIMP_LIBDIR)/plug-ins|${PREFIX}/${PLUGIN_DIR}|g' ${WRKSRC}/src/Makefile.in ${WRKSRC}/src/Makefile.am
+
+.include <bsd.port.mk>
diff --git a/graphics/gimp-greycstoration/distinfo b/graphics/gimp-greycstoration/distinfo
new file mode 100644
index 000000000000..4d9d5d4609fd
--- /dev/null
+++ b/graphics/gimp-greycstoration/distinfo
@@ -0,0 +1,3 @@
+MD5 (greycstoration-0.2.0.tar.bz2) = 3ec7b4d5895a54fbc407916c318ef937
+SHA256 (greycstoration-0.2.0.tar.bz2) = aa2a2f5b81134a02caf056085db22526bb3962d4deccb1885fa96395e37933a9
+SIZE (greycstoration-0.2.0.tar.bz2) = 193064
diff --git a/graphics/gimp-greycstoration/pkg-descr b/graphics/gimp-greycstoration/pkg-descr
new file mode 100644
index 000000000000..80c68c31c21a
--- /dev/null
+++ b/graphics/gimp-greycstoration/pkg-descr
@@ -0,0 +1,7 @@
+GREYCstoration is a Gimp plugin using the algorithm written by David Tschumperle
+from GREYC laboratory (at Caen in France).
+
+WWW: http://www.haypocalc.com/wiki/GREYCstoration_in_english
+
+- Elisey Savateev
+b3k@mail.ru
diff --git a/graphics/gimp-greycstoration/pkg-plist b/graphics/gimp-greycstoration/pkg-plist
new file mode 100644
index 000000000000..7ffbb2b1a182
--- /dev/null
+++ b/graphics/gimp-greycstoration/pkg-plist
@@ -0,0 +1,2 @@
+%%PLUGIN_DIR%%/greycstoration
+@dirrmtry %%PLUGIN_DIR%%