aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-03-05 13:44:39 +0800
committermarcus <marcus@FreeBSD.org>2003-03-05 13:44:39 +0800
commit39944c0d6540f07423a42cc69426898800764bfc (patch)
treec4a467ae8cf86b0b8bc617e6baa2e2e77473160b /graphics
parentfcb7bec08b996d8f234c3b1d250f59dca6a73f0a (diff)
downloadfreebsd-ports-gnome-39944c0d6540f07423a42cc69426898800764bfc.tar.gz
freebsd-ports-gnome-39944c0d6540f07423a42cc69426898800764bfc.tar.zst
freebsd-ports-gnome-39944c0d6540f07423a42cc69426898800764bfc.zip
Fix a hang on exit on -CURRENT.
Approved by: maintainer timeout
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gthumb2/Makefile1
-rw-r--r--graphics/gthumb2/files/patch-libgthumb_image-loader.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/graphics/gthumb2/Makefile b/graphics/gthumb2/Makefile
index 1a40c4f38e44..f4032abddf99 100644
--- a/graphics/gthumb2/Makefile
+++ b/graphics/gthumb2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gthumb2
PORTVERSION= 2.1.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.1
diff --git a/graphics/gthumb2/files/patch-libgthumb_image-loader.c b/graphics/gthumb2/files/patch-libgthumb_image-loader.c
new file mode 100644
index 000000000000..461a0048fa61
--- /dev/null
+++ b/graphics/gthumb2/files/patch-libgthumb_image-loader.c
@@ -0,0 +1,14 @@
+--- libgthumb/image-loader.c.orig Mon Mar 3 15:45:30 2003
++++ libgthumb/image-loader.c Mon Mar 3 15:45:32 2003
+@@ -534,8 +534,10 @@
+ image_loader_sync_pixbuf (il);
+
+ priv->done_func = NULL;
+- if (done_func != NULL)
++ if (done_func != NULL) {
+ (*done_func) (priv->done_func_data);
++ return;
++ }
+
+ if (! priv->emit_signal)
+ return;