aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2013-05-23 03:34:18 +0800
committeroliver <oliver@FreeBSD.org>2013-05-23 03:34:18 +0800
commit5ad7f5beddec967eb3701dcb050eddcd89385e07 (patch)
treea1257305498b16428f9fe3508509e793457c2f77 /graphics
parent6c8ecd060f41b4757e5f1d8bcbbfec00bccccc0b (diff)
downloadfreebsd-ports-gnome-5ad7f5beddec967eb3701dcb050eddcd89385e07.tar.gz
freebsd-ports-gnome-5ad7f5beddec967eb3701dcb050eddcd89385e07.tar.zst
freebsd-ports-gnome-5ad7f5beddec967eb3701dcb050eddcd89385e07.zip
add patch file to fix building in case textproc/tinyxml is installed on the system
PR: 175763
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ogre3d/files/patch-Tools_XMLConverter_CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/graphics/ogre3d/files/patch-Tools_XMLConverter_CMakeLists.txt b/graphics/ogre3d/files/patch-Tools_XMLConverter_CMakeLists.txt
new file mode 100644
index 000000000000..05a2faad21e4
--- /dev/null
+++ b/graphics/ogre3d/files/patch-Tools_XMLConverter_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- Tools/XMLConverter/CMakeLists.txt.orig 2013-05-21 20:52:22.000000000 +0200
++++ Tools/XMLConverter/CMakeLists.txt 2013-05-21 20:52:22.000000000 +0200
+@@ -27,6 +27,7 @@
+ src/tinyxmlparser.cpp
+ )
+
++set (CMAKE_INCLUDE_DIRECTORIES_BEFORE ON)
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include)
+ add_definitions(-DTIXML_USE_STL)
+ ogre_add_executable(OgreXMLConverter ${HEADER_FILES} ${SOURCE_FILES})