aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-10-31 06:08:14 +0800
committerjgh <jgh@FreeBSD.org>2012-10-31 06:08:14 +0800
commit5b37dd910ee4758cc907ac1ea86fa7e851d5bb26 (patch)
tree3644f8a4580de70b2357c3bc32156cebe3b9888a /graphics
parent9f7d30030447643174af5a509a1d1dff35ee688a (diff)
downloadfreebsd-ports-gnome-5b37dd910ee4758cc907ac1ea86fa7e851d5bb26.tar.gz
freebsd-ports-gnome-5b37dd910ee4758cc907ac1ea86fa7e851d5bb26.tar.zst
freebsd-ports-gnome-5b37dd910ee4758cc907ac1ea86fa7e851d5bb26.zip
- add additional support for tomcat7 and adjust pkg-message accordingly
PR: 173126 Submitted by: nemysis@gmx.ch Patch by: jgh Approved by: maintainer, wen Feature safe: yes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/deegree-wfs/Makefile35
-rw-r--r--graphics/deegree-wfs/files/pkg-message.in (renamed from graphics/deegree-wfs/pkg-message)2
2 files changed, 26 insertions, 11 deletions
diff --git a/graphics/deegree-wfs/Makefile b/graphics/deegree-wfs/Makefile
index 82b66087b9a0..3ed772324277 100644
--- a/graphics/deegree-wfs/Makefile
+++ b/graphics/deegree-wfs/Makefile
@@ -13,25 +13,43 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_${PORTVERSION}
MAINTAINER= wenheping@gmail.com
COMMENT= Deegree Web Feature Service(WFS)
-RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
-
USE_ZIP= yes
USE_JAVA= 1.5+
NO_BUILD= yes
-TOMCATVER= apache-tomcat-6.0
TOMCATDIR= ${PREFIX}/${TOMCATVER}
+APPHOME= ${LOCALBASE}/${TOMCATVER}
WEBAPPDIR= ${TOMCATDIR}/webapps
-PORTDOCS= *
+PORTDOCS= README.txt deegree_wfs_documentation_en.pdf
DOCSDIR= ${PREFIX}/share/doc/deegree-wfs
PLIST_SUB= TOMCATDIR=${TOMCATDIR:S|^${PREFIX}/||}
+SUB_FILES= pkg-message
+SUB_LIST= TCPORT=${TCPORT}
+
+OPTIONS_SINGLE= AS
+OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
+OPTIONS_DEFAULT= TOMCAT6
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTOMCAT6}
+TOMCATVER= apache-tomcat-6.0
+TCPORT= 8180
+BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
+RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
+.endif
+
+.if ${PORT_OPTIONS:MTOMCAT7}
+TOMCATVER= apache-tomcat-7.0
+TCPORT= 8080
+BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat7
+RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat7
+.endif
post-extract:
@${MKDIR} ${WRKDIR}/${PORTDIRNAME}
@${TAR} xf ${WRKDIR}/deegree-wfs.war -C ${WRKDIR}/${PORTDIRNAME}
-.include <bsd.port.options.mk>
-
do-install:
cd ${WRKDIR} && \
${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
@@ -39,11 +57,8 @@ do-install:
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/README.txt ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/deegree_wfs_documentation_en.pdf ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKDIR}/|} ${DOCSDIR}
.endif
-
-post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/graphics/deegree-wfs/pkg-message b/graphics/deegree-wfs/files/pkg-message.in
index 66fb4805bfe1..e322d5843ff5 100644
--- a/graphics/deegree-wfs/pkg-message
+++ b/graphics/deegree-wfs/files/pkg-message.in
@@ -4,7 +4,7 @@ To start DeeGree correctly, please set the variable JAVA_OPTS with:
setenv JAVA_OPTS "-server -Xms256m -Xmx512m"
Now you should start your Tomcat server and browse with:
- http://your-server:8180/deegree-wfs
+ http://your-server:%%TCPORT%%/deegree-wfs
Enjoy it !
==========================================================================