aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-07-09 17:01:35 +0800
committermiwi <miwi@FreeBSD.org>2009-07-09 17:01:35 +0800
commit69a42a6e85cdb48922e2c9acac79e4cfd9e1949e (patch)
treee74d036dedceefe4cc35b4174f0a1766fcd4c6a9 /graphics
parent1148e1c1859120de822643dd67804e478cff999f (diff)
downloadfreebsd-ports-gnome-69a42a6e85cdb48922e2c9acac79e4cfd9e1949e.tar.gz
freebsd-ports-gnome-69a42a6e85cdb48922e2c9acac79e4cfd9e1949e.tar.zst
freebsd-ports-gnome-69a42a6e85cdb48922e2c9acac79e4cfd9e1949e.zip
Pycha is a very simple Python package for drawing charts using the
great Cairo library. Its goals are: * Lightweight * Simple to use * Nice looking with default values * Customization It won't try to draw any possible chart on earth but draw the most common ones nicely. WWW: http://bitbucket.org/lgs/pycha/wiki/Home PR: ports/136597 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-pycha/Makefile28
-rw-r--r--graphics/py-pycha/distinfo3
-rw-r--r--graphics/py-pycha/pkg-descr10
-rw-r--r--graphics/py-pycha/pkg-plist2
5 files changed, 44 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index c449ec826c2e..fd5e6f89e865 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -734,6 +734,7 @@
SUBDIR += py-opengl
SUBDIR += py-paint
SUBDIR += py-poppler
+ SUBDIR += py-pycha
SUBDIR += py-pydot
SUBDIR += py-pyglet
SUBDIR += py-pygooglechart
diff --git a/graphics/py-pycha/Makefile b/graphics/py-pycha/Makefile
new file mode 100644
index 000000000000..8a8cac5729c9
--- /dev/null
+++ b/graphics/py-pycha/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: pycha
+# Date created: 08 July, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pycha
+PORTVERSION= 0.5.0
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A library for making charts with Python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+OPTIONS= CAIRO "Add support for py-cairo" On
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_CAIRO)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/cairo:${PORTSDIR}/graphics/py-cairo
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/py-pycha/distinfo b/graphics/py-pycha/distinfo
new file mode 100644
index 000000000000..46f9d789b29a
--- /dev/null
+++ b/graphics/py-pycha/distinfo
@@ -0,0 +1,3 @@
+MD5 (pycha-0.5.0.tar.gz) = bb9038b89d001d7afea9b12b7f0edc11
+SHA256 (pycha-0.5.0.tar.gz) = b750eeff0a83996bf9f5d05ab678066bcff88784ff8643add3041d7c9d74916f
+SIZE (pycha-0.5.0.tar.gz) = 195610
diff --git a/graphics/py-pycha/pkg-descr b/graphics/py-pycha/pkg-descr
new file mode 100644
index 000000000000..d510e861151c
--- /dev/null
+++ b/graphics/py-pycha/pkg-descr
@@ -0,0 +1,10 @@
+Pycha is a very simple Python package for drawing charts using the
+great Cairo library. Its goals are:
+ * Lightweight
+ * Simple to use
+ * Nice looking with default values
+ * Customization
+It won't try to draw any possible chart on earth but draw the most
+common ones nicely.
+
+WWW: http://bitbucket.org/lgs/pycha/wiki/Home
diff --git a/graphics/py-pycha/pkg-plist b/graphics/py-pycha/pkg-plist
new file mode 100644
index 000000000000..6ea13162380d
--- /dev/null
+++ b/graphics/py-pycha/pkg-plist
@@ -0,0 +1,2 @@
+bin/chavier
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%