aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2014-04-15 05:09:48 +0800
committerthierry <thierry@FreeBSD.org>2014-04-15 05:09:48 +0800
commit6dc4fa3f3d0bff5d08f791fdf8b6f5471c2c53d1 (patch)
tree320ff740ff9c0b661e503be8844b5e860062ed11 /graphics
parent554404bac00f5eaab35cb8696018b729c6f8d4a3 (diff)
downloadfreebsd-ports-gnome-6dc4fa3f3d0bff5d08f791fdf8b6f5471c2c53d1.tar.gz
freebsd-ports-gnome-6dc4fa3f3d0bff5d08f791fdf8b6f5471c2c53d1.tar.zst
freebsd-ports-gnome-6dc4fa3f3d0bff5d08f791fdf8b6f5471c2c53d1.zip
- Support stage;
- Change the missing home page for the Darwin page.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/SciPlot/Makefile23
-rw-r--r--graphics/SciPlot/pkg-descr2
2 files changed, 11 insertions, 14 deletions
diff --git a/graphics/SciPlot/Makefile b/graphics/SciPlot/Makefile
index 2fdfe4b43e65..4d3171e14078 100644
--- a/graphics/SciPlot/Makefile
+++ b/graphics/SciPlot/Makefile
@@ -26,25 +26,22 @@ PORTDOCS= README SciPlot.html SciPlotDemo.html SciPlotProg.html
EXDATA= data.txt
EXBINS= realtime sciplot
-NO_STAGE= yes
do-install:
- ${MKDIR} ${PREFIX}/include/${PORTNAME}
- ${INSTALL_DATA} ${INCLUDES:S|^|${WRKSRC}/|} ${PREFIX}/include/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/${LIBNAME}.a ${PREFIX}/lib
- ${INSTALL_PROGRAM} ${WRKSRC}/${LIBNAME}.so.0 ${PREFIX}/lib
- (cd ${PREFIX}/lib; ${LN} -sf ${LIBNAME}.so.0 ${LIBNAME}.so)
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/${PORTNAME}
+ ${INSTALL_DATA} ${INCLUDES:S|^|${WRKSRC}/|} ${STAGEDIR}${PREFIX}/include/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/${LIBNAME}.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_PROGRAM} ${WRKSRC}/${LIBNAME}.so.0 ${STAGEDIR}${PREFIX}/lib
+ ${LN} -sf ${LIBNAME}.so.0 ${STAGEDIR}${PREFIX}/lib/${LIBNAME}.so
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.endif
.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${EXDATA:S|^|${WRKSRC}/|} ${EXAMPLESDIR}
- ${INSTALL_PROGRAM} ${EXBINS:S|^|${WRKSRC}/|} ${EXAMPLESDIR}
- @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${EXDATA:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_PROGRAM} ${EXBINS:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/graphics/SciPlot/pkg-descr b/graphics/SciPlot/pkg-descr
index d1d97248735d..8f3976be3c05 100644
--- a/graphics/SciPlot/pkg-descr
+++ b/graphics/SciPlot/pkg-descr
@@ -10,4 +10,4 @@ specification, dashed lines, symbols drawn at points, logarithmic scales on one
or both axes in cartesian plots, and degrees or radians as angles in polar
plots.
-WWW: http://www.questconsult.com/~jrm/SciPlot.html
+WWW: http://src.gnu-darwin.org/ports/graphics/SciPlot/work/SciPlot-1.36/SciPlot.html