aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-12-06 02:16:49 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-12-06 02:16:49 +0800
commit6e483d8bdddacf66e5ee7a8b375dcfd43d466136 (patch)
treef9549df518302c77db9de7835b56689660c5769b /graphics
parenta2e50c7e1c605122ac81132973bcd8f3e456c4f5 (diff)
downloadfreebsd-ports-gnome-6e483d8bdddacf66e5ee7a8b375dcfd43d466136.tar.gz
freebsd-ports-gnome-6e483d8bdddacf66e5ee7a8b375dcfd43d466136.tar.zst
freebsd-ports-gnome-6e483d8bdddacf66e5ee7a8b375dcfd43d466136.zip
- Add an option to select GUI toolkit
- Switch default to gtk2 as per documentation - Update depends PR: 223672 Submitted by: bsdpr@phoe.frmug.org
Diffstat (limited to 'graphics')
-rw-r--r--graphics/geeqie/Makefile21
1 files changed, 17 insertions, 4 deletions
diff --git a/graphics/geeqie/Makefile b/graphics/geeqie/Makefile
index 2595b42398e6..33bdef37fd6e 100644
--- a/graphics/geeqie/Makefile
+++ b/graphics/geeqie/Makefile
@@ -3,7 +3,7 @@
PORTNAME= geeqie
PORTVERSION= 1.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://www.geeqie.org/
@@ -17,18 +17,24 @@ LIB_DEPENDS= libpng.so:graphics/png
USES= autoreconf gettext gmake jpeg localbase pkgconfig \
desktop-file-utils tar:xz lua:51
-USE_GNOME= gtk30 intltool
+USE_GNOME= intltool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-readmedir="${DOCSDIR}"
PORTDOCS= *
OPTIONS_DEFINE= EXIV2 LCMS LIRC GPS TIFF DOCS
-OPTIONS_DEFAULT=EXIV2 LCMS
+OPTIONS_DEFAULT=EXIV2 LCMS GTK2
+OPTIONS_SINGLE= TOOLKIT
+OPTIONS_SINGLE_TOOLKIT=GTK2 GTK3
+
EXIV2_DESC= Metadata editing
LCMS_DESC= Color adjusting
LIRC_DESC= Remote control
GPS_DESC= GPS map support via libchamplain (experimental!)
+TOOLKIT_DESC= Graphical user interface toolkit
+GTK2_DESC= Use GTK 2
+GTK3_DESC= Use GTK 3
EXIV2_LIB_DEPENDS= libexiv2.so:graphics/exiv2
EXIV2_CONFIGURE_ENABLE= exiv2
@@ -38,14 +44,21 @@ LCMS_CONFIGURE_ENABLE= lcms
LIRC_LIB_DEPENDS= liblirc_client.so:comms/lirc
LIRC_CONFIGURE_ENABLE= lirc
+LIRC_CONFIGURE_ON= --with-lirc-prefix="${LOCALBASE}"
GPS_LIB_DEPENDS= libchamplain-0.12.so:graphics/libchamplain \
libclutter-gtk-1.0.so:graphics/clutter-gtk3
-GPS_CONFIGURE_ENABLE= gps clutter
+GPS_CONFIGURE_ENABLE= map gpu-accell
TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
TIFF_CONFIGURE_ENABLE= tiff
+GTK2_USE= GNOME=gtk20
+GTK3_USE= GNOME=gtk30
+GTK3_CONFIGURE_ENABLE= gtk3
+GTK3_PREVENTS= GPS
+GTK3_PREVENTS_MSG= GPS option does not support GTK3 yet
+
post-patch:
@${REINPLACE_CMD} -e 's| -r %F||' ${WRKSRC}/geeqie.desktop.in
@${REINPLACE_CMD} -e '/readme_DATA/ s|COPYING||' ${WRKSRC}/Makefile.am