aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-04-02 17:53:02 +0800
committerclsung <clsung@FreeBSD.org>2007-04-02 17:53:02 +0800
commit76814003a109fb7f1ece56aa64476ff24ec510d6 (patch)
tree109a69c25d6a54b3690dc3a6b1f4ca37f3e60ef9 /graphics
parent4d93c6c4707aade15e8736846af328128ebf480b (diff)
downloadfreebsd-ports-gnome-76814003a109fb7f1ece56aa64476ff24ec510d6.tar.gz
freebsd-ports-gnome-76814003a109fb7f1ece56aa64476ff24ec510d6.tar.zst
freebsd-ports-gnome-76814003a109fb7f1ece56aa64476ff24ec510d6.zip
- unbreak
Diffstat (limited to 'graphics')
-rw-r--r--graphics/p5-GraphViz-Data-Structure/Makefile12
-rw-r--r--graphics/p5-GraphViz-Data-Structure/files/patch-Makefile.PL18
2 files changed, 20 insertions, 10 deletions
diff --git a/graphics/p5-GraphViz-Data-Structure/Makefile b/graphics/p5-GraphViz-Data-Structure/Makefile
index 174540585f2f..8a6c9b463c00 100644
--- a/graphics/p5-GraphViz-Data-Structure/Makefile
+++ b/graphics/p5-GraphViz-Data-Structure/Makefile
@@ -17,19 +17,11 @@ MAINTAINER= clsung@FreeBSD.org
COMMENT= Visualise data structures
BUILD_DEPENDS= ${SITE_PERL}/GraphViz.pm:${PORTSDIR}/graphics/p5-GraphViz \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+ ${LOCALBASE}/bin/dot:${PORTSDIR}/graphics/graphviz
RUN_DEPENDS= ${BUILD_DEPENDS}
-BROKEN= Does not build
-
PERL_CONFIGURE= yes
MAN3= GraphViz::Data::Structure.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-GraphViz-Data-Structure/files/patch-Makefile.PL b/graphics/p5-GraphViz-Data-Structure/files/patch-Makefile.PL
new file mode 100644
index 000000000000..f911f05a1d64
--- /dev/null
+++ b/graphics/p5-GraphViz-Data-Structure/files/patch-Makefile.PL
@@ -0,0 +1,18 @@
+--- Makefile.PL.orig Tue Sep 27 05:20:28 2005
++++ Makefile.PL Mon Apr 2 17:27:28 2007
+@@ -2,15 +2,6 @@
+ use 5.008;
+ # See lib/ExtUtils/MakeMaker.pm for details of how to influence
+ # the contents of the Makefile that is written.
+-my $dot_version = `dot -V 2>&1`;
+-
+-if (!$dot_version) {
+- die "You must install the graphviz package (http://www.graphviz.org) before using this module.\n";
+-}
+-else {
+- my ($v) = ($dot_version =~ /dot version (.*?) /);
+- die "You must have at least version 2.2 of dot to use this module" if ($v+0 < 2.2);
+-}
+
+ WriteMakefile(
+ NAME => 'GraphViz::Data::Structure',