aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2010-11-24 08:40:22 +0800
committerdougb <dougb@FreeBSD.org>2010-11-24 08:40:22 +0800
commit82f1c37e526ea00969bfb8c2de38ad1baa2b9680 (patch)
treee3132d0ac0a2fcc619aa6fc22e7c0436e65d1f49 /graphics
parentc440148fdffde09e3a4b46f75bff97a3af4d1c3c (diff)
downloadfreebsd-ports-gnome-82f1c37e526ea00969bfb8c2de38ad1baa2b9680.tar.gz
freebsd-ports-gnome-82f1c37e526ea00969bfb8c2de38ad1baa2b9680.tar.zst
freebsd-ports-gnome-82f1c37e526ea00969bfb8c2de38ad1baa2b9680.zip
Allow the Makefile to determine the state of PERL_THREADED.
While I'm here, you cannot rely on the value of a define to be something specific, it is either defined or it is not. No PORTREVISION bump because WITH_THREADS is not the default, and for those attempting to use this option and/or related options the port has not built since the last update. Approved by: lack of response from maintainer, problem affecting users
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ImageMagick/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 8140e42c2442..cef6db3a2f94 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -84,6 +84,7 @@ CONFIGURE_ARGS+= --disable-hdri
.if defined(WITH_THREADS)
_IMAGEMAGICK_THREADS=yes
_IMAGEMAGICK_THREADS_MSG=with threads
+PERL_THREADED!= /bin/sh -c 'case `perl --version` in *freebsd-thread*) echo yes ;; esac'
.else
_IMAGEMAGICK_THREADS=no
_IMAGEMAGICK_THREADS_MSG=without threads
@@ -96,7 +97,7 @@ PLIST_SUB+= WITH_PERL=''
MAN3= Image::Magick.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
# PerlMagick not works with threads, if perl is not threaded, and vice versa
-. if defined(PERL_THREADED) && ${PERL_THREADED} == "true"
+. if defined(PERL_THREADED)
_IMAGEMAGICK_THREADS_PERL_MSG=Perl is threaded
_IMAGEMAGICK_THREADS=yes
. else