aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-08-25 01:50:04 +0800
committerkwm <kwm@FreeBSD.org>2010-08-25 01:50:04 +0800
commit8b8b303fb4b0d298ef345dae3c5db5b9e0be5e23 (patch)
tree6ead6a55ce80addec763c493ec9bd2424a8a6b3c /graphics
parente01494e9cbca1fb0d76e6435f55828f0d8f85b02 (diff)
downloadfreebsd-ports-gnome-8b8b303fb4b0d298ef345dae3c5db5b9e0be5e23.tar.gz
freebsd-ports-gnome-8b8b303fb4b0d298ef345dae3c5db5b9e0be5e23.tar.zst
freebsd-ports-gnome-8b8b303fb4b0d298ef345dae3c5db5b9e0be5e23.zip
imlib can't handle 32-bit visuals, so only use 24 as maximum.
PR: ports/149843 Submitted by: Yuri <yuri@tsoft.com> Obtained from: Ubuntu
Diffstat (limited to 'graphics')
-rw-r--r--graphics/imlib/Makefile2
-rw-r--r--graphics/imlib/files/patch-max-24bpp44
2 files changed, 45 insertions, 1 deletions
diff --git a/graphics/imlib/Makefile b/graphics/imlib/Makefile
index 720e110618d1..7160e310f59e 100644
--- a/graphics/imlib/Makefile
+++ b/graphics/imlib/Makefile
@@ -8,7 +8,7 @@
PORTNAME= imlib
PORTVERSION= 1.9.15
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= graphics
MASTER_SITES= GNOME
DIST_SUBDIR= gnome
diff --git a/graphics/imlib/files/patch-max-24bpp b/graphics/imlib/files/patch-max-24bpp
new file mode 100644
index 000000000000..7635bb36c9ca
--- /dev/null
+++ b/graphics/imlib/files/patch-max-24bpp
@@ -0,0 +1,44 @@
+Fix a bug in imlib so that kuickshow works.
+https://bugs.kde.org/show_bug.cgi?id=248431
+
+
+--- Imlib/misc.c
++++ Imlib/misc.c
+@@ -423,6 +423,8 @@
+ if (xvir[i].depth > max)
+ max = xvir[i].depth;
+ }
++ if (max > 24)
++ max = 24;
+ if (max > 8)
+ {
+ id->x.depth = max;
+@@ -1026,6 +1028,8 @@
+ if (xvir[i].depth > max)
+ max = xvir[i].depth;
+ }
++ if (max > 24)
++ max = 24;
+ if (max > 8)
+ {
+ id->x.depth = max;
+--- gdk_imlib/misc.c
++++ gdk_imlib/misc.c
+@@ -455,6 +455,8 @@
+ if (xvir[i].depth > max)
+ max = xvir[i].depth;
+ }
++ if (max > 24)
++ max = 24;
+ if (max > 8)
+ {
+ id->x.depth = max;
+@@ -1004,6 +1006,8 @@
+ if (xvir[i].depth > max)
+ max = xvir[i].depth;
+ }
++ if (max > 24)
++ max = 24;
+ if (max > 8)
+ {
+ id->x.depth = max;