aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2018-08-14 04:22:38 +0800
committerantoine <antoine@FreeBSD.org>2018-08-14 04:22:38 +0800
commit9157ccf38f1af63a10206ebfcc38b3ee2f985c73 (patch)
treeb44f9a9490223ad15b3dad6f2492134852caa8fd /graphics
parent77bde3b4cadec17a01f0b30f9a22ae99536870e1 (diff)
downloadfreebsd-ports-gnome-9157ccf38f1af63a10206ebfcc38b3ee2f985c73.tar.gz
freebsd-ports-gnome-9157ccf38f1af63a10206ebfcc38b3ee2f985c73.tar.zst
freebsd-ports-gnome-9157ccf38f1af63a10206ebfcc38b3ee2f985c73.zip
Update graphics/jpeg-turbo and graphics/libjpeg-turbo to 2.0.0
Upstream switched build system to CMake PR: 230143 With hat: portmgr
Diffstat (limited to 'graphics')
-rw-r--r--graphics/jpeg-turbo/Makefile29
-rw-r--r--graphics/jpeg-turbo/distinfo6
-rw-r--r--graphics/jpeg-turbo/files/patch-md5_md5.c11
-rw-r--r--graphics/jpeg-turbo/pkg-plist4
-rw-r--r--graphics/libjpeg-turbo/Makefile2
5 files changed, 15 insertions, 37 deletions
diff --git a/graphics/jpeg-turbo/Makefile b/graphics/jpeg-turbo/Makefile
index 32329911edee..2b1a66012cca 100644
--- a/graphics/jpeg-turbo/Makefile
+++ b/graphics/jpeg-turbo/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= jpeg-turbo
-PORTVERSION= 1.5.3
+PORTVERSION= 2.0.0
PORTREVISION?= 0
CATEGORIES= graphics
MASTER_SITES= SF/lib${PORTNAME}/${PORTVERSION}
@@ -15,30 +15,22 @@ LICENSE= BSD3CLAUSE IJG ZLIB
LICENSE_COMB= multi
LICENSE_GROUPS_IJG= FSF GPL
LICENSE_NAME_IJG= Independent JPEG Group License
-LICENSE_FILE_BSD3CLAUSE= ${WRKSRC}/turbojpeg.c
+LICENSE_FILE_BSD3CLAUSE= ${WRKSRC}/LICENSE.md
LICENSE_FILE_IJG= ${WRKSRC}/README.ijg
-LICENSE_FILE_ZLIB= ${WRKSRC}/simd/jsimdext.inc
+LICENSE_FILE_ZLIB= ${WRKSRC}/LICENSE.md
LICENSE_PERMS_IJG= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USES= cpe libtool pathfix
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-jpeg8
+USES= cmake:outsource cpe
USE_LDCONFIG= yes
-INSTALL_TARGET= install-strip
-TEST_TARGET= test
+CMAKE_ON= WITH_JPEG8
CPE_VENDOR= d.r.commander
CPE_PRODUCT= libjpeg-turbo
+TEST_TARGET= test
PORTDOCS= *
-PORTEXAMPLES= *
-
-OPTIONS_DEFINE= DOCS EXAMPLES
-
-DOCS_MAKE_ARGS= docdir="${DOCSDIR}"
-DOCS_MAKE_ARGS_OFF= dist_doc_DATA=""
+DOCSDIR= ${PREFIX}/share/doc/libjpeg-turbo
-EXAMPLES_MAKE_ARGS= exampledir="${EXAMPLESDIR}"
-EXAMPLES_MAKE_ARGS_OFF= dist_example_DATA=""
+OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
@@ -47,12 +39,9 @@ BUILD_DEPENDS+= nasm:devel/nasm
.endif
.if ${SLAVE_PORT} == yes
-# libturbojpeg.a has to be built with PIC for virtualgl
-CONFIGURE_ARGS+=--with-pic
-USES+= jpeg
PLIST_SUB+= JPEG="@comment " LIBTURBOJPEG=""
.else
-CONFIGURE_ARGS+=--without-turbojpeg
+CMAKE_OFF= WITH_TURBOJPEG
CONFLICTS_INSTALL= jpeg-[0-9]*
PLIST_SUB+= JPEG="" LIBTURBOJPEG="@comment "
.endif
diff --git a/graphics/jpeg-turbo/distinfo b/graphics/jpeg-turbo/distinfo
index 431b0226ab33..36fab0d93eb7 100644
--- a/graphics/jpeg-turbo/distinfo
+++ b/graphics/jpeg-turbo/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1514013995
-SHA256 (libjpeg-turbo-1.5.3.tar.gz) = b24890e2bb46e12e72a79f7e965f409f4e16466d00e1dd15d93d73ee6b592523
-SIZE (libjpeg-turbo-1.5.3.tar.gz) = 1658672
+TIMESTAMP = 1532858291
+SHA256 (libjpeg-turbo-2.0.0.tar.gz) = 778876105d0d316203c928fd2a0374c8c01f755d0a00b12a1c8934aeccff8868
+SIZE (libjpeg-turbo-2.0.0.tar.gz) = 2158457
diff --git a/graphics/jpeg-turbo/files/patch-md5_md5.c b/graphics/jpeg-turbo/files/patch-md5_md5.c
deleted file mode 100644
index 02338b3a9b78..000000000000
--- a/graphics/jpeg-turbo/files/patch-md5_md5.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- md5/md5.c.orig 2017-07-07 20:31:10 UTC
-+++ md5/md5.c
-@@ -54,6 +54,8 @@ static void MD5Transform(unsigned int [4
- #include <libkern/OSByteOrder.h>
- #define le32toh(x) OSSwapLittleToHostInt32(x)
- #define htole32(x) OSSwapHostToLittleInt32(x)
-+#elif defined(__FreeBSD__)
-+#include <sys/endian.h>
- #endif
-
- /*
diff --git a/graphics/jpeg-turbo/pkg-plist b/graphics/jpeg-turbo/pkg-plist
index ef955e6d3279..ae21a2a923b9 100644
--- a/graphics/jpeg-turbo/pkg-plist
+++ b/graphics/jpeg-turbo/pkg-plist
@@ -10,7 +10,7 @@
%%JPEG%%lib/libjpeg.a
%%JPEG%%lib/libjpeg.so
%%JPEG%%lib/libjpeg.so.8
-%%JPEG%%lib/libjpeg.so.8.1.2
+%%JPEG%%lib/libjpeg.so.8.2.2
%%JPEG%%libdata/pkgconfig/libjpeg.pc
%%JPEG%%man/man1/cjpeg.1.gz
%%JPEG%%man/man1/djpeg.1.gz
@@ -22,5 +22,5 @@
%%LIBTURBOJPEG%%lib/libturbojpeg.a
%%LIBTURBOJPEG%%lib/libturbojpeg.so
%%LIBTURBOJPEG%%lib/libturbojpeg.so.0
-%%LIBTURBOJPEG%%lib/libturbojpeg.so.0.1.0
+%%LIBTURBOJPEG%%lib/libturbojpeg.so.0.2.0
%%LIBTURBOJPEG%%libdata/pkgconfig/libturbojpeg.pc
diff --git a/graphics/libjpeg-turbo/Makefile b/graphics/libjpeg-turbo/Makefile
index 49c409a18ffc..22cac97a0b1c 100644
--- a/graphics/libjpeg-turbo/Makefile
+++ b/graphics/libjpeg-turbo/Makefile
@@ -8,6 +8,6 @@ COMMENT= SIMD-accelerated JPEG codec library, provides libTurboJPEG
MASTERDIR= ${.CURDIR:H}/jpeg-turbo
SLAVE_PORT= yes
-OPTIONS_EXCLUDE=DOCS EXAMPLES
+OPTIONS_EXCLUDE=DOCS
.include "${MASTERDIR}/Makefile"