aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-09-20 09:13:47 +0800
committerjbeich <jbeich@FreeBSD.org>2015-09-20 09:13:47 +0800
commit9b732ad740635e0caf083b37a6c587f7fc6657f5 (patch)
tree55de2489e46adf7e8df2eb49a07dd5510150b7ce /graphics
parent863dde86c6223e196b52927c530c953db8fb7a0e (diff)
downloadfreebsd-ports-gnome-9b732ad740635e0caf083b37a6c587f7fc6657f5.tar.gz
freebsd-ports-gnome-9b732ad740635e0caf083b37a6c587f7fc6657f5.tar.zst
freebsd-ports-gnome-9b732ad740635e0caf083b37a6c587f7fc6657f5.zip
Convert the rest to USE_GL
Tested by: make describe (only touched ports) Approved by: portmgr blanket
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gource/Makefile2
-rw-r--r--graphics/libEGL/Makefile4
-rw-r--r--graphics/libgltf/Makefile2
-rw-r--r--graphics/libprojectm/Makefile2
4 files changed, 5 insertions, 5 deletions
diff --git a/graphics/gource/Makefile b/graphics/gource/Makefile
index 3a5901c7ee88..54c9dbb6bd40 100644
--- a/graphics/gource/Makefile
+++ b/graphics/gource/Makefile
@@ -15,12 +15,12 @@ BUILD_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:${PORTSDIR}/math/glm
LIB_DEPENDS= libSDL_image.so:${PORTSDIR}/graphics/sdl_image \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libpcre.so:${PORTSDIR}/devel/pcre \
- libGLEW.so:${PORTSDIR}/graphics/glew \
libboost_filesystem.so:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:${PORTSDIR}/math/glm
GNU_CONFIGURE= yes
USES= gmake pkgconfig compiler:c++0x
+USE_GL= glew
CONFIGURE_ARGS+=--with-boost-system=boost_system \
--with-boost-filesystem=boost_filesystem
diff --git a/graphics/libEGL/Makefile b/graphics/libEGL/Makefile
index 1ef8fe5471b5..3ea2c3072f08 100644
--- a/graphics/libEGL/Makefile
+++ b/graphics/libEGL/Makefile
@@ -11,9 +11,9 @@ COMMENT= OpenEGL library
LIB_DEPENDS+= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
libexpat.so:${PORTSDIR}/textproc/expat2 \
libdevq.so:${PORTSDIR}/devel/libdevq \
- libdrm.so:${PORTSDIR}/graphics/libdrm \
- libgbm.so:${PORTSDIR}/graphics/gbm
+ libdrm.so:${PORTSDIR}/graphics/libdrm
+USE_GL= gbm
USE_XORG= x11 xau xcb xdmcp
# stuff not needed by libEGL but configure wants it
diff --git a/graphics/libgltf/Makefile b/graphics/libgltf/Makefile
index 1e502ad30ed4..14fb9f8e52bd 100644
--- a/graphics/libgltf/Makefile
+++ b/graphics/libgltf/Makefile
@@ -13,9 +13,9 @@ LICENSE_COMB= dual
BUILD_DEPENDS= ${LOCALBASE}/include/boost/ptr_container/ptr_map.hpp:${PORTSDIR}/devel/boost-libs \
${LOCALBASE}/include/glm/glm.hpp:${PORTSDIR}/math/glm
-LIB_DEPENDS= libGLEW.so:${PORTSDIR}/graphics/glew
USES= compiler:c++0x libtool pathfix pkgconfig tar:bzip2
+USE_GL= glew
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-werror
diff --git a/graphics/libprojectm/Makefile b/graphics/libprojectm/Makefile
index f022b545a743..f9d0c6325df0 100644
--- a/graphics/libprojectm/Makefile
+++ b/graphics/libprojectm/Makefile
@@ -13,10 +13,10 @@ COMMENT= Awesome music visualiser
LICENSE= LGPL21
LIB_DEPENDS= libftgl.so:${PORTSDIR}/graphics/ftgl \
- libGLEW.so:${PORTSDIR}/graphics/glew \
libfreetype.so:${PORTSDIR}/print/freetype2
USES= cmake
+USE_GL= glew
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
USE_LDCONFIG= yes