aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-10-12 12:23:23 +0800
committerdinoex <dinoex@FreeBSD.org>2004-10-12 12:23:23 +0800
commita7274ef3feccf2bc4c0977ba0a9c1225d6144f43 (patch)
treeedfa683ace4d6b10b2d17d5ed11f39f097260298 /graphics
parentde2eee536fba25c40d0c9eb0ab38120e30bc790e (diff)
downloadfreebsd-ports-gnome-a7274ef3feccf2bc4c0977ba0a9c1225d6144f43.tar.gz
freebsd-ports-gnome-a7274ef3feccf2bc4c0977ba0a9c1225d6144f43.tar.zst
freebsd-ports-gnome-a7274ef3feccf2bc4c0977ba0a9c1225d6144f43.zip
- Enable LZW compression kit for users who are able to use LZW
PR: 72039 Submitted by: Michael Johnson
Diffstat (limited to 'graphics')
-rw-r--r--graphics/tiff/Makefile30
-rw-r--r--graphics/tiff/distinfo2
2 files changed, 31 insertions, 1 deletions
diff --git a/graphics/tiff/Makefile b/graphics/tiff/Makefile
index cc7692ceaeba..8919984d8a52 100644
--- a/graphics/tiff/Makefile
+++ b/graphics/tiff/Makefile
@@ -14,6 +14,8 @@ CATEGORIES= graphics
MASTER_SITES= ftp://ftp.remotesensing.org/pub/libtiff/ \
http://libtiff.maptools.org/dl/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
+DISTFILES= ${PORTNAME}-v${PORTVERSION}${EXTRACT_SUFX} ${LZW_DIST}
+PKGNAMESUFFIX?= ${TIFF_SUFFIX}${PKGNAMESUFFIX2}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Tools and library routines for working with TIFF images
@@ -113,4 +115,30 @@ MLINKS= TIFFError.3t TIFFSetErrorHandler.3t \
TIFFtile.3t TIFFTileRowSize.3t \
TIFFtile.3t TIFFVTileSize.3t
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_TIFF_LZW_KIT)
+TIFF_SUFFIX= -lzw
+LZKIT= libtiff-lzw-compression-kit
+LZKIT_VER= 1.5
+LZW_DIST= ${LZKIT}-${LZKIT_VER}${EXTRACT_SUFX}
+RESTRICTED= "Redistribution not allowed"
+
+.if !exists(${DISTDIR}/${LZW_DIST})
+IGNORE= Due to patent enforcement from Unisys you must manually\
+ fetch ${LZW_DIST} from ftp://ftp.remotesensing.org/libtiff\
+ and place it in ${DISTDIR}. \
+ To use this patch legally you must live in a country where the patent\
+ does not apply or you must obtain a license from Unisys
+.endif
+
+post-patch:
+ @${CP} -f ${WRKDIR}/${LZKIT}-${LZKIT_VER}/tif_lzw.c ${WRKSRC}/libtiff
+.else
+
+pre-everything::
+ @${ECHO_MSG} "===> Enable LZW Compression by defining WITH_TIFF_LZW_KIT"
+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/tiff/distinfo b/graphics/tiff/distinfo
index 22224cb36e4c..933dc83b58d7 100644
--- a/graphics/tiff/distinfo
+++ b/graphics/tiff/distinfo
@@ -1,2 +1,4 @@
MD5 (tiff-v3.6.1.tar.gz) = b3f0ee7617593c2703755672fb1bfed3
SIZE (tiff-v3.6.1.tar.gz) = 1072165
+MD5 (libtiff-lzw-compression-kit-1.5.tar.gz) = 2cd1c94d237d47104106de3bf4f08baa
+SIZE (libtiff-lzw-compression-kit-1.5.tar.gz) = 9646