aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-08-19 04:43:58 +0800
committerdanfe <danfe@FreeBSD.org>2015-08-19 04:43:58 +0800
commitb197ffa49844df5b898a515d7ae9408e7649b324 (patch)
treea94ca09c54b55374ddc2feead5741175bb4ba140 /graphics
parentb9c7574dc2dfe37964ab1027ab815b10215e0991 (diff)
downloadfreebsd-ports-gnome-b197ffa49844df5b898a515d7ae9408e7649b324.tar.gz
freebsd-ports-gnome-b197ffa49844df5b898a515d7ae9408e7649b324.tar.zst
freebsd-ports-gnome-b197ffa49844df5b898a515d7ae9408e7649b324.zip
- Belatedly update to version 1.4 (switch to DISTVERSION to make testing
of -RC versions easier) - Point MASTER_SITES to fetch distfiles from Bitbucket (src.luxrender.net redirects there now) - Add two new USES: `execinfo' and `python:version'; the latter is needed to avoid build breakage when both Python 2.x and 3.x are installed - Remove `-pedantic' from CMAKE_CXX_FLAGS to allow building with GCC 4.2 by avoiding "floating constant exceeds range of 'long double'" error - Reword X11_DESC slightly while here in order to insert space in "Qt 4" while retaining visual appeal of option description text in the dialog
Diffstat (limited to 'graphics')
-rw-r--r--graphics/luxrender/Makefile33
-rw-r--r--graphics/luxrender/distinfo8
-rw-r--r--graphics/luxrender/files/patch-CMakeLists.txt9
-rw-r--r--graphics/luxrender/files/patch-gcc42-fixes16
-rw-r--r--graphics/luxrender/files/patch-luxrays-cmake-PlatformSpecific.cmake9
-rw-r--r--graphics/luxrender/files/patch-luxrays-include-luxcore-luxcore.h20
-rw-r--r--graphics/luxrender/files/patch-luxrays-samples-benchsimple-CMakeLists.txt6
-rw-r--r--graphics/luxrender/files/patch-luxrays-samples-luxcoredemo-CMakeLists.txt16
-rw-r--r--graphics/luxrender/files/patch-luxrays-samples-luxcorescenedemo-CMakeLists.txt16
-rw-r--r--graphics/luxrender/files/patch-luxrays-samples-slglibdemo-CMakeLists.txt16
-rw-r--r--graphics/luxrender/files/patch-luxrays-samples-smallluxgpu4-CMakeLists.txt8
11 files changed, 101 insertions, 56 deletions
diff --git a/graphics/luxrender/Makefile b/graphics/luxrender/Makefile
index 86752f1f20f2..9373e53859a0 100644
--- a/graphics/luxrender/Makefile
+++ b/graphics/luxrender/Makefile
@@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= luxrender
-PORTVERSION= 1.3.1
-PORTREVISION= 4
+DISTVERSION= 1.4
CATEGORIES= graphics
-MASTER_SITES= http://src.luxrender.net/lux/get/ \
- http://src.luxrender.net/luxrays/get/:lr
-DISTFILES= v${PORTVERSION:S/.//g}${EXTRACT_SUFX} \
- luxrender_v${PORTVERSION}${EXTRACT_SUFX}:lr
+MASTER_SITES= https://bitbucket.org/luxrender/lux/get/ \
+ https://bitbucket.org/luxrender/luxrays/get/:lr
+DISTFILES= v${DISTVERSION:C/[.-]//g}${EXTRACT_SUFX} \
+ ${PORTNAME}_v${DISTVERSION:S/-//}${EXTRACT_SUFX}:lr
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= danfe@FreeBSD.org
@@ -19,33 +18,31 @@ LICENSE= GPLv3
LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs \
libfftw3.so:${PORTSDIR}/math/fftw3 \
libfreeimage.so:${PORTSDIR}/graphics/freeimage \
- libpng.so:${PORTSDIR}/graphics/png \
- libIlmImf.so:${PORTSDIR}/graphics/OpenEXR
-.if !exists(/usr/include/execinfo.h)
-LIB_DEPENDS+= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
-.endif
+ libOpenImageIO.so:${PORTSDIR}/graphics/openimageio
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= uses SSE extensions
-USES= bison cmake tar:bzip2
+USES= bison cmake execinfo python:version tar:bzip2
USE_GL= glut glew
WRKSRC= ${WRKDIR}/luxrender-lux-${LUX_REV}
LUXRAYS_WRKSRC= ${WRKDIR}/luxrender-luxrays-${LUXRAYS_REV}
-CMAKE_ARGS= -DLUXRAYS_INCLUDE_DIRS:PATH="${LUXRAYS_WRKSRC}/include" \
+CMAKE_ARGS= -DLUXCORE_INCLUDE_DIRS:PATH="${LUXRAYS_WRKSRC}/include" \
+ -DLUXCORE_LIBRARY:STRING="${LUXRAYS_WRKSRC}/lib/libluxcore.a" \
+ -DLUXRAYS_INCLUDE_DIRS:PATH="${LUXRAYS_WRKSRC}/include" \
-DLUXRAYS_LIBRARY:STRING="${LUXRAYS_WRKSRC}/lib/libluxrays.a" \
-DSLG_INCLUDE_DIRS:PATH="${LUXRAYS_WRKSRC}/include" \
-DSLG_LIBRARY:PATH="${LUXRAYS_WRKSRC}/lib/libsmallluxgpu.a" \
-DLUXRAYS_DISABLE_OPENCL:BOOL=ON
-LUX_REV= d0b0e20c47cc
-LUXRAYS_REV= 7459cd8a9583
+LUX_REV= dfd211d6faa0
+LUXRAYS_REV= 7c7127ee1fa4
OPTIONS_DEFINE= X11
OPTIONS_DEFAULT= X11
-X11_DESC= Build GUI executable (Qt4-based)
+X11_DESC= Build GUI executable (requires Qt 4)
X11_USE= QT4=moc_build,qmake_build,rcc_build,uic_build,corelib,gui
X11_PLIST_FILES= bin/luxrender
@@ -56,6 +53,10 @@ post-patch:
${WRKSRC}/shapes/mikktspace/weldmesh.c
@${REINPLACE_CMD} -e '/^set(Boost_USE_STATIC_LIBS/s,ON,OFF,' \
${LUXRAYS_WRKSRC}/cmake/Dependencies.cmake
+# Avoid picking up Python 3.x bits if they're installed
+ @${REINPLACE_CMD} -e 's,PythonLibs,& ${PYTHON_VER} EXACT REQUIRED,' \
+ ${LUXRAYS_WRKSRC}/cmake/Dependencies.cmake \
+ ${WRKSRC}/cmake/pylux.cmake
pre-configure:
cd ${LUXRAYS_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} \
diff --git a/graphics/luxrender/distinfo b/graphics/luxrender/distinfo
index e3716a709a2c..21b9a50c4199 100644
--- a/graphics/luxrender/distinfo
+++ b/graphics/luxrender/distinfo
@@ -1,4 +1,4 @@
-SHA256 (luxrender/v131.tar.bz2) = b38fb83e0e9a8bc09587ac78de688f9a79fbbe9e2e20ff5822bc72a24bb230fd
-SIZE (luxrender/v131.tar.bz2) = 2541070
-SHA256 (luxrender/luxrender_v1.3.1.tar.bz2) = bae72176f33e4c307cba3f03c332024b6c46ea5d88251e14f5c748a6b0626bc5
-SIZE (luxrender/luxrender_v1.3.1.tar.bz2) = 44433304
+SHA256 (luxrender/v14.tar.bz2) = 87389167496037e22cbf420efd610474d6a02395c4f4e4a39e2bd50453676b0b
+SIZE (luxrender/v14.tar.bz2) = 2642639
+SHA256 (luxrender/luxrender_v1.4.tar.bz2) = 8229a814807fed2810eefd4a5ba051e7b05a4b30862ee066a3c205d6bd730205
+SIZE (luxrender/luxrender_v1.4.tar.bz2) = 26682611
diff --git a/graphics/luxrender/files/patch-CMakeLists.txt b/graphics/luxrender/files/patch-CMakeLists.txt
index 1cea51b134b9..1fba01bbd1cf 100644
--- a/graphics/luxrender/files/patch-CMakeLists.txt
+++ b/graphics/luxrender/files/patch-CMakeLists.txt
@@ -1,14 +1,5 @@
--- CMakeLists.txt.orig
+++ CMakeLists.txt
-@@ -179,7 +179,7 @@ IF(NOT APPLE AND NOT WIN32)
- STRING(REGEX MATCH "(x86_64-*)|(X86_64-*)|(AMD64-*)|(amd64-*)" _mach_x86_64 ${MACHINE})
- IF (_mach_x86_64)
- SET(ARCH_X86_64 1)
-- SET(LIB_SUFFIX 64)
-+ #SET(LIB_SUFFIX 64)
- #jromang - Hack to avoid boost bug on x64 Ubuntu 8.10 and Fedora 10 (http://www.luxrender.net/mantis/view.php?id=433)
- ADD_DEFINITIONS(-DBOOST_NO_INTRINSIC_INT64_T)
- ENDIF (_mach_x86_64)
@@ -298,7 +298,7 @@ ELSEIF(MSVC)
ELSE(APPLE)
# Dade - default compiler options
diff --git a/graphics/luxrender/files/patch-gcc42-fixes b/graphics/luxrender/files/patch-gcc42-fixes
index 54a59afc7419..7648ae07fd03 100644
--- a/graphics/luxrender/files/patch-gcc42-fixes
+++ b/graphics/luxrender/files/patch-gcc42-fixes
@@ -1,3 +1,19 @@
+--- ../luxrender-luxrays-7c7127ee1fa4/include/luxrays/core/geometry/frame.h.orig
++++ ../luxrender-luxrays-7c7127ee1fa4/include/luxrays/core/geometry/frame.h
+@@ -46,11 +46,11 @@ public:
+ SetFromZ(z);
+ }
+
+- Frame(const Normal &z) {
++ Frame(const luxrays::Normal &z) {
+ SetFromZ(Vector(z));
+ }
+
+- void SetFromZ(const Normal &z) {
++ void SetFromZ(const luxrays::Normal &z) {
+ SetFromZ(Vector(z));
+ }
+
--- textures/bilerp.h.orig
+++ textures/bilerp.h
@@ -39,7 +39,7 @@ public:
diff --git a/graphics/luxrender/files/patch-luxrays-cmake-PlatformSpecific.cmake b/graphics/luxrender/files/patch-luxrays-cmake-PlatformSpecific.cmake
index 74c02cfb6c22..06026047e648 100644
--- a/graphics/luxrender/files/patch-luxrays-cmake-PlatformSpecific.cmake
+++ b/graphics/luxrender/files/patch-luxrays-cmake-PlatformSpecific.cmake
@@ -1,14 +1,15 @@
---- ../luxrender-luxrays-7459cd8a9583/cmake/PlatformSpecific.cmake.orig
-+++ ../luxrender-luxrays-7459cd8a9583/cmake/PlatformSpecific.cmake
-@@ -106,18 +106,17 @@ ENDIF(MSVC)
+--- ../luxrender-luxrays-7c7127ee1fa4/cmake/PlatformSpecific.cmake.orig
++++ ../luxrender-luxrays-7c7127ee1fa4/cmake/PlatformSpecific.cmake
+@@ -138,18 +138,17 @@ ENDIF(MSVC)
-IF(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
+#IF(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
# Update if necessary
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wno-long-long -pedantic")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wno-long-long -pedantic")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse -msse2 -msse3 -mssse3")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wno-long-long")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse")
IF(NOT CYGWIN)
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
diff --git a/graphics/luxrender/files/patch-luxrays-include-luxcore-luxcore.h b/graphics/luxrender/files/patch-luxrays-include-luxcore-luxcore.h
new file mode 100644
index 000000000000..5682d834aedd
--- /dev/null
+++ b/graphics/luxrender/files/patch-luxrays-include-luxcore-luxcore.h
@@ -0,0 +1,20 @@
+--- ../luxrender-luxrays-7c7127ee1fa4/include/luxcore/luxcore.h.orig 2015-01-20 22:45:32.000000000 +0000
++++ ../luxrender-luxrays-7c7127ee1fa4/include/luxcore/luxcore.h
+@@ -63,7 +63,7 @@
+ */
+ namespace luxcore {
+
+-CPP_EXPORT CPP_API void (*LuxCore_LogHandler)(const char *msg); // LuxCore Log Handler
++extern CPP_API void (*LuxCore_LogHandler)(const char *msg); // LuxCore Log Handler
+
+ #define LC_LOG(a) { if (luxcore::LuxCore_LogHandler) { std::stringstream _LUXCORE_LOG_LOCAL_SS; _LUXCORE_LOG_LOCAL_SS << a; luxcore::LuxCore_LogHandler(_LUXCORE_LOG_LOCAL_SS.str().c_str()); } }
+
+@@ -603,7 +603,7 @@ public:
+ *
+ * \return the default Properties.
+ */
+- static const luxrays::Properties &GetDefaultProperties();
++ const luxrays::Properties &GetDefaultProperties();
+
+ friend class RenderSession;
+
diff --git a/graphics/luxrender/files/patch-luxrays-samples-benchsimple-CMakeLists.txt b/graphics/luxrender/files/patch-luxrays-samples-benchsimple-CMakeLists.txt
index 365228d90514..8b82dec72892 100644
--- a/graphics/luxrender/files/patch-luxrays-samples-benchsimple-CMakeLists.txt
+++ b/graphics/luxrender/files/patch-luxrays-samples-benchsimple-CMakeLists.txt
@@ -1,5 +1,5 @@
---- ../luxrender-luxrays-7459cd8a9583/samples/benchsimple/CMakeLists.txt.orig
-+++ ../luxrender-luxrays-7459cd8a9583/samples/benchsimple/CMakeLists.txt
+--- ../luxrender-luxrays-7c7127ee1fa4/samples/benchsimple/CMakeLists.txt.orig
++++ ../luxrender-luxrays-7c7127ee1fa4/samples/benchsimple/CMakeLists.txt
@@ -19,8 +19,10 @@
# LuxRays website: http://www.luxrender.net #
###########################################################################
@@ -11,4 +11,4 @@
add_executable(benchsimple benchsimple.cpp)
-target_link_libraries(benchsimple luxrays)
-+target_link_libraries(benchsimple luxrays ${CMAKE_THREAD_LIBS_INIT})
++target_link_libraries(benchsimple luxrays ${PYTHON_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
diff --git a/graphics/luxrender/files/patch-luxrays-samples-luxcoredemo-CMakeLists.txt b/graphics/luxrender/files/patch-luxrays-samples-luxcoredemo-CMakeLists.txt
new file mode 100644
index 000000000000..79099952acd2
--- /dev/null
+++ b/graphics/luxrender/files/patch-luxrays-samples-luxcoredemo-CMakeLists.txt
@@ -0,0 +1,16 @@
+--- ../luxrender-luxrays-7c7127ee1fa4/samples/luxcoredemo/CMakeLists.txt.orig
++++ ../luxrender-luxrays-7c7127ee1fa4/samples/luxcoredemo/CMakeLists.txt
+@@ -22,10 +22,12 @@
+ #
+ ################################################################################
+
++find_package(Threads)
++
+ set(LUXCORELIBDEMO_SRCS
+ luxcoredemo.cpp
+ )
+
+ add_executable(luxcoredemo ${LUXCORELIBDEMO_SRCS})
+
+-TARGET_LINK_LIBRARIES(luxcoredemo luxcore smallluxgpu luxrays ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcoredemo luxcore smallluxgpu luxrays ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES} ${PYTHON_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
diff --git a/graphics/luxrender/files/patch-luxrays-samples-luxcorescenedemo-CMakeLists.txt b/graphics/luxrender/files/patch-luxrays-samples-luxcorescenedemo-CMakeLists.txt
new file mode 100644
index 000000000000..d26f96765c6e
--- /dev/null
+++ b/graphics/luxrender/files/patch-luxrays-samples-luxcorescenedemo-CMakeLists.txt
@@ -0,0 +1,16 @@
+--- ../luxrender-luxrays-7c7127ee1fa4/samples/luxcorescenedemo/CMakeLists.txt.orig 2015-01-20 22:45:32 UTC
++++ ../luxrender-luxrays-7c7127ee1fa4/samples/luxcorescenedemo/CMakeLists.txt
+@@ -22,10 +22,12 @@
+ #
+ ################################################################################
+
++find_package(Threads)
++
+ set(LUXCORESCENEDEMO_SRCS
+ luxcorescenedemo.cpp
+ )
+
+ add_executable(luxcorescenedemo ${LUXCORESCENEDEMO_SRCS})
+
+-TARGET_LINK_LIBRARIES(luxcorescenedemo luxcore smallluxgpu luxrays ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcorescenedemo luxcore smallluxgpu luxrays ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES} ${PYTHON_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
diff --git a/graphics/luxrender/files/patch-luxrays-samples-slglibdemo-CMakeLists.txt b/graphics/luxrender/files/patch-luxrays-samples-slglibdemo-CMakeLists.txt
deleted file mode 100644
index 7ec194181b39..000000000000
--- a/graphics/luxrender/files/patch-luxrays-samples-slglibdemo-CMakeLists.txt
+++ /dev/null
@@ -1,16 +0,0 @@
---- ../luxrender-luxrays-7459cd8a9583/samples/slglibdemo/CMakeLists.txt.orig
-+++ ../luxrender-luxrays-7459cd8a9583/samples/slglibdemo/CMakeLists.txt
-@@ -25,10 +25,12 @@
- #
- #############################################################################
-
-+find_package(Threads)
-+
- set(SLGLIBDEMO_SRCS
- slglibdemo.cpp
- )
-
- add_executable(slg4libdemo ${SLGLIBDEMO_SRCS})
-
--TARGET_LINK_LIBRARIES(slg4libdemo smallluxgpu luxrays)
-+TARGET_LINK_LIBRARIES(slg4libdemo smallluxgpu luxrays ${CMAKE_THREAD_LIBS_INIT})
diff --git a/graphics/luxrender/files/patch-luxrays-samples-smallluxgpu4-CMakeLists.txt b/graphics/luxrender/files/patch-luxrays-samples-smallluxgpu4-CMakeLists.txt
index a179ae1fd051..06569f21524a 100644
--- a/graphics/luxrender/files/patch-luxrays-samples-smallluxgpu4-CMakeLists.txt
+++ b/graphics/luxrender/files/patch-luxrays-samples-smallluxgpu4-CMakeLists.txt
@@ -1,5 +1,5 @@
---- ../luxrender-luxrays-7459cd8a9583/samples/smallluxgpu4/CMakeLists.txt.orig
-+++ ../luxrender-luxrays-7459cd8a9583/samples/smallluxgpu4/CMakeLists.txt
+--- ../luxrender-luxrays-7c7127ee1fa4/samples/smallluxgpu4/CMakeLists.txt.orig
++++ ../luxrender-luxrays-7c7127ee1fa4/samples/smallluxgpu4/CMakeLists.txt
@@ -25,6 +25,8 @@
#
#############################################################################
@@ -13,8 +13,8 @@
add_executable(slg4 ${SMALLLUXGPU_SRCS})
--TARGET_LINK_LIBRARIES(slg4 smallluxgpu luxrays ${OPENGL_LIBRARIES} ${GLEW_LIBRARY} ${GLUT_LIBRARY})
-+TARGET_LINK_LIBRARIES(slg4 smallluxgpu luxrays ${OPENGL_LIBRARIES} ${GLEW_LIBRARY} ${GLUT_LIBRARY} ${CMAKE_THREAD_LIBS_INIT} -lexecinfo)
+-TARGET_LINK_LIBRARIES(slg4 luxcore smallluxgpu luxrays ${OPENGL_LIBRARIES} ${GLEW_LIBRARY} ${GLUT_LIBRARY} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
++TARGET_LINK_LIBRARIES(slg4 luxcore smallluxgpu luxrays ${OPENGL_LIBRARIES} ${GLEW_LIBRARY} ${GLUT_LIBRARY} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES} ${PYTHON_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} -lexecinfo)
# This instructs FREEGLUT to emit a pragma for the static version
SET_TARGET_PROPERTIES(slg4 PROPERTIES COMPILE_DEFINITIONS FREEGLUT_STATIC)