aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-21 00:23:28 +0800
committermat <mat@FreeBSD.org>2016-06-21 00:23:28 +0800
commitbc12b6beb26907f267f34c1f8598d120cabecbae (patch)
treee83ee6693050a76e305a95a376451aa583df151e /graphics
parent5616a93eb39854a280bacec86824bbec7824d5b3 (diff)
downloadfreebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.tar.gz
freebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.tar.zst
freebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.zip
With the power of USES=dos2unix, get rid of most patches and files
with CRLF. While there, run make makepatch, rename patches to use the new scheme, and various fixes. With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'graphics')
-rw-r--r--graphics/c-a-i-r/Makefile3
-rw-r--r--graphics/c-a-i-r/files/patch-CAIR.cpp76
-rw-r--r--graphics/picpuz/Makefile3
-rw-r--r--graphics/picpuz/files/patch-Makefile10
-rw-r--r--graphics/picpuz/files/patch-zfuncs.cpp10
-rw-r--r--graphics/picpuz/files/patch-zfuncs.h18
-rw-r--r--graphics/seam-carving-gui/Makefile3
-rw-r--r--graphics/seam-carving-gui/files/patch-cair_CAIR.cpp76
8 files changed, 101 insertions, 98 deletions
diff --git a/graphics/c-a-i-r/Makefile b/graphics/c-a-i-r/Makefile
index 7817ee3d6062..a4db05a84714 100644
--- a/graphics/c-a-i-r/Makefile
+++ b/graphics/c-a-i-r/Makefile
@@ -10,7 +10,8 @@ DISTNAME= CAIR_v${PORTVERSION}
MAINTAINER= buganini@gmail.com
COMMENT= Content Aware Image Resizer is an implementation of seam carving
-USES= gmake zip
+USES= dos2unix gmake zip
+DOS2UNIX_GLOB= *.cpp
MAKE_ARGS+= CC="${CXX}"
diff --git a/graphics/c-a-i-r/files/patch-CAIR.cpp b/graphics/c-a-i-r/files/patch-CAIR.cpp
index 9292b9dbe1bc..ea099db1c685 100644
--- a/graphics/c-a-i-r/files/patch-CAIR.cpp
+++ b/graphics/c-a-i-r/files/patch-CAIR.cpp
@@ -1,38 +1,38 @@
---- CAIR.cpp.orig 2010-03-16 08:51:06.000000000 +0800
-+++ CAIR.cpp 2010-03-16 08:55:11.000000000 +0800
-@@ -276,7 +276,7 @@
- //Our thread function for the Grayscale
- void * Gray_Quadrant( void * id )
- {
-- int num = *((int *)id);
-+ long int num = *((long int *)id);
-
- while( true )
- {
-@@ -437,7 +437,7 @@
- //The thread function, splitting the image into strips
- void * Edge_Quadrant( void * id )
- {
-- int num = *((int *)id);
-+ long int num = *((long int *)id);
-
- while( true )
- {
-@@ -744,7 +744,7 @@
- //This works like Remove_Quadrant, strips across the image.
- void * Add_Quadrant( void * id )
- {
-- int num = *((int *)id);
-+ long int num = *((long int *)id);
- Thread_Params add_area;
-
- while( true )
-@@ -907,7 +907,7 @@
- //the areas are not quadrants, rather, more like strips, but I keep the name convention
- void * Remove_Quadrant( void * id )
- {
-- int num = *((int *)id);
-+ long int num = *((long int *)id);
- Thread_Params remove_area;
-
- while( true )
+--- CAIR.cpp.orig 2016-06-20 15:51:27 UTC
++++ CAIR.cpp
+@@ -276,7 +276,7 @@ inline CML_byte Grayscale_Pixel( CML_RGB
+ //Our thread function for the Grayscale
+ void * Gray_Quadrant( void * id )
+ {
+- int num = *((int *)id);
++ long int num = *((long int *)id);
+
+ while( true )
+ {
+@@ -437,7 +437,7 @@ int Convolve_Pixel( CML_image_ptr * Sour
+ //The thread function, splitting the image into strips
+ void * Edge_Quadrant( void * id )
+ {
+- int num = *((int *)id);
++ long int num = *((long int *)id);
+
+ while( true )
+ {
+@@ -744,7 +744,7 @@ CML_RGBA Average_Pixels( CML_RGBA Pixel1
+ //This works like Remove_Quadrant, strips across the image.
+ void * Add_Quadrant( void * id )
+ {
+- int num = *((int *)id);
++ long int num = *((long int *)id);
+ Thread_Params add_area;
+
+ while( true )
+@@ -907,7 +907,7 @@ bool CAIR_Add( CML_image * Source, CML_i
+ //the areas are not quadrants, rather, more like strips, but I keep the name convention
+ void * Remove_Quadrant( void * id )
+ {
+- int num = *((int *)id);
++ long int num = *((long int *)id);
+ Thread_Params remove_area;
+
+ while( true )
diff --git a/graphics/picpuz/Makefile b/graphics/picpuz/Makefile
index 3d9277fd8bf2..ec862e9b9107 100644
--- a/graphics/picpuz/Makefile
+++ b/graphics/picpuz/Makefile
@@ -11,7 +11,8 @@ MASTER_SITES= http://kornelix.squarespace.com/storage/downloads/ \
MAINTAINER= devel@stasyan.com
COMMENT= Jigsaw puzzle program
-USES= execinfo gmake pkgconfig
+USES= dos2unix execinfo gmake pkgconfig
+DOS2UNIX_GLOB= *.h
USE_GNOME= gtk20
ALL_TARGET= #
diff --git a/graphics/picpuz/files/patch-Makefile b/graphics/picpuz/files/patch-Makefile
index c75beed6f02b..bdb765ed5381 100644
--- a/graphics/picpuz/files/patch-Makefile
+++ b/graphics/picpuz/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2009-10-29 09:38:40.000000000 +0100
-+++ Makefile 2014-02-18 19:19:51.140331100 +0100
-@@ -6,7 +6,7 @@
+--- Makefile.orig 2009-10-29 08:38:40 UTC
++++ Makefile
+@@ -6,7 +6,7 @@ SOURCE = $(PROGRAM)-$(VERSION).cpp
# replace CFLAGS and LFLAGS -O (oh) with -g for GDB debugging
CFLAGS = -O -Wall -c `pkg-config --cflags gtk+-2.0`
@@ -9,7 +9,7 @@
# use $PREFIX if defined, else assume /usr/local
ifeq "$(PREFIX)" ""
-@@ -19,14 +19,14 @@
+@@ -19,14 +19,14 @@ DOCDIR = $(PREFIX)/share/doc/$(PROGRAM)
DESKTOP = $(DATADIR)/kornelix-$(PROGRAM).desktop
$(PROGRAM): $(PROGRAM).o zfuncs.o
@@ -27,7 +27,7 @@
-D "DATADIR=\"$(DATADIR)\"" -D "DOCDIR=\"$(DOCDIR)\"" -D "BINDIR=\"$(BINDIR)\""
install: $(PROGRAM)
-@@ -39,15 +39,15 @@
+@@ -39,15 +39,15 @@ install: $(PROGRAM)
cp $(PROGRAM) $(DESTDIR)$(BINDIR)
cp -R locales/* $(DESTDIR)$(DATADIR)/locales
# install .desktop file (menu entry)
diff --git a/graphics/picpuz/files/patch-zfuncs.cpp b/graphics/picpuz/files/patch-zfuncs.cpp
index f5e5d7f228f2..16f9033b5509 100644
--- a/graphics/picpuz/files/patch-zfuncs.cpp
+++ b/graphics/picpuz/files/patch-zfuncs.cpp
@@ -1,5 +1,5 @@
---- zfuncs.cpp.orig 2009-10-29 08:38:40.000000000 +0000
-+++ zfuncs.cpp 2013-03-30 09:06:21.000000000 +0000
+--- zfuncs.cpp.orig 2009-10-29 08:38:40 UTC
++++ zfuncs.cpp
@@ -23,6 +23,11 @@
// zfuncs.cpp version v.2.28
@@ -12,7 +12,7 @@
/**************************************************************************
system-level utility functions
-@@ -236,7 +241,7 @@
+@@ -236,7 +241,7 @@ void synch_threads(int NT)
// safely access parameters from multiple threads
// limitation: one lock for any number of parameters
@@ -21,7 +21,7 @@
int zget_locked(int &param) // lock and return parameter
{
-@@ -2916,7 +2921,7 @@
+@@ -2916,7 +2921,7 @@ int initz_appfiles(const char *appname,
strcpy(zicondir,zdatadir);
strcat(zicondir,"/icons");
@@ -30,7 +30,7 @@
if (strEqu(pp,"root")) snprintf(zuserdir,199,"/root/.%s",zappname); // get /root/.appname
else snprintf(zuserdir,199,"%s/.%s",getenv("HOME"),zappname); // or /home/user/.appname
-@@ -3415,7 +3420,7 @@
+@@ -3415,7 +3420,7 @@ pthread_t tid_main = 0;
pthread_t tids[tmax];
int tlocks[tmax];
int zinit = 0;
diff --git a/graphics/picpuz/files/patch-zfuncs.h b/graphics/picpuz/files/patch-zfuncs.h
index 64aab991edc2..35cc9f2c69f5 100644
--- a/graphics/picpuz/files/patch-zfuncs.h
+++ b/graphics/picpuz/files/patch-zfuncs.h
@@ -1,5 +1,5 @@
---- zfuncs.h.orig 2009-10-29 08:38:40.000000000 +0000
-+++ zfuncs.h 2013-03-30 09:03:57.000000000 +0000
+--- zfuncs.h.orig 2016-06-20 15:52:16 UTC
++++ zfuncs.h
@@ -36,7 +36,201 @@
#include <signal.h>
#include <execinfo.h>
@@ -212,12 +212,12 @@
#define mutex_init pthread_mutex_init
#define mutex_lock pthread_mutex_lock
#define mutex_trylock pthread_mutex_trylock
-@@ -495,7 +689,7 @@
+@@ -495,7 +689,7 @@ class Queue
{
- char wmi[8];
- Vxstring * vd; // vector of xstrings
-- mutex qmutex; // for multi-thread access
-+ mutex_tp qmutex; // for multi-thread access
+ char wmi[8];
+ Vxstring * vd; // vector of xstrings
+- mutex qmutex; // for multi-thread access
++ mutex_tp qmutex; // for multi-thread access
int qcap; // queue capacity
- int qcount; // curr. queue count
- int ent1; // first entry pointer
+ int qcount; // curr. queue count
+ int ent1; // first entry pointer
diff --git a/graphics/seam-carving-gui/Makefile b/graphics/seam-carving-gui/Makefile
index cf6eec847f83..ac920f93f179 100644
--- a/graphics/seam-carving-gui/Makefile
+++ b/graphics/seam-carving-gui/Makefile
@@ -11,7 +11,8 @@ DISTNAME= SeamCarvingGui-Src-${PORTVERSION}
MAINTAINER= buganini@gmail.com
COMMENT= The Seam Carving GUI is a GUI front end to CAIR
-USES= gmake qmake
+USES= dos2unix gmake qmake
+DOS2UNIX_GLOB= *.cpp
USE_QT4= gui imageformats_run moc_build uic_build
WRKSRC= ${WRKDIR}/Src\ Seam\ Carving\ GUI\ ${PORTVERSION}
diff --git a/graphics/seam-carving-gui/files/patch-cair_CAIR.cpp b/graphics/seam-carving-gui/files/patch-cair_CAIR.cpp
index 3c66e1a8ef49..9d6e31ba60dd 100644
--- a/graphics/seam-carving-gui/files/patch-cair_CAIR.cpp
+++ b/graphics/seam-carving-gui/files/patch-cair_CAIR.cpp
@@ -1,38 +1,38 @@
---- cair/CAIR.cpp.orig 2010-02-28 16:44:47.000000000 +0800
-+++ cair/CAIR.cpp 2010-02-28 16:45:32.000000000 +0800
-@@ -276,7 +276,7 @@
- //Our thread function for the Grayscale
- void * Gray_Quadrant( void * id )
- {
-- int num = *((int *)id);
-+ long int num = *((long int *)id);
-
- while( true )
- {
-@@ -437,7 +437,7 @@
- //The thread function, splitting the image into strips
- void * Edge_Quadrant( void * id )
- {
-- int num = *((int *)id);
-+ long int num = *((long int *)id);
-
- while( true )
- {
-@@ -744,7 +744,7 @@
- //This works like Remove_Quadrant, strips across the image.
- void * Add_Quadrant( void * id )
- {
-- int num = *((int *)id);
-+ long int num = *((long int *)id);
- Thread_Params add_area;
-
- while( true )
-@@ -907,7 +907,7 @@
- //the areas are not quadrants, rather, more like strips, but I keep the name convention
- void * Remove_Quadrant( void * id )
- {
-- int num = *((int *)id);
-+ long int num = *((long int *)id);
- Thread_Params remove_area;
-
- while( true )
+--- cair/CAIR.cpp.orig 2016-06-20 15:53:24 UTC
++++ cair/CAIR.cpp
+@@ -276,7 +276,7 @@ inline CML_byte Grayscale_Pixel( CML_RGB
+ //Our thread function for the Grayscale
+ void * Gray_Quadrant( void * id )
+ {
+- int num = *((int *)id);
++ long int num = *((long int *)id);
+
+ while( true )
+ {
+@@ -437,7 +437,7 @@ int Convolve_Pixel( CML_image_ptr * Sour
+ //The thread function, splitting the image into strips
+ void * Edge_Quadrant( void * id )
+ {
+- int num = *((int *)id);
++ long int num = *((long int *)id);
+
+ while( true )
+ {
+@@ -744,7 +744,7 @@ CML_RGBA Average_Pixels( CML_RGBA Pixel1
+ //This works like Remove_Quadrant, strips across the image.
+ void * Add_Quadrant( void * id )
+ {
+- int num = *((int *)id);
++ long int num = *((long int *)id);
+ Thread_Params add_area;
+
+ while( true )
+@@ -907,7 +907,7 @@ bool CAIR_Add( CML_image * Source, CML_i
+ //the areas are not quadrants, rather, more like strips, but I keep the name convention
+ void * Remove_Quadrant( void * id )
+ {
+- int num = *((int *)id);
++ long int num = *((long int *)id);
+ Thread_Params remove_area;
+
+ while( true )