aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-10-12 05:45:55 +0800
committermiwi <miwi@FreeBSD.org>2007-10-12 05:45:55 +0800
commitc7076b80dcd716be613d893101d47db0dc88d476 (patch)
treec026311c500a57d111f6609ec3a3b63fe275a322 /graphics
parent604fb70fbc66a8107fcdb415101b9844ef9379f0 (diff)
downloadfreebsd-ports-gnome-c7076b80dcd716be613d893101d47db0dc88d476.tar.gz
freebsd-ports-gnome-c7076b80dcd716be613d893101d47db0dc88d476.tar.zst
freebsd-ports-gnome-c7076b80dcd716be613d893101d47db0dc88d476.zip
* Fix build with gcc42
* Minor port updates * Allow the build on amd64 PR: 117089 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> (maintainer)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sharpconstruct/Makefile13
-rw-r--r--graphics/sharpconstruct/files/patch-include-Optimized.h11
2 files changed, 13 insertions, 11 deletions
diff --git a/graphics/sharpconstruct/Makefile b/graphics/sharpconstruct/Makefile
index 64d397a39d9e..0ae4f249701a 100644
--- a/graphics/sharpconstruct/Makefile
+++ b/graphics/sharpconstruct/Makefile
@@ -9,7 +9,7 @@ PORTNAME= sharpconstruct
PORTVERSION= 0.11
PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= sharp3d
MAINTAINER= amdmi3@amdmi3.ru
@@ -23,12 +23,9 @@ USE_X_PREFIX= yes
USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_GCC= 3.4+
MAN1= sharpconstruct.1
-ONLY_FOR_ARCHS= i386
-
post-patch:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/include/Align.hh
@${REINPLACE_CMD} -e 's|"/sharpconstruct|"|' ${WRKSRC}/src/MainWindow.cc
@@ -38,10 +35,4 @@ post-patch:
@${FIND} ${WRKSRC} -name Makefile.in -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e '/^DEFS / s|$$| -DDATADIR=\\"${DATADIR}\\"|'
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/sharpconstruct/files/patch-include-Optimized.h b/graphics/sharpconstruct/files/patch-include-Optimized.h
new file mode 100644
index 000000000000..7d46da59de34
--- /dev/null
+++ b/graphics/sharpconstruct/files/patch-include-Optimized.h
@@ -0,0 +1,11 @@
+--- include/Optimized.h.orig Sat Dec 31 06:26:59 2005
++++ include/Optimized.h Thu Oct 11 02:07:55 2007
+@@ -193,7 +193,7 @@
+ void Normalize( Point3D& );
+
+ typedef Point3D Normal3D;
+- typedef std::vector< Point3D, Align< Point3D > > Point3DVector;
++ typedef std::vector< Point3D > Point3DVector;
+
+ void Normalize( Point3DVector& );
+ /*class Point3DVector