aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2013-03-19 21:04:30 +0800
committereadler <eadler@FreeBSD.org>2013-03-19 21:04:30 +0800
commitcdabc54ad469c80d08327c0d32dfa55c640cff2a (patch)
treeeba3c1f7e94497327507881e3b0eb623013d377e /graphics
parent3e5b766396a89930130c8530a30308b48d239d4b (diff)
downloadfreebsd-ports-gnome-cdabc54ad469c80d08327c0d32dfa55c640cff2a.tar.gz
freebsd-ports-gnome-cdabc54ad469c80d08327c0d32dfa55c640cff2a.tar.zst
freebsd-ports-gnome-cdabc54ad469c80d08327c0d32dfa55c640cff2a.zip
This changes almost all the "gnomehack" only USE_GNOME cases to USES= pathfix.
If a port used other USE_GNOME items it was untouched. The ports that used other USES were fixed by hand. PR: ports/177081 Reviewed by: bapt Approved by: portmgr (miwi)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/agg/Makefile2
-rw-r--r--graphics/autotrace/Makefile2
-rw-r--r--graphics/cairo-java/Makefile2
-rw-r--r--graphics/cegui/Makefile2
-rw-r--r--graphics/djvulibre/Makefile2
-rw-r--r--graphics/epeg/Makefile2
-rw-r--r--graphics/ftgl/Makefile2
-rw-r--r--graphics/geglmm/Makefile2
-rw-r--r--graphics/giblib/Makefile2
-rw-r--r--graphics/glitz/Makefile2
-rw-r--r--graphics/goom/Makefile2
-rw-r--r--graphics/gstreamer-plugins-gl/Makefile2
-rw-r--r--graphics/imlib2_loaders/Makefile2
-rw-r--r--graphics/libart_lgpl/Makefile2
-rw-r--r--graphics/libcdr/Makefile2
-rw-r--r--graphics/libsvg-cairo/Makefile2
-rw-r--r--graphics/libvisual/Makefile2
-rw-r--r--graphics/passepartout/Makefile2
-rw-r--r--graphics/pstoedit/Makefile2
-rw-r--r--graphics/py-cairo/Makefile2
-rw-r--r--graphics/quesoglc/Makefile2
-rw-r--r--graphics/reallyslick/Makefile2
-rw-r--r--graphics/sage/Makefile2
-rw-r--r--graphics/sampleicc/Makefile2
-rw-r--r--graphics/sane-backends/Makefile2
-rw-r--r--graphics/simage/Makefile2
26 files changed, 26 insertions, 26 deletions
diff --git a/graphics/agg/Makefile b/graphics/agg/Makefile
index c511013f8e51..c23e19bf3d7f 100644
--- a/graphics/agg/Makefile
+++ b/graphics/agg/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
USE_XORG= x11
-USE_GNOME= gnomehack
+USES= pathfix
USE_SDL= sdl
USE_GMAKE= yes
USE_PKGCONFIG= yes
diff --git a/graphics/autotrace/Makefile b/graphics/autotrace/Makefile
index 3b407e2822f1..65e0f69eaee5 100644
--- a/graphics/autotrace/Makefile
+++ b/graphics/autotrace/Makefile
@@ -20,7 +20,7 @@ OPTIONS_DEFAULT= IMAGEMAGICK PSTOEDIT
MING_DESC= Enable swf interface
PSTOEDIT_DESC= Convert postscript to other formats
-USE_GNOME= gnomehack
+USES= pathfix
USE_PKGCONFIG= build
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
diff --git a/graphics/cairo-java/Makefile b/graphics/cairo-java/Makefile
index f41a22ccd996..a8d18b0f0b9f 100644
--- a/graphics/cairo-java/Makefile
+++ b/graphics/cairo-java/Makefile
@@ -22,7 +22,7 @@ GNU_CONFIGURE= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
-USE_GNOME= gnomehack
+USES= pathfix
CONFIGURE_ARGS= --without-gcj-compile --with-jardir=${JAVAJARDIR}
CPPFLAGS+= -I${JAVA_HOME}/include -I${JAVA_HOME}/include/freebsd
CAIRO_API_VERSION= 1.0
diff --git a/graphics/cegui/Makefile b/graphics/cegui/Makefile
index 0a42730c0d41..2d2102494e5a 100644
--- a/graphics/cegui/Makefile
+++ b/graphics/cegui/Makefile
@@ -33,7 +33,7 @@ USE_GL= yes
USE_LUA= 5.1
LUA_COMPS= toluaxx
USE_PYTHON= 2.6+
-USE_GNOME= gnomehack
+USES= pathfix
PLIST_SUB+= WITH_OGRE=""
.include <bsd.port.options.mk>
diff --git a/graphics/djvulibre/Makefile b/graphics/djvulibre/Makefile
index 283d11e56234..dfb8f5a3ffb0 100644
--- a/graphics/djvulibre/Makefile
+++ b/graphics/djvulibre/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
tiff:${PORTSDIR}/graphics/tiff
USE_ICONV= yes
-USE_GNOME= gnomehack
+USES= pathfix
GNU_CONFIGURE= yes
CONFIGURE_ENV= JPEG_CFLAGS="-I${LOCALBASE}/include" \
JPEG_LIBS="-L${LOCALBASE}/lib -ljpeg" \
diff --git a/graphics/epeg/Makefile b/graphics/epeg/Makefile
index f72fc48eaea8..2cf10a9a2aa3 100644
--- a/graphics/epeg/Makefile
+++ b/graphics/epeg/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_LDCONFIG= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/graphics/ftgl/Makefile b/graphics/ftgl/Makefile
index 8504ef269058..d88cbf81c7bf 100644
--- a/graphics/ftgl/Makefile
+++ b/graphics/ftgl/Makefile
@@ -22,7 +22,7 @@ USE_XORG= x11 xext xmu
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gl-inc="${LOCALBASE}/include" \
--without-glut-inc
-USE_GNOME= gnomehack
+USES= pathfix
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/graphics/geglmm/Makefile b/graphics/geglmm/Makefile
index b7db58dd0f40..950e262f9436 100644
--- a/graphics/geglmm/Makefile
+++ b/graphics/geglmm/Makefile
@@ -22,7 +22,7 @@ BROKEN= does not compile
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BZIP2= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_PERL5_BUILD= yes
USE_LDCONFIG= yes
diff --git a/graphics/giblib/Makefile b/graphics/giblib/Makefile
index 9b8371b00027..4f7fe952f8e8 100644
--- a/graphics/giblib/Makefile
+++ b/graphics/giblib/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A utility library that includes a wrapper for imlib2
USE_AUTOTOOLS= libtool
-USE_GNOME= gnomehack
+USES= pathfix
USE_EFL= imlib2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/graphics/glitz/Makefile b/graphics/glitz/Makefile
index 01b89a45b3af..e008c44816da 100644
--- a/graphics/glitz/Makefile
+++ b/graphics/glitz/Makefile
@@ -13,7 +13,7 @@ COMMENT= OpenGL image compositing library
USE_GL= yes
USE_XORG= xt
-USE_GNOME= gnomehack
+USES= pathfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/graphics/goom/Makefile b/graphics/goom/Makefile
index 7764a4aeca1d..552acf56d85a 100644
--- a/graphics/goom/Makefile
+++ b/graphics/goom/Makefile
@@ -17,7 +17,7 @@ COMMENT= Visual effects library
USE_AUTOTOOLS= libtool
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S|.|-|}
-USE_GNOME= gnomehack
+USES= pathfix
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/gstreamer-plugins-gl/Makefile b/graphics/gstreamer-plugins-gl/Makefile
index b004db76e981..67533fba7505 100644
--- a/graphics/gstreamer-plugins-gl/Makefile
+++ b/graphics/gstreamer-plugins-gl/Makefile
@@ -22,7 +22,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
USE_LDCONFIG= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_GSTREAMER= yes
USE_XORG= ice x11
USE_GL= gl glu glew
diff --git a/graphics/imlib2_loaders/Makefile b/graphics/imlib2_loaders/Makefile
index 3ca86d7a8571..4ed202708be8 100644
--- a/graphics/imlib2_loaders/Makefile
+++ b/graphics/imlib2_loaders/Makefile
@@ -18,7 +18,7 @@ COMMENT= Extra image loader plugins for Imlib 2
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_EFL= imlib2 libtool_hack
OPTIONS= EDB "Enable edb loader" on \
diff --git a/graphics/libart_lgpl/Makefile b/graphics/libart_lgpl/Makefile
index d2015e406f7e..430120002e3b 100644
--- a/graphics/libart_lgpl/Makefile
+++ b/graphics/libart_lgpl/Makefile
@@ -15,7 +15,7 @@ COMMENT= Library for high-performance 2D graphics
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
USE_LDCONFIG= yes
-USE_GNOME= gnomehack
+USES= pathfix
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/graphics/libcdr/Makefile b/graphics/libcdr/Makefile
index e7f4fca8a2f8..1bf2c105212f 100644
--- a/graphics/libcdr/Makefile
+++ b/graphics/libcdr/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= icui18n:${PORTSDIR}/devel/icu \
USE_XZ= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-werror --without-docs
-USE_GNOME= gnomehack
+USES= pathfix
USE_LDCONFIG= yes
USE_PKGCONFIG= build
diff --git a/graphics/libsvg-cairo/Makefile b/graphics/libsvg-cairo/Makefile
index 1d43046ffecc..d6227d412ee2 100644
--- a/graphics/libsvg-cairo/Makefile
+++ b/graphics/libsvg-cairo/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_LDCONFIG= yes
PLIST_FILES= include/svg-cairo.h \
lib/libsvg-cairo.a \
diff --git a/graphics/libvisual/Makefile b/graphics/libvisual/Makefile
index 2f860e1ef043..cb47ca979f9d 100644
--- a/graphics/libvisual/Makefile
+++ b/graphics/libvisual/Makefile
@@ -17,7 +17,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Abstraction library that sits between apps and visual plugin
-USE_GNOME= gnomehack
+USES= pathfix
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
USE_PKGCONFIG= yes
diff --git a/graphics/passepartout/Makefile b/graphics/passepartout/Makefile
index 96da913ce9c0..c9c768ebf7d8 100644
--- a/graphics/passepartout/Makefile
+++ b/graphics/passepartout/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack
+USES= pathfix
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/pstoedit/Makefile b/graphics/pstoedit/Makefile
index eabad1e12016..438e53d214c8 100644
--- a/graphics/pstoedit/Makefile
+++ b/graphics/pstoedit/Makefile
@@ -20,7 +20,7 @@ EMF_DESC= Enable emf interface
MING_DESC= Enable swf interface
PLOTUTILS_DESC= Enable libplot interface
-USE_GNOME= gnomehack
+USES= pathfix
USE_GHOSTSCRIPT= yes
USE_PKGCONFIG= build
USE_AUTOTOOLS= libtool
diff --git a/graphics/py-cairo/Makefile b/graphics/py-cairo/Makefile
index 0ee609cd7323..8503a90a36a3 100644
--- a/graphics/py-cairo/Makefile
+++ b/graphics/py-cairo/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
WRKSRC= ${WRKDIR}/py${PORTNAME}-${PORTVERSION}
USE_PYTHON= 2.6-2.7
USE_GMAKE= yes
-USE_GNOME= gnomehack
+USES= pathfix
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/quesoglc/Makefile b/graphics/quesoglc/Makefile
index d9ccfa937a07..0ab2c7c86e08 100644
--- a/graphics/quesoglc/Makefile
+++ b/graphics/quesoglc/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= fribidi.3:${PORTSDIR}/converters/fribidi \
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_GL= gl glu glut
USE_LDCONFIG= yes
diff --git a/graphics/reallyslick/Makefile b/graphics/reallyslick/Makefile
index 0cee4212ab65..054dfe784b25 100644
--- a/graphics/reallyslick/Makefile
+++ b/graphics/reallyslick/Makefile
@@ -24,7 +24,7 @@ GLEW_DESC= Enable GLEW support
USE_BZIP2= yes
USE_GL= glut
-USE_GNOME= gnomehack
+USES= pathfix
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/graphics/sage/Makefile b/graphics/sage/Makefile
index b4ae3c025a18..eeb03a404988 100644
--- a/graphics/sage/Makefile
+++ b/graphics/sage/Makefile
@@ -17,7 +17,7 @@ COMMENT= OpenGL extension library
CONFIGURE_ARGS= --program-transform-name=
GNU_CONFIGURE= yes
USE_GL= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_LDCONFIG= yes
USE_SDL= sdl
diff --git a/graphics/sampleicc/Makefile b/graphics/sampleicc/Makefile
index 9d52745fc77c..912c1afd1a3a 100644
--- a/graphics/sampleicc/Makefile
+++ b/graphics/sampleicc/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index 1c1e18829c84..d07e2d0c7448 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -30,7 +30,7 @@ USB_DESC= USB support
GPHOTO2_DESC= gPhoto2 support
IEEE1284_DESC= libieee1284 support
-USE_GNOME= gnomehack
+USES= pathfix
USE_PKGCONFIG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/graphics/simage/Makefile b/graphics/simage/Makefile
index d350e5a69071..886e4fda5802 100644
--- a/graphics/simage/Makefile
+++ b/graphics/simage/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
gif.5:${PORTSDIR}/graphics/giflib \
png15:${PORTSDIR}/graphics/png
-USE_GNOME= gnomehack
+USES= pathfix
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --with-mpeg2enc
USE_LDCONFIG= yes