aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-12-14 22:25:11 +0800
committertcberner <tcberner@FreeBSD.org>2018-12-14 22:25:11 +0800
commitd094acfa24d6e641c1f0a7889a7d249d22f49e43 (patch)
tree99f22c4c2a6185debaa333ee8ec692503133ee58 /graphics
parent8da003e4862e09226178fbac1950a5dfc4c6708d (diff)
downloadfreebsd-ports-gnome-d094acfa24d6e641c1f0a7889a7d249d22f49e43.tar.gz
freebsd-ports-gnome-d094acfa24d6e641c1f0a7889a7d249d22f49e43.tar.zst
freebsd-ports-gnome-d094acfa24d6e641c1f0a7889a7d249d22f49e43.zip
New port: graphics/qtpbfimageplugin
PR: 233878 Submitted by: Nikolay Korotkiy <sikmir@gmail.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/qtpbfimageplugin/Makefile26
-rw-r--r--graphics/qtpbfimageplugin/distinfo3
-rw-r--r--graphics/qtpbfimageplugin/pkg-descr5
4 files changed, 35 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 3ed067e90cb1..f101e411ea5d 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -987,6 +987,7 @@
SUBDIR += qt5-svg
SUBDIR += qt5-wayland
SUBDIR += qtawesome
+ SUBDIR += qtpbfimageplugin
SUBDIR += quat
SUBDIR += quat-gui
SUBDIR += quesa
diff --git a/graphics/qtpbfimageplugin/Makefile b/graphics/qtpbfimageplugin/Makefile
new file mode 100644
index 000000000000..e172ac1ec871
--- /dev/null
+++ b/graphics/qtpbfimageplugin/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= qtpbfimageplugin
+DISTVERSION= 1.1
+CATEGORIES= graphics
+
+MAINTAINER= sikmir@gmail.com
+COMMENT= Qt image plugin for displaying Mapbox vector tiles
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libprotobuf-lite.so:devel/protobuf
+
+USES= gl qmake qt:5
+USE_QT= core gui buildtools_build
+USE_GL= gl
+USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+
+USE_GITHUB= yes
+GH_ACCOUNT= tumic0
+GH_PROJECT= QtPBFImagePlugin
+
+PLIST_FILES= ${QT_PLUGINDIR}/imageformats/libpbf.so
+
+.include <bsd.port.mk>
diff --git a/graphics/qtpbfimageplugin/distinfo b/graphics/qtpbfimageplugin/distinfo
new file mode 100644
index 000000000000..dd3f3efee71f
--- /dev/null
+++ b/graphics/qtpbfimageplugin/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1544334839
+SHA256 (tumic0-QtPBFImagePlugin-1.1_GH0.tar.gz) = d12224b19fd61adef815468b7e3a6941fb193a43f7d0bd616e00e61d50a7db72
+SIZE (tumic0-QtPBFImagePlugin-1.1_GH0.tar.gz) = 193382
diff --git a/graphics/qtpbfimageplugin/pkg-descr b/graphics/qtpbfimageplugin/pkg-descr
new file mode 100644
index 000000000000..ed5d4623f640
--- /dev/null
+++ b/graphics/qtpbfimageplugin/pkg-descr
@@ -0,0 +1,5 @@
+QtPBFImagePlugin is a Qt image plugin that enables applications capable of
+displaying raster MBTiles maps or raster XYZ online maps to also display PBF
+vector tiles without (almost) any application modifications.
+
+WWW: https://github.com/tumic0/QtPBFImagePlugin