aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2014-12-05 17:01:56 +0800
committerdanfe <danfe@FreeBSD.org>2014-12-05 17:01:56 +0800
commitd9cd7860b1c2ce226525a772dfa2ca5e2b98b4e8 (patch)
tree1139d6adecbecbfabbd4ad244c877b5a20a36aa3 /graphics
parent46d7431b5e688c93b40fceb8f5bb5447b6901ed4 (diff)
downloadfreebsd-ports-gnome-d9cd7860b1c2ce226525a772dfa2ca5e2b98b4e8.tar.gz
freebsd-ports-gnome-d9cd7860b1c2ce226525a772dfa2ca5e2b98b4e8.tar.zst
freebsd-ports-gnome-d9cd7860b1c2ce226525a772dfa2ca5e2b98b4e8.zip
- Resurrect, unbreak, stagify, modernize Makefile
- Define LICENSE (GPLv2), remove -O3 from CFLAGS - Rename (regenerate) one ::-containing patch file - Contract MASTER_SITES, update pkg-plist and pkg-descr
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/yukon/Makefile60
-rw-r--r--graphics/yukon/distinfo2
-rw-r--r--graphics/yukon/files/patch-Makefile51
-rw-r--r--graphics/yukon/files/patch-include_yukon.h14
-rw-r--r--graphics/yukon/pkg-descr6
-rw-r--r--graphics/yukon/pkg-plist8
7 files changed, 142 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 192cef85cab3..68f0394b6935 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -1054,6 +1054,7 @@
SUBDIR += yafray
SUBDIR += yagf
SUBDIR += yed
+ SUBDIR += yukon
SUBDIR += zathura
SUBDIR += zathura-djvu
SUBDIR += zathura-pdf-mupdf
diff --git a/graphics/yukon/Makefile b/graphics/yukon/Makefile
new file mode 100644
index 000000000000..ce1fc089e0c9
--- /dev/null
+++ b/graphics/yukon/Makefile
@@ -0,0 +1,60 @@
+# Created by: Bruce M Simpson <bms@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= yukon
+PORTVERSION= 2010011201
+CATEGORIES= graphics
+MASTER_SITES= LOCAL/bms
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Real-time capture tool for OpenGL applications
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libseom.so:${PORTSDIR}/graphics/seom
+
+USES= gmake tar:bzip2
+USE_XORG= x11 xv
+USE_GL= gl
+USE_LDCONFIG= ${PREFIX}/lib/yukon
+
+# NOTE: These should be bumped if the underlying GL or Xorg ports change.
+LIBGL_MAJOR= 1
+LIBX11_MAJOR= 6
+
+MAKE_ENV+= LIBGL_MAJOR="${LIBGL_MAJOR}" LIBX11_MAJOR="${LIBX11_MAJOR}"
+PLIST_SUB+= LIBGL_MAJOR="${LIBGL_MAJOR}" LIBX11_MAJOR="${LIBX11_MAJOR}"
+
+#
+# To roll snapshot: as bms: make BOOTSTRAP=defined fetch
+#
+.if defined(BOOTSTRAP)
+FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+SVN_REV= 158 # svn tip at epoch 2009120801
+SVNROOT_URI= https://devel.neopsis.com/svn/yukon
+
+do-fetch:
+ @${MKDIR} ${WRKDIR}
+ svn export -r ${SVN_REV} ${SVNROOT_URI}/trunk ${WRKSRC}
+ cd ${WRKDIR}; tar cvfy ${DISTDIR}/${DISTNAME}.tar.bz2 ${DISTNAME}
+.if ${USER} == bms
+ ${CHMOD} ugo+r ${DISTDIR}/${DISTNAME}.tar.bz2
+ scp -p ${DISTDIR}/${DISTNAME}.tar.bz2 \
+ freefall.freebsd.org:public_distfiles/
+.endif
+.endif # defined(BOOTSTRAP)
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/etc/yukon,${PREFIX}/etc/yukon,' \
+ ${WRKSRC}/src/core/conf.c ${WRKSRC}/src/scripts/yukon
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/yukon/system
+ @${PRINTF} 'LDPATH="%s"\n' ${PREFIX}/lib/yukon \
+ >> ${TMPDIR}/yukon-system-conf
+ ${INSTALL_DATA} ${TMPDIR}/yukon-system-conf \
+ ${STAGEDIR}${PREFIX}/etc/yukon/system/default
+ ${INSTALL_DATA} ${WRKSRC}/tools/yukon.conf \
+ ${STAGEDIR}${PREFIX}/etc/yukon/conf.sample
+
+.include <bsd.port.mk>
diff --git a/graphics/yukon/distinfo b/graphics/yukon/distinfo
new file mode 100644
index 000000000000..101b6fa35389
--- /dev/null
+++ b/graphics/yukon/distinfo
@@ -0,0 +1,2 @@
+SHA256 (yukon-2010011201.tar.bz2) = 8e261dfe86c762912b9d1a577909c77a01b0877d4ac86bde0ba1c6b7901a3bdd
+SIZE (yukon-2010011201.tar.bz2) = 13388
diff --git a/graphics/yukon/files/patch-Makefile b/graphics/yukon/files/patch-Makefile
new file mode 100644
index 000000000000..6caf56570c47
--- /dev/null
+++ b/graphics/yukon/files/patch-Makefile
@@ -0,0 +1,51 @@
+--- Makefile.orig 2007-07-31 17:10:01 UTC
++++ Makefile
+@@ -1,15 +1,14 @@
+
+ DESTDIR =
+-PREFIX = /usr/local
+ LIBDIR = lib
+
+-CC = gcc
+-CFLAGS = -Iinclude -Wall -std=c99 -O3
++CC ?= gcc
++CFLAGS = -I${PWD}/include -Wall -std=c99 -I$(LOCALBASE)/include -L$(LOCALBASE)/lib
+
+ OBJS = src/core/conf.o src/core/glue.o src/core/log.o
+ LIBS = libX11.so libGL.so
+
+--include config.make
++###-include config.make
+
+ .PHONY: all clean install
+ all: $(LIBS) yukon-core-lib sysconf
+@@ -23,19 +22,24 @@ $(LIBS):
+ rm -f $@.native
+
+ yukon-core-lib: $(OBJS)
+- $(CC) -shared -o $@ $(OBJS) -lseom
++ $(CC) -shared -o $@ $(OBJS) -lseom -L${LOCALBASE}/lib
+
+ sysconf:
+ echo 'LDPATH="$(PREFIX)/$(LIBDIR)/yukon"' > $@
+
+-soname = `objdump -x /usr/$(LIBDIR)/$(1) | grep SONAME | awk '{ print $$2 }'`
++soname = `objdump -x $(PREFIX)/$(LIBDIR)/$(1) | grep SONAME | awk '{ print $$2 }'`
+ install: $(LIBS) yukon-core-lib
+ install -m 755 -d $(DESTDIR)$(PREFIX)/bin $(DESTDIR)$(PREFIX)/$(LIBDIR)/yukon
+ install -m 755 src/scripts/yukon $(DESTDIR)$(PREFIX)/bin
+ install -m 755 yukon-core-lib $(DESTDIR)$(PREFIX)/$(LIBDIR)/yukon
+-
+- $(foreach lib,$(LIBS),ln -sf /usr/$(LIBDIR)/$(lib) $(DESTDIR)$(PREFIX)/$(LIBDIR)/yukon/$(lib).native;)
+- $(foreach lib,$(LIBS),install -m 755 $(lib) $(DESTDIR)$(PREFIX)/$(LIBDIR)/yukon/$(call soname,$(lib));)
++ ln -sf $(LOCALBASE)/lib/libX11.so.$(LIBX11_MAJOR) \
++ $(DESTDIR)$(PREFIX)/$(LIBDIR)/yukon/libX11.so.native
++ ln -sf $(LOCALBASE)/lib/libGL.so.$(LIBGL_MAJOR) \
++ $(DESTDIR)$(PREFIX)/$(LIBDIR)/yukon/libGL.so.native
++ install -m 755 libX11.so \
++ $(DESTDIR)$(PREFIX)/$(LIBDIR)/yukon/libX11.so.$(LIBX11_MAJOR)
++ install -m 755 libGL.so \
++ $(DESTDIR)$(PREFIX)/$(LIBDIR)/yukon/libGL.so.$(LIBGL_MAJOR)
+
+ clean:
+ rm -f $(OBJS) $(LIBS) yukon-core-lib sysconf
diff --git a/graphics/yukon/files/patch-include_yukon.h b/graphics/yukon/files/patch-include_yukon.h
new file mode 100644
index 000000000000..e280a47d1438
--- /dev/null
+++ b/graphics/yukon/files/patch-include_yukon.h
@@ -0,0 +1,14 @@
+--- include/yukon.h.orig 2007-06-07 13:30:34 UTC
++++ include/yukon.h
+@@ -2,8 +2,10 @@
+ #ifndef __YUKON_H__
+ #define __YUKON_H__
+
++#include <sys/param.h>
++#include <sys/limits.h>
++
+ #include <stdarg.h>
+-#include <linux/limits.h>
+
+ #include <seom/seom.h>
+
diff --git a/graphics/yukon/pkg-descr b/graphics/yukon/pkg-descr
new file mode 100644
index 000000000000..7d6c48cf927e
--- /dev/null
+++ b/graphics/yukon/pkg-descr
@@ -0,0 +1,6 @@
+Yukon is a set of libraries and applications that are designed to
+capture realtime videos of OpenGL applications (games). The original
+design idea is based on Anandtech's FrameGetter, but was extended
+to suit today's high-performance computers.
+
+WWW: https://github.com/wereHamster/yukon
diff --git a/graphics/yukon/pkg-plist b/graphics/yukon/pkg-plist
new file mode 100644
index 000000000000..d4e4b8bb8811
--- /dev/null
+++ b/graphics/yukon/pkg-plist
@@ -0,0 +1,8 @@
+bin/yukon
+@sample etc/yukon/conf.sample
+etc/yukon/system/default
+lib/yukon/libGL.so.%%LIBGL_MAJOR%%
+lib/yukon/libGL.so.native
+lib/yukon/libX11.so.%%LIBX11_MAJOR%%
+lib/yukon/libX11.so.native
+lib/yukon/yukon-core-lib