aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-05-11 03:53:45 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-05-11 03:53:45 +0800
commitdd243dc8e0ead158250793eb866e3ed75c87916c (patch)
tree631874d8590f1155282736006ef26457693b7212 /graphics
parentcc1f5fb606278f50f7e9b8830973beeb31333d25 (diff)
downloadfreebsd-ports-gnome-dd243dc8e0ead158250793eb866e3ed75c87916c.tar.gz
freebsd-ports-gnome-dd243dc8e0ead158250793eb866e3ed75c87916c.tar.zst
freebsd-ports-gnome-dd243dc8e0ead158250793eb866e3ed75c87916c.zip
- Fix dependency
- Fix LICENSE_COMB - Switch to options helpers - Add NO_ARCH Approved by: portmgr blanket
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-pyggel/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/graphics/py-pyggel/Makefile b/graphics/py-pyggel/Makefile
index 6ac04da8efcb..064d4cc14ef9 100644
--- a/graphics/py-pyggel/Makefile
+++ b/graphics/py-pyggel/Makefile
@@ -15,40 +15,38 @@ MAINTAINER= koalative@gmail.com
COMMENT= Python Graphical Game Engine and Libraries
LICENSE= LGPL3 PD
-LICENSE_COMB= dual
+LICENSE_COMB= multi
RUN_DEPENDS= ${PYNUMPY} \
${PYGAME} \
- ${PYTHON_PKGNAMEPREFIX}opengl>=0:graphics/py-PyOpenGL \
+ ${PYTHON_PKGNAMEPREFIX}PyOpenGL>=0:graphics/py-PyOpenGL \
${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow
USES= dos2unix python:2 zip
DOS2UNIX_GLOB= *.mtl *.py *.txt
USE_PYTHON= autoplist distutils
NO_BUILD= yes
+NO_ARCH= yes
PORTDOCS= Readme.txt
PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|data_files =|#data_files =|' \
${WRKSRC}/setup.py
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.if ${PORT_OPTIONS:MEXAMPLES}
+post-install-EXAMPLES-on:
@(cd ${WRKSRC}/examples_and_tutorials && ${COPYTREE_SHARE} . \
${STAGEDIR}${EXAMPLESDIR}/examples_and_tutorials)
@(cd ${WRKSRC} && ${COPYTREE_SHARE} data ${STAGEDIR}${EXAMPLESDIR})
-. for f in test_FBO test_camera test_gui test_mesh test_particle test_texture_swap
+.for f in test_FBO test_camera test_gui test_mesh test_particle test_texture_swap
@(cd ${WRKSRC} && ${COPYTREE_SHARE} ${f}.py ${STAGEDIR}${EXAMPLESDIR})
-. endfor
-.endif
+.endfor
.include <bsd.port.mk>