aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-04-03 16:14:43 +0800
committerwill <will@FreeBSD.org>2001-04-03 16:14:43 +0800
commite282c995211fa7d389e4d3b437d0ff892d4d929b (patch)
treec8e1217a1b00314713ec60f3c0d07c11dc242116 /graphics
parenta4c43b9975be01621916750b073e7125e629feba (diff)
downloadfreebsd-ports-gnome-e282c995211fa7d389e4d3b437d0ff892d4d929b.tar.gz
freebsd-ports-gnome-e282c995211fa7d389e4d3b437d0ff892d4d929b.tar.zst
freebsd-ports-gnome-e282c995211fa7d389e4d3b437d0ff892d4d929b.zip
Overhaul QT/KDE support:
- bsd.port.mk update to use bsd.kde.mk for USE_{QT,KDE}* - Cleanup corresponding ports for bsd.kde.mk update. - Fix bsd.kde.mk: use correct kdelibs dependency, put qt at the bottom, introduce QT_NONSTANDARD variable for nonstandard configure setup. - Update KDE2 to 2.1.1. Two patches included in x11/kdelibs2 to fix the proxy authentication that was broken for 2.1.1. Remove old patches. - Potentially fix kdelibs build for alpha. - Fix qt-designer 2.3.0 build. - Ruby stuff left alone since it looks like black magic to me. Should still work w/ compat shims for older USE_QT[,2] style. Some others were also left alone for the same reason. Reviewed by: portmgr, ports (bsd.kde.mk+bsd.port.mk) Submitted by: David Faure <faure@kde.org> (proxy auth patches) Alex Zepeda <garbanzo@kde.org> (old patches removal)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/avifile/Makefile8
-rw-r--r--graphics/ecg2png/Makefile6
-rw-r--r--graphics/imanager/Makefile5
-rw-r--r--graphics/kdegraphics2/Makefile12
-rw-r--r--graphics/kdegraphics2/distinfo2
-rw-r--r--graphics/kdegraphics3/Makefile12
-rw-r--r--graphics/kdegraphics3/distinfo2
-rw-r--r--graphics/kdegraphics4/Makefile12
-rw-r--r--graphics/kdegraphics4/distinfo2
-rw-r--r--graphics/killustrator/Makefile6
-rw-r--r--graphics/kplot3d/Makefile4
-rw-r--r--graphics/view3ds/Makefile2
12 files changed, 20 insertions, 53 deletions
diff --git a/graphics/avifile/Makefile b/graphics/avifile/Makefile
index 5a41ad1ef4a2..f1476632e523 100644
--- a/graphics/avifile/Makefile
+++ b/graphics/avifile/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl-devel
RUN_DEPENDS= ${CODEC_DETECTION_FILE}:${CODEC_PORT}
ONLY_FOR_ARCHS= i386
-USE_QT2= yes
+USE_QT_VER= 2
USE_XLIB= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
@@ -28,11 +28,8 @@ USE_AUTOCONF= yes
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- MOC="${MOC}" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib \
- --with-win32-path=${LOCALBASE}/lib/win32 \
+CONFIGURE_ARGS= --with-win32-path=${LOCALBASE}/lib/win32 \
--enable-release
PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
@@ -50,7 +47,6 @@ LIB_VERSION= 0
EXTRA_BUILD_DIR= player samples/benchmark samples/qtrecompress
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-MOC?= ${X11BASE}/bin/moc2
DIFF?= /usr/bin/diff
.include <bsd.port.pre.mk>
diff --git a/graphics/ecg2png/Makefile b/graphics/ecg2png/Makefile
index 166c91e5f305..552dabdf20cd 100644
--- a/graphics/ecg2png/Makefile
+++ b/graphics/ecg2png/Makefile
@@ -15,11 +15,11 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
-USE_QT2= yes
+USE_QT_VER= 2
WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${X11BASE}/include/qt2 -I${LOCALBASE}/include/gd" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ARGS= --x-includes=${X11BASE}/include --x-libraries=${X11BASE}/lib
+QTCPPFLAGS+= -I/usr/local/include/gd
USE_GMAKE= yes
USE_AUTOMAKE= yes
diff --git a/graphics/imanager/Makefile b/graphics/imanager/Makefile
index e1a456dd5edf..55adc3d7088a 100644
--- a/graphics/imanager/Makefile
+++ b/graphics/imanager/Makefile
@@ -13,10 +13,9 @@ DISTNAME= imanager-${PORTVERSION}.final.imlib
MAINTAINER= ports@freebsd.org
-LIB_DEPENDS= Imlib.5:${PORTSDIR}/graphics/imlib \
- kdecore.3:${PORTSDIR}/x11/kdelibs11
+LIB_DEPENDS= Imlib.5:${PORTSDIR}/graphics/imlib
-USE_QT= yes
+USE_KDELIBS_VER=1
HAS_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/graphics/kdegraphics2/Makefile b/graphics/kdegraphics2/Makefile
index 5cd06a85e3bc..193b12e8e9e0 100644
--- a/graphics/kdegraphics2/Makefile
+++ b/graphics/kdegraphics2/Makefile
@@ -6,28 +6,20 @@
#
PORTNAME= kdegraphics
-PORTVERSION= 2.1
+PORTVERSION= 2.1.1
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/distribution/tar/generic/src
MAINTAINER= will@FreeBSD.org
-LIB_DEPENDS= kdecore.4:${PORTSDIR}/x11/kdelibs2
BUILD_DEPENDS= dvips:${PORTSDIR}/print/teTeX
RUN_DEPENDS= dvips:${PORTSDIR}/print/teTeX
-USE_QT2= yes
-MOC?= ${X11BASE}/bin/moc2
+USE_KDELIBS_VER=2
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib
-CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc" \
- USER_LDFLAGS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes
.include <bsd.port.mk>
diff --git a/graphics/kdegraphics2/distinfo b/graphics/kdegraphics2/distinfo
index a61e71638f8d..dbb28870f30f 100644
--- a/graphics/kdegraphics2/distinfo
+++ b/graphics/kdegraphics2/distinfo
@@ -1 +1 @@
-MD5 (kdegraphics-2.1.tar.bz2) = 3cb2294fc570fa771a834bef64d2bf33
+MD5 (kdegraphics-2.1.1.tar.bz2) = 686f47becc517d4e6358b35b8a6f2b58
diff --git a/graphics/kdegraphics3/Makefile b/graphics/kdegraphics3/Makefile
index 5cd06a85e3bc..193b12e8e9e0 100644
--- a/graphics/kdegraphics3/Makefile
+++ b/graphics/kdegraphics3/Makefile
@@ -6,28 +6,20 @@
#
PORTNAME= kdegraphics
-PORTVERSION= 2.1
+PORTVERSION= 2.1.1
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/distribution/tar/generic/src
MAINTAINER= will@FreeBSD.org
-LIB_DEPENDS= kdecore.4:${PORTSDIR}/x11/kdelibs2
BUILD_DEPENDS= dvips:${PORTSDIR}/print/teTeX
RUN_DEPENDS= dvips:${PORTSDIR}/print/teTeX
-USE_QT2= yes
-MOC?= ${X11BASE}/bin/moc2
+USE_KDELIBS_VER=2
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib
-CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc" \
- USER_LDFLAGS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes
.include <bsd.port.mk>
diff --git a/graphics/kdegraphics3/distinfo b/graphics/kdegraphics3/distinfo
index a61e71638f8d..dbb28870f30f 100644
--- a/graphics/kdegraphics3/distinfo
+++ b/graphics/kdegraphics3/distinfo
@@ -1 +1 @@
-MD5 (kdegraphics-2.1.tar.bz2) = 3cb2294fc570fa771a834bef64d2bf33
+MD5 (kdegraphics-2.1.1.tar.bz2) = 686f47becc517d4e6358b35b8a6f2b58
diff --git a/graphics/kdegraphics4/Makefile b/graphics/kdegraphics4/Makefile
index 5cd06a85e3bc..193b12e8e9e0 100644
--- a/graphics/kdegraphics4/Makefile
+++ b/graphics/kdegraphics4/Makefile
@@ -6,28 +6,20 @@
#
PORTNAME= kdegraphics
-PORTVERSION= 2.1
+PORTVERSION= 2.1.1
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/distribution/tar/generic/src
MAINTAINER= will@FreeBSD.org
-LIB_DEPENDS= kdecore.4:${PORTSDIR}/x11/kdelibs2
BUILD_DEPENDS= dvips:${PORTSDIR}/print/teTeX
RUN_DEPENDS= dvips:${PORTSDIR}/print/teTeX
-USE_QT2= yes
-MOC?= ${X11BASE}/bin/moc2
+USE_KDELIBS_VER=2
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib
-CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc" \
- USER_LDFLAGS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes
.include <bsd.port.mk>
diff --git a/graphics/kdegraphics4/distinfo b/graphics/kdegraphics4/distinfo
index a61e71638f8d..dbb28870f30f 100644
--- a/graphics/kdegraphics4/distinfo
+++ b/graphics/kdegraphics4/distinfo
@@ -1 +1 @@
-MD5 (kdegraphics-2.1.tar.bz2) = 3cb2294fc570fa771a834bef64d2bf33
+MD5 (kdegraphics-2.1.1.tar.bz2) = 686f47becc517d4e6358b35b8a6f2b58
diff --git a/graphics/killustrator/Makefile b/graphics/killustrator/Makefile
index 925f1fde5d9f..cdf8f6b84b02 100644
--- a/graphics/killustrator/Makefile
+++ b/graphics/killustrator/Makefile
@@ -12,12 +12,10 @@ MASTER_SITES= http://wwwiti.cs.uni-magdeburg.de/~sattler/pub/killustrator/
MAINTAINER= jedgar@FreeBSD.org
-LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11 \
- intl.1:${PORTSDIR}/devel/gettext \
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-RUN_DEPENDS= ${LOCALBASE}/bin/kdehelp:${PORTSDIR}/x11/kdebase11
-USE_QT= yes
+USE_KDEBASE_VER=1
USE_GMAKE= yes
USE_LIBTOOL= yes
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
diff --git a/graphics/kplot3d/Makefile b/graphics/kplot3d/Makefile
index 4b59c7ae7a69..72bb0acc5b66 100644
--- a/graphics/kplot3d/Makefile
+++ b/graphics/kplot3d/Makefile
@@ -12,9 +12,7 @@ MASTER_SITES= http://members.nbci.com/kplot3d/
MAINTAINER= jedgar@FreeBSD.org
-LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11
-
-USE_QT= yes
+USE_KDELIBS_VER=1
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/graphics/view3ds/Makefile b/graphics/view3ds/Makefile
index 671831e5dcc5..a6fb0436a6ea 100644
--- a/graphics/view3ds/Makefile
+++ b/graphics/view3ds/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= sobomax@FreeBSD.org
LIB_DEPENDS= 3ds.0:${PORTSDIR}/graphics/lib3ds
USE_X_PREFIX= yes
-USE_QT2= yes
+USE_QT_VER= 2
USE_MESA= yes
USE_GMAKE= yes
USE_LIBTOOL= yes