aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2007-10-26 03:20:04 +0800
committermezz <mezz@FreeBSD.org>2007-10-26 03:20:04 +0800
commitee8b5bb05b7610425be59f0e983040bf097211ea (patch)
tree0c7adc0a3888cd52f41b73ced1c90d0e2ca71c3f /graphics
parent1449e3ad681c8bfee52c3d13c7ef83d651651787 (diff)
downloadfreebsd-ports-gnome-ee8b5bb05b7610425be59f0e983040bf097211ea.tar.gz
freebsd-ports-gnome-ee8b5bb05b7610425be59f0e983040bf097211ea.tar.zst
freebsd-ports-gnome-ee8b5bb05b7610425be59f0e983040bf097211ea.zip
- Fix the plist when GNOME support disable.
- Ensure it will actually diable GNOME support for real if anyone run WITHOUT_GNOME=libgnomeui by add --diable-* PR: ports/117503 Reported by: Dmitry Marakasov <amdmi3@amdmi3.ru>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/dia/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/dia/Makefile b/graphics/dia/Makefile
index c63fb10bdfcc..ccdde291e3f2 100644
--- a/graphics/dia/Makefile
+++ b/graphics/dia/Makefile
@@ -8,7 +8,7 @@
PORTNAME= dia
DISTVERSION= 0.96.1
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
@@ -51,13 +51,16 @@ USE_GNOME+= libgnomeui
CONFIGURE_ARGS+= --enable-gnome --enable-bonobo
PKGNAMESUFFIX= -gnome
GNOME_ENABLED= yes
+.else
+CONFIGURE_ARGS+= --disable-gnome --disable-bonobo
.endif
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/lib/intl.c
- @${REINPLACE_CMD} -e 's|[(]pkgdatadir[)]/help|(datadir)/gnome/help/dia|g' \
- ${WRKSRC}/doc/Makefile.in
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|[(]pkgdatadir[)]/help|(datadir)/gnome/help/dia|g ; \
+ s|[(]datadir[)]/help|(datadir)/gnome/help|g'
.ifndef (GNOME_ENABLED)
@${FIND} ${WRKSRC} -name Makefile.in | \
${XARGS} ${REINPLACE_CMD} -e \