aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-10-16 06:23:25 +0800
committerkris <kris@FreeBSD.org>2003-10-16 06:23:25 +0800
commitf9b8a43f16536bbc163670780a8ba1b1493ab25f (patch)
tree2aa38ce908f8f531a2345f4fccb5514c0c1a5ae6 /graphics
parentdc7dab69f2bb0fa4ab19824cfb8731526ee017c5 (diff)
downloadfreebsd-ports-gnome-f9b8a43f16536bbc163670780a8ba1b1493ab25f.tar.gz
freebsd-ports-gnome-f9b8a43f16536bbc163670780a8ba1b1493ab25f.tar.zst
freebsd-ports-gnome-f9b8a43f16536bbc163670780a8ba1b1493ab25f.zip
BROKEN on 5.x: does not compile
Diffstat (limited to 'graphics')
-rw-r--r--graphics/evolvotron/Makefile8
-rw-r--r--graphics/filmgimp/Makefile4
-rw-r--r--graphics/kisomandel/Makefile8
-rw-r--r--graphics/picturebook/Makefile8
4 files changed, 25 insertions, 3 deletions
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
index 8e9d5a050937..886bf53ddbe6 100644
--- a/graphics/evolvotron/Makefile
+++ b/graphics/evolvotron/Makefile
@@ -24,7 +24,13 @@ GNU_CONFIGURE= yes
MAKE_ENV= QTDIR="${QTDIR}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/evolvotron ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/filmgimp/Makefile b/graphics/filmgimp/Makefile
index 503753eebb88..7fa1922ee471 100644
--- a/graphics/filmgimp/Makefile
+++ b/graphics/filmgimp/Makefile
@@ -39,6 +39,10 @@ MAKE_ENV+= CC=${CC} CXX=${CXX}
MAN1= filmgimp.1 filmgimptool.1
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
post-configure:
# this must be done to avoid conflicts with ${X11BASE}/include/libgimp/
@${FIND} ${WRKSRC} -name "Makefile" | \
diff --git a/graphics/kisomandel/Makefile b/graphics/kisomandel/Makefile
index 58367cbed22d..f74f41f43c41 100644
--- a/graphics/kisomandel/Makefile
+++ b/graphics/kisomandel/Makefile
@@ -24,10 +24,16 @@ GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s,-lqt,-lqt2,g" ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e "s,-lqt,-lqt2,g"
@${REINPLACE_CMD} -e "s,malloc.h,stdlib.h,g" ${WRKSRC}/kisomandel/fractal.cpp
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/picturebook/Makefile b/graphics/picturebook/Makefile
index 2b4bcc38a28d..9103c7958d1a 100644
--- a/graphics/picturebook/Makefile
+++ b/graphics/picturebook/Makefile
@@ -19,6 +19,12 @@ COMMENT= SONY VAIO camera capture utility
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GNOME= imlib
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
post-build:
cd ${WRKSRC}; \
${CC} ${CFLAGS} -o setbrightness setbrightness.c; \
@@ -33,4 +39,4 @@ do-install:
.if!defined(NOPORTDOCS)
${INSTALL_MAN} ${PATCHDIR}/README.FreeBSD ${DOCSDIR}/README.FreeBSD
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>