aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2002-03-31 12:08:43 +0800
committerkris <kris@FreeBSD.org>2002-03-31 12:08:43 +0800
commit0c4ad11f9c87f218dfa4a20cf6429f0bf73808ad (patch)
treee6341164ce44253cf488db509ffb9a79e1730699 /graphics
parenteb0f18a1af0516452fc403116f98f657d4dd99bb (diff)
downloadfreebsd-ports-gnome-0c4ad11f9c87f218dfa4a20cf6429f0bf73808ad.tar.gz
freebsd-ports-gnome-0c4ad11f9c87f218dfa4a20cf6429f0bf73808ad.tar.zst
freebsd-ports-gnome-0c4ad11f9c87f218dfa4a20cf6429f0bf73808ad.zip
Remove #include <malloc.h>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/osg-devel/Makefile5
-rw-r--r--graphics/osg/Makefile5
2 files changed, 10 insertions, 0 deletions
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index d2a52dce24ac..bc35a579b9d8 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -28,6 +28,11 @@ MAKE_ENV= CXX="${CXX}" \
ALL_TARGET= freebsd
+pre-patch:
+ @${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
+ ${WRKSRC}/src/osgPlugins/flt/Input.cpp \
+ ${WRKSRC}/src/osgPlugins/flt/Record.cpp
+
post-patch:
.for suf in defs rules
@${LN} -sf ${WRKSRC}/Make/make${suf}.linux \
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index d2a52dce24ac..bc35a579b9d8 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -28,6 +28,11 @@ MAKE_ENV= CXX="${CXX}" \
ALL_TARGET= freebsd
+pre-patch:
+ @${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
+ ${WRKSRC}/src/osgPlugins/flt/Input.cpp \
+ ${WRKSRC}/src/osgPlugins/flt/Record.cpp
+
post-patch:
.for suf in defs rules
@${LN} -sf ${WRKSRC}/Make/make${suf}.linux \