aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2007-08-19 03:50:29 +0800
committerbeech <beech@FreeBSD.org>2007-08-19 03:50:29 +0800
commit0c5e1ec2167631408f1dd53738511ebf87768c6f (patch)
tree490893ab3cdace3bc7f42e79d9a32d82a92a09a6 /graphics
parentd5114a5875164c0f9f15689db7914cae5efa065b (diff)
downloadfreebsd-ports-gnome-0c5e1ec2167631408f1dd53738511ebf87768c6f.tar.gz
freebsd-ports-gnome-0c5e1ec2167631408f1dd53738511ebf87768c6f.tar.zst
freebsd-ports-gnome-0c5e1ec2167631408f1dd53738511ebf87768c6f.zip
- Fix build with gcc42
- Add patch-gcc4 PR: ports/115566 Submitted by: David Yeske <dyeske@gmail.com> (maintainer) Approved by: sat (mentor) Obtained from: Gentoo Portage
Diffstat (limited to 'graphics')
-rw-r--r--graphics/evolvotron/Makefile13
-rw-r--r--graphics/evolvotron/files/patch-gcc433
2 files changed, 40 insertions, 6 deletions
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
index 6b0d4d1ee6a9..7fcf72945fbc 100644
--- a/graphics/evolvotron/Makefile
+++ b/graphics/evolvotron/Makefile
@@ -8,8 +8,7 @@ PORTNAME= evolvotron
PORTVERSION= 0.4.0
PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= dyeske@gmail.com
COMMENT= Generative software that evolves images/textures/patterns
@@ -20,7 +19,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_QT_VER= 3
USE_PYTHON= yes
-USE_X_PREFIX= yes
+USE_XORG= x11
GNU_CONFIGURE= yes
MAKE_ENV= QTDIR=${QT_PREFIX} MOC=${MOC}
@@ -32,9 +31,11 @@ post-patch:
${WRKSRC}/common.pro
do-configure:
- cd ${WRKSRC} && ./text_to_markup.py -html < USAGE > evolvotron.html
- cd ${WRKSRC} && ./text_to_markup.py -qml -s < USAGE > libevolvotron/usage_text.h
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ VERSION_NUMBER=${PORTVERSION} main.pro
+ @cd ${WRKSRC} && ./text_to_markup.py -html < USAGE > evolvotron.html
+ @cd ${WRKSRC} && ./text_to_markup.py -qml -s < USAGE > libevolvotron/usage_text.h
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake -spec \
+ ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
+ VERSION_NUMBER=${PORTVERSION} main.pro
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/evolvotron/evolvotron ${PREFIX}/bin
diff --git a/graphics/evolvotron/files/patch-gcc4 b/graphics/evolvotron/files/patch-gcc4
new file mode 100644
index 000000000000..63b0d335b067
--- /dev/null
+++ b/graphics/evolvotron/files/patch-gcc4
@@ -0,0 +1,33 @@
+diff -Nru evolvotron.vanilla/libevolvotron/function_node.h evolvotron/libevolvotron/function_node.h
+--- libevolvotron/function_node.h 2006-09-03 17:42:30.000000000 +0200
++++ libevolvotron/function_node.h 2006-09-03 17:46:11.000000000 +0200
+@@ -133,7 +133,7 @@
+ static const std::vector<FunctionNode*> stubargs(const MutationParameters& parameters,uint n,bool exciting=false);
+
+ //! Return a suitable starting value for a node's iteration count (assuming it's iterative).
+- static const uint FunctionNode::stubiterations(const MutationParameters& parameters);
++ static const uint stubiterations(const MutationParameters& parameters);
+
+ //! Constructor given an array of params and args and an iteration count.
+ /*! These MUST be provided; there are no alterative constructors.
+diff -Nru evolvotron.vanilla/libevolvotron/mutation_parameters.h evolvotron/libevolvotron/mutation_parameters.h
+--- libevolvotron/mutation_parameters.h 2006-09-03 17:42:30.000000000 +0200
++++ libevolvotron/mutation_parameters.h 2006-09-03 17:43:19.000000000 +0200
+@@ -266,7 +266,7 @@
+ //! This returns a new random bit of tree.
+ /*! Setting the "exciting" flag avoids the most basic node types, but only at the top level of the stub tree.
+ */
+- FunctionNode*const MutationParameters::random_function_stub(bool exciting) const;
++ FunctionNode*const random_function_stub(bool exciting) const;
+
+ void change_function_weighting(const FunctionRegistration* fn,float w);
+
+@@ -277,7 +277,7 @@
+ protected:
+
+ //! Return a random function appropriately biased by current settings
+- FunctionNode*const MutationParameters::random_function() const;
++ FunctionNode*const random_function() const;
+
+ //! Return a random function registration, appropriately biased by current settings
+ const FunctionRegistration*const random_weighted_function_registration() const;