aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2017-12-31 20:42:19 +0800
committerzeising <zeising@FreeBSD.org>2017-12-31 20:42:19 +0800
commit161625cb8fbdd03d4813188afc1121981f81129c (patch)
tree30acbf053095ce304cea6d02b990f9f2dd1aecb3 /graphics
parent82b10d0cf2e3f367d5a0e99cd5664ab5e65079c4 (diff)
downloadfreebsd-ports-gnome-161625cb8fbdd03d4813188afc1121981f81129c.tar.gz
freebsd-ports-gnome-161625cb8fbdd03d4813188afc1121981f81129c.tar.zst
freebsd-ports-gnome-161625cb8fbdd03d4813188afc1121981f81129c.zip
Properly fix when X11 option is off.
When the X11 option is off, there are still things in the Imlib2.h header that uses X11, fix this by removing those bits when building without X11. PR: 224354 Submitted by: Dominik Honnef
Diffstat (limited to 'graphics')
-rw-r--r--graphics/imlib2/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index 34f6e8f7860a..146be68b6a23 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= imlib2
PORTVERSION= 1.4.10
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= graphics enlightenment
MASTER_SITES= SF/enlightenment/imlib2-src/${PORTVERSION}
@@ -63,10 +64,10 @@ CONFIGURE_ARGS+= --enable-amd64
CONFIGURE_ARGS+= --disable-amd64
.endif
-post-patch-X11-on:
+post-patch-X11-off:
@${REINPLACE_CMD} -e '/MY_LIBS =/s/-lXext -lX11//' \
${WRKSRC}/src/lib/Makefile.in
- @${REINPLACE_CMD} -e '/# ifndef X_DISPLAY_MISSING/,/# endif/ d' \
+ @${REINPLACE_CMD} -e '/#ifndef X_DISPLAY_MISSING/,/#endif/ d' \
${WRKSRC}/src/lib/Imlib2.h
.include <bsd.port.mk>