aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2000-10-26 19:25:17 +0800
committerache <ache@FreeBSD.org>2000-10-26 19:25:17 +0800
commit52dcf7b515329a2d13c6ca783885c9a79ca3d774 (patch)
treedb636fdbf6d780a5128844704d09f0df41738cf9 /graphics
parent0d9b24966f3a978d20315946399702f552dd75e1 (diff)
downloadfreebsd-ports-gnome-52dcf7b515329a2d13c6ca783885c9a79ca3d774.tar.gz
freebsd-ports-gnome-52dcf7b515329a2d13c6ca783885c9a79ca3d774.tar.zst
freebsd-ports-gnome-52dcf7b515329a2d13c6ca783885c9a79ca3d774.zip
Rename PNG_WITH_MMX to WITH_PNG_MMX to be consistent with other WITH_*
variables Requested by: ade
Diffstat (limited to 'graphics')
-rw-r--r--graphics/png/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index a22318702b26..58f3c6e8f43e 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -32,7 +32,7 @@ MAN5= png.5
.include <bsd.port.pre.mk>
-.if defined(PNG_WITH_MMX) && (${ARCH} == "i386")
+.if defined(WITH_PNG_MMX) && (${ARCH} == "i386")
MAKE_ENV+= USE_MMX=yes
MMX_PATCH= libpng-mmx-1.0.9pre3.zip
DISTFILES+= ${MMX_PATCH}
@@ -44,13 +44,13 @@ post-extract:
# Please don't delete the following line - this link used by ghostscript* ports
@${LN} -sf ${WRKSRC} ${WRKDIR}/libpng
#
-.if defined(PNG_WITH_MMX) && (${ARCH} == "i386")
+.if defined(WITH_PNG_MMX) && (${ARCH} == "i386")
@cd ${WRKDIR} && unzip ${DISTDIR}/${MMX_PATCH} >/dev/null
@${CP} ${WRKDIR}/pnggccrd.c ${WRKSRC}/pnggccrd.c
.elif ${ARCH} == "i386"
@${ECHO_MSG}
@${ECHO_MSG} " If you have a CPU with MMX instruction set (Pentium/P55C and higher) you can"
- @${ECHO_MSG} " try to add \"PNG_WITH_MMX=YES\" to /etc/make.conf to build libpng with"
+ @${ECHO_MSG} " try to add \"WITH_PNG_MMX=YES\" to /etc/make.conf to build libpng with"
@${ECHO_MSG} " MMX-optimized assembler routines."
@${ECHO_MSG}
.endif