aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-06-15 21:10:58 +0800
committerpav <pav@FreeBSD.org>2007-06-15 21:10:58 +0800
commit56a247b739769f5ad350948a34d30f4de1154682 (patch)
treed8b0668a1c030801b3f6bdcfa06e1654f89da96e /graphics
parent7c5159d4553112044b886e6c672f0b0c1455c0c8 (diff)
downloadfreebsd-ports-gnome-56a247b739769f5ad350948a34d30f4de1154682.tar.gz
freebsd-ports-gnome-56a247b739769f5ad350948a34d30f4de1154682.tar.zst
freebsd-ports-gnome-56a247b739769f5ad350948a34d30f4de1154682.zip
- Fix pstoedit detection in configure script, pstoedit switched to pkg-config
recently - Style PR: ports/111400 Reported by: bf <bf2006a@yahoo.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/autotrace/Makefile9
-rw-r--r--graphics/autotrace/files/patch-configure13
2 files changed, 6 insertions, 16 deletions
diff --git a/graphics/autotrace/Makefile b/graphics/autotrace/Makefile
index 9b4a7cf4f203..5323cbddf6e8 100644
--- a/graphics/autotrace/Makefile
+++ b/graphics/autotrace/Makefile
@@ -7,7 +7,7 @@
PORTNAME= autotrace
PORTVERSION= 0.31.1
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,7 +21,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
pstoedit.0:${PORTSDIR}/graphics/pstoedit
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/ming"
@@ -29,9 +29,12 @@ USE_XLIB= yes
MAN1= autotrace.1
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e \
's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|' \
${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/$$PSTOEDIT_CONFIG/ s|--version|--modversion| ; \
+ s|$$PSTOEDIT_CONFIG $$pstoedit_args|pkg-config pstoedit| ; \
+ /^PSTOEDIT_CONFIG=/ s|=.*$$|=pkg-config| ' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/graphics/autotrace/files/patch-configure b/graphics/autotrace/files/patch-configure
deleted file mode 100644
index 3cb74ad296d7..000000000000
--- a/graphics/autotrace/files/patch-configure
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- configure 2002/09/12 11:32:09 1.1
-+++ configure 2002/09/12 11:32:32
-@@ -6509,6 +6509,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'