aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-10-17 17:04:40 +0800
committerknu <knu@FreeBSD.org>2000-10-17 17:04:40 +0800
commit819646bfc081be2e8a97ece1f376efacff9fd762 (patch)
treee45d5e4b6d3c6bcc494f1762e098abbd88e26d61 /graphics
parent27133eb33b182369fe2d176019826f6d8182f25c (diff)
downloadfreebsd-ports-gnome-819646bfc081be2e8a97ece1f376efacff9fd762.tar.gz
freebsd-ports-gnome-819646bfc081be2e8a97ece1f376efacff9fd762.tar.zst
freebsd-ports-gnome-819646bfc081be2e8a97ece1f376efacff9fd762.zip
Respect CC and CFLAGS.
Define and use SWIG instead of hardcoding swig's executable name in a patch. Remove the "chmod 755 xxx.so" line from the distributed Makefile.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-ming/Makefile6
-rw-r--r--graphics/py-ming/files/patch-Makefile13
2 files changed, 10 insertions, 9 deletions
diff --git a/graphics/py-ming/Makefile b/graphics/py-ming/Makefile
index c774aee1cdc5..0629866e0b01 100644
--- a/graphics/py-ming/Makefile
+++ b/graphics/py-ming/Makefile
@@ -14,7 +14,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= swig1.3:${PORTSDIR}/devel/SWIG-devel
+BUILD_DEPENDS= ${SWIG}:${PORTSDIR}/devel/SWIG-devel
LIB_DEPENDS= ming.0:${PORTSDIR}/graphics/ming
USE_PYTHON= yes
@@ -22,7 +22,9 @@ USE_PYTHON= yes
MD5_FILE= ${PORTSDIR}/graphics/ming/distinfo
WRKSRC= ${WRKDIR}/${DISTNAME}/py_ext
-MAKE_ARGS= PYTHON_VERSION="${PYTHON_VERSION}"
+MAKE_ARGS= PYTHON_VERSION="${PYTHON_VERSION}" SWIG="${SWIG}"
+
+SWIG= swig1.3
EXAMPLES= shape.py test.py
diff --git a/graphics/py-ming/files/patch-Makefile b/graphics/py-ming/files/patch-Makefile
index 84e230b7958b..189718208c3e 100644
--- a/graphics/py-ming/files/patch-Makefile
+++ b/graphics/py-ming/files/patch-Makefile
@@ -1,13 +1,13 @@
--- Makefile.orig Fri Oct 13 15:26:29 2000
-+++ Makefile Mon Oct 16 19:08:12 2000
-@@ -1,11 +1,11 @@
++++ Makefile Tue Oct 17 17:43:54 2000
+@@ -1,11 +1,10 @@
all:
- swig -python ming.i
- gcc -I .. -I /usr/include/python1.5/ -fpic -c ming_wrap.c
- gcc -L .. -shared -o mingcmodule.so ming_wrap.o -lming
-+ swig1.3 -python ming.i
-+ gcc -I${LOCALBASE}/include/ming -I${LOCALBASE}/include/${PYTHON_VERSION} -fpic -c ming_wrap.c
-+ gcc -L${LOCALBASE}/lib -shared -o mingcmodule.so ming_wrap.o -lming
++ ${SWIG} -python ming.i
++ ${CC} ${CFLAGS} -I${LOCALBASE}/include/ming -I${LOCALBASE}/include/${PYTHON_VERSION} -fpic -c ming_wrap.c
++ ${CC} -shared -o mingcmodule.so ming_wrap.o -L${LOCALBASE}/lib -lming
clean:
rm -f mingcmodule.so core *~ *.o ming_wrap*
@@ -15,5 +15,4 @@
install:
- cp mingcmodule.so ming.py /usr/lib/python1.5/site-packages
- chmod 755 /usr/lib/python1.5/site-packages/mingcmodule.so
-+ cp mingcmodule.so ming.py ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages
-+ chmod 755 ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/mingcmodule.so
++ ${BSD_INSTALL_DATA} mingcmodule.so ming.py ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages