aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-07-07 19:00:16 +0800
committertobik <tobik@FreeBSD.org>2018-07-07 19:00:16 +0800
commit85f83e4883b67fe820f3804415a6792d5c898b31 (patch)
tree730467251549782ea3af82591a9310b7a0604d49 /graphics
parente95aebb9bfd395026d5babe0510edbd390010f1d (diff)
downloadfreebsd-ports-gnome-85f83e4883b67fe820f3804415a6792d5c898b31.tar.gz
freebsd-ports-gnome-85f83e4883b67fe820f3804415a6792d5c898b31.tar.zst
freebsd-ports-gnome-85f83e4883b67fe820f3804415a6792d5c898b31.zip
graphics/povray37: Update to 3.7.0.8
- Fixes build with Clang 6 - Reset maintainer after not responding for > 6 months - While here add license and sort variables Changes: https://github.com/POV-Ray/povray/releases/ PR: 215473 Submitted by: Andrey Zholos <aaz@q-fu.com>, Chad Jacob Milios <milios@ccsys.com> Approved by: bkoenig@alpha-tierchen.de (maintainer timeout, > 6 months)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/povray37/Makefile91
-rw-r--r--graphics/povray37/distinfo5
-rw-r--r--graphics/povray37/files/patch-Makefile.in58
-rw-r--r--graphics/povray37/files/patch-source_base_image_image.cpp29
-rw-r--r--graphics/povray37/files/patch-unix_povray.conf13
-rw-r--r--graphics/povray37/files/patch-vfe_unix_syspovconfig.h12
-rw-r--r--graphics/povray37/files/patch-vfe_unix_vfeplatform.cpp10
-rw-r--r--graphics/povray37/files/patch-vfe_vfe.cpp40
-rw-r--r--graphics/povray37/files/patch-vfe_vfe.h24
-rw-r--r--graphics/povray37/files/patch-vfe_vfesession.cpp20
-rw-r--r--graphics/povray37/files/patch-vfe_vfesession.h11
-rw-r--r--graphics/povray37/pkg-plist10
12 files changed, 70 insertions, 253 deletions
diff --git a/graphics/povray37/Makefile b/graphics/povray37/Makefile
index 8b189c4e5261..17e5ab86eb29 100644
--- a/graphics/povray37/Makefile
+++ b/graphics/povray37/Makefile
@@ -1,47 +1,48 @@
# $FreeBSD$
PORTNAME= povray
-DISTVERSION= 3.7.0.RC6
-PORTREVISION= 14
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.7.0.8
CATEGORIES= graphics
-MASTER_SITES= http://www.povray.org/beta/source/
PKGNAMESUFFIX= 37
-DIST_SUBDIR= ${PORTNAME}${PKGNAMESUFFIX}
-MAINTAINER= bkoenig@alpha-tierchen.de
+MAINTAINER= ports@FreeBSD.org
COMMENT= Persistence of Vision Ray Tracer
-LIB_DEPENDS= libboost_thread.so:devel/boost-libs
+LICENSE= AGPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_powerpc64= Does not build: c++: Internal error: Killed (program cc1plus)
-OPTIONS_DEFINE= X11 PNG JPEG TIFF OPENEXR STATIC IO EXAMPLES DOCS
-OPTIONS_DEFAULT=PNG JPEG
-OPTIONS_SUB= yes
-IO_DESC= Without I/O restrictions (security risk)
-EXAMPLES_DESC= Install example scenes
-DOCS_DESC= Install HTML documentation
+LIB_DEPENDS= libboost_thread.so:devel/boost-libs
+
+USES= autoreconf:build gmake
+USE_GITHUB= yes
+GH_ACCOUNT= POV-Ray
-USES= gmake localbase
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= COMPILED_BY=${MAINTAINER} \
+ --program-transform-name='s/povray/${PKGBASE}/' \
+ --disable-optimiz
VERSION_BASE= ${PORTVERSION:C/([0-9]+\.[0-9]+).*/\1/}
-
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${VERSION_BASE}
-EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}-${VERSION_BASE}
DATADIR= ${PREFIX}/share/${PORTNAME}-${VERSION_BASE}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${VERSION_BASE}
ETCDIR= ${PREFIX}/etc/${PORTNAME}/${VERSION_BASE}
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}-${VERSION_BASE}
-LIBS+= -lboost_system
+OPTIONS_DEFINE= X11 PNG JPEG TIFF OPENEXR STATIC IO EXAMPLES DOCS
+OPTIONS_DEFAULT=PNG JPEG
+OPTIONS_SUB= yes
-CONFIGURE_ARGS= COMPILED_BY=${MAINTAINER} \
- --program-transform-name='s/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/' \
- --disable-optimiz
+DOCS_DESC= Install HTML documentation
+EXAMPLES_DESC= Install example scenes
+IO_DESC= Without I/O restrictions (security risk)
+IO_CONFIGURE_ON= --disable-io-restrictions
+STATIC_CONFIGURE_ON= --enable-static
X11_USE= XORG=xpm,sm,ice,x11 SDL=sdl
X11_CONFIGURE_OFF= --without-x
-STATIC_CONFIGURE_ON= --enable-static
-IO_CONFIGURE_ON= --disable-io-restrictions
.include <bsd.port.options.mk>
@@ -90,49 +91,27 @@ CONFIGURE_ARGS+=--without-openexr
CONFIGURE_ARGS+=NON_REDISTRIBUTABLE_BUILD=yes
.endif
-DOC_FILES= AUTHORS ChangeLog NEWS
PORTDOCS= *
PORTEXAMPLES= *
post-patch:
-# Fix with boost 1.52 and now boost 1.55
- @${REINPLACE_CMD} -e 's/TIME_UTC/TIME_UTC_/g' ${WRKSRC}/source/backend/scene/view.cpp \
- ${WRKSRC}/source/base/timer.cpp \
- ${WRKSRC}/vfe/vfepovms.cpp \
- ${WRKSRC}/vfe/unix/platformbase.cpp \
- ${WRKSRC}/vfe/vfesession.cpp
- @${FIND} ${WRKSRC}/source/*end \( -name \*.h -o -name \*.cpp \) | \
- ${XARGS} ${GREP} -l shared_ptr | ${SED} '/shellout/d' | \
- ${XARGS} ${REINPLACE_CMD} -e 's|shared_ptr|boost::shared_ptr|g'
+ ${REINPLACE_CMD} -e 's|@@EXAMPLESDIR@@|${EXAMPLESDIR}|' \
+ -e 's|@@ETCDIR@@|${ETCDIR}|' \
+ ${WRKSRC}/unix/povray.conf
+
+pre-configure:
+ cd ${WRKSRC}/unix && ./prebuild.sh
pre-build:
.if ${PORT_OPTIONS:MSTATIC} && ${PORT_OPTIONS:MTIFF}
-# graphics/tiff adds dependencies on libjpeg and libjbig
- @${REINPLACE_CMD} -e 's,^\(LIBS = .*\)-ltiff\(.*\),\1-ltiff -ljpeg -ljbig\2,' ${WRKSRC}/unix/Makefile
+# graphics/tiff adds dependencies on libjpeg, libjbig and liblzma
+ @${REINPLACE_CMD} -e 's,^\(LIBS = .*\)-ltiff\(.*\),\1-ltiff -ljpeg -ljbig -llzma\2,' ${WRKSRC}/unix/Makefile
.endif
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/unix/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/${PORTNAME}${PKGNAMESUFFIX}.1
- @${MKDIR} ${STAGEDIR}${ETCDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${STAGEDIR}${ETCDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.ini ${STAGEDIR}${ETCDIR}
-.for i in include ini scripts
- ${MKDIR} ${STAGEDIR}${DATADIR}/$i
- cd ${WRKSRC}/$i && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/$i
+post-install:
+ ${MV} ${STAGEDIR}${DATADIR}/scenes ${STAGEDIR}${EXAMPLESDIR}
+.for i in povray.conf povray.ini
+ ${MV} ${STAGEDIR}${ETCDIR}/${i} ${STAGEDIR}${ETCDIR}/${i}.sample
.endfor
-do-install-X11-on:
- @${MKDIR} ${STAGEDIR}${DATADIR}/icons
- cd ${WRKSRC}/icons && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/icons
-
-do-install-EXAMPLES-on:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKSRC}/scenes && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
-
-do-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOC_FILES} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
-
.include <bsd.port.mk>
diff --git a/graphics/povray37/distinfo b/graphics/povray37/distinfo
index ce614eeaf70d..6173f0005443 100644
--- a/graphics/povray37/distinfo
+++ b/graphics/povray37/distinfo
@@ -1,2 +1,3 @@
-SHA256 (povray37/povray-3.7.0.RC6.tar.gz) = 374957bdb90fb7be5f36f839b3f04ab0a4340f6e8cf369f658d6592a342803e3
-SIZE (povray37/povray-3.7.0.RC6.tar.gz) = 13298421
+TIMESTAMP = 1530591958
+SHA256 (POV-Ray-povray-v3.7.0.8_GH0.tar.gz) = 53d11ebd2972fc452af168a00eb83aefb61387662c10784e81b63e44aa575de4
+SIZE (POV-Ray-povray-v3.7.0.8_GH0.tar.gz) = 52884333
diff --git a/graphics/povray37/files/patch-Makefile.in b/graphics/povray37/files/patch-Makefile.in
deleted file mode 100644
index 7ac1615efd5e..000000000000
--- a/graphics/povray37/files/patch-Makefile.in
+++ /dev/null
@@ -1,58 +0,0 @@
---- Makefile.in.orig 2011-01-22 06:36:17.000000000 +0100
-+++ Makefile.in 2011-04-15 21:25:36.000000000 +0200
-@@ -512,16 +512,6 @@
- cd "$(DESTDIR)$(povconfdir)" && rm -f $$files
- install-povdocDATA: $(povdoc_DATA)
- @$(NORMAL_INSTALL)
-- test -z "$(povdocdir)" || $(MKDIR_P) "$(DESTDIR)$(povdocdir)"
-- @list='$(povdoc_DATA)'; test -n "$(povdocdir)" || list=; \
-- for p in $$list; do \
-- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
-- echo "$$d$$p"; \
-- done | $(am__base_list) | \
-- while read files; do \
-- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(povdocdir)'"; \
-- $(INSTALL_DATA) $$files "$(DESTDIR)$(povdocdir)" || exit $$?; \
-- done
-
- uninstall-povdocDATA:
- @$(NORMAL_UNINSTALL)
-@@ -1018,7 +1008,7 @@
- install-data-local:
- cat /dev/null > $(povinstall);
- @echo "Creating data directories..."; \
-- list='$(top_srcdir)/icons $(top_srcdir)/include $(top_srcdir)/ini $(top_srcdir)/scenes'; \
-+ list='$(top_srcdir)/include $(top_srcdir)/ini'; \
- dirlist=`find $$list -type d | sed s,$(top_srcdir)/,,`; \
- for p in "" $$dirlist ; do \
- $(mkdir_p) $(DESTDIR)$(povlibdir)/$$p && printf "%s\n" "$(DESTDIR)$(povlibdir)/$$p" "`cat $(povinstall)`" > $(povinstall); \
-@@ -1028,29 +1018,6 @@
- for f in $$filelist ; do \
- $(INSTALL_DATA) $(top_srcdir)/$$f $(DESTDIR)$(povlibdir)/$$f && echo "$(DESTDIR)$(povlibdir)/$$f" >> $(povinstall); \
- done
-- @echo "Creating documentation directories..."; \
-- dirlist=`find $(top_srcdir)/doc/ -type d | sed s,$(top_srcdir)/doc/,,`; \
-- for p in "" $$dirlist ; do \
-- $(mkdir_p) $(DESTDIR)$(povdocdir)/$$p && printf "%s\n" "$(DESTDIR)$(povdocdir)/$$p" "`cat $(povinstall)`" > $(povinstall); \
-- done
-- @echo "Copying documentation files..."; \
-- filelist=`find $(top_srcdir)/doc/ -type f | sed s,$(top_srcdir)/doc/,,`; \
-- for f in $$filelist ; do \
-- $(INSTALL_DATA) $(top_srcdir)/doc/$$f $(DESTDIR)$(povdocdir)/$$f && echo "$(DESTDIR)$(povdocdir)/$$f" >> $(povinstall); \
-- done
-- @echo "Creating user directories..."; \
-- for p in $(povuser) $(povconfuser) ; do \
-- $(mkdir_p) $$p && chown $(povowner) $$p && chgrp $(povgroup) $$p && printf "%s\n" "$$p" "`cat $(povinstall)`" > $(povinstall); \
-- done
-- @echo "Copying user configuration and INI files..."; \
-- for f in povray.conf povray.ini ; do \
-- if test -f $(povconfuser)/$$f; then \
-- echo "Creating backup of $(povconfuser)/$$f"; \
-- mv -f $(povconfuser)/$$f $(povconfuser)/$$f.bak; \
-- fi; \
-- done; \
-- $(INSTALL_DATA) $(top_srcdir)/povray.conf $(povconfuser)/povray.conf && chown $(povowner) $(povconfuser)/povray.conf && chgrp $(povgroup) $(povconfuser)/povray.conf && echo "$(povconfuser)/povray.conf" >> $(povinstall); \
-- $(INSTALL_DATA) $(top_builddir)/povray.ini $(povconfuser)/povray.ini && chown $(povowner) $(povconfuser)/povray.ini && chgrp $(povgroup) $(povconfuser)/povray.ini && echo "$(povconfuser)/povray.ini" >> $(povinstall)
-
- # Remove data, config, and empty folders for 'make uninstall'.
- # Use 'hook' instead of 'local' so as to properly remove *empty* folders (e.g. scripts).
diff --git a/graphics/povray37/files/patch-source_base_image_image.cpp b/graphics/povray37/files/patch-source_base_image_image.cpp
deleted file mode 100644
index 1d9eccebaac0..000000000000
--- a/graphics/povray37/files/patch-source_base_image_image.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
---- source/base/image/image.cpp.orig 2012-06-19 02:57:32.000000000 +0200
-+++ source/base/image/image.cpp 2012-09-22 23:19:44.000000000 +0200
-@@ -2884,7 +2884,7 @@
- meta[0] = sizeof(pixel_type);
- meta[1] = m_Width;
- meta[2] = m_Height;
-- if (lseek64(m_File, pos, SEEK_SET) != pos)
-+ if (lseek(m_File, pos, SEEK_SET) != pos)
- throw POV_EXCEPTION(kFileDataErr, "Intermediate image storage backing file write/seek failed at creation.");
- if (write(m_File, &meta[0], (int) sizeof(size_type)*3) != (sizeof(size_type)*3))
- throw POV_EXCEPTION(kFileDataErr, "Intermediate image storage backing file write failed at creation.");
-@@ -3055,7 +3055,7 @@
- #endif
- pos = block * sizeof(pixel_type) * m_Blocksize;
- int chunk = sizeof(pixel_type) * m_Blocksize;
-- if (lseek64(m_File, pos, SEEK_SET) != pos)
-+ if (lseek(m_File, pos, SEEK_SET) != pos)
- throw POV_EXCEPTION(kFileDataErr, "Intermediate image storage backing file read/seek failed.");
- int bytes = read(m_File, &m_Buffer[0], chunk);
- if (bytes != (sizeof(pixel_type) * m_Blocksize))
-@@ -3078,7 +3078,7 @@
-
- if (m_Dirty) {
- pos = m_CurrentBlock * sizeof(pixel_type) * m_Blocksize;
-- if (lseek64(m_File, pos, SEEK_SET) != pos)
-+ if (lseek(m_File, pos, SEEK_SET) != pos)
- throw POV_EXCEPTION(kFileDataErr, "Intermediate image storage backing file write/seek failed.");
- if (write(m_File, &m_Buffer[0], (int) sizeof(pixel_type) * m_Blocksize) != (sizeof(pixel_type) * m_Blocksize))
- throw POV_EXCEPTION(kFileDataErr, "Intermediate image storage backing file write failed.");
diff --git a/graphics/povray37/files/patch-unix_povray.conf b/graphics/povray37/files/patch-unix_povray.conf
new file mode 100644
index 000000000000..912e7c75bb9d
--- /dev/null
+++ b/graphics/povray37/files/patch-unix_povray.conf
@@ -0,0 +1,13 @@
+--- unix/povray.conf.orig 2018-05-27 09:54:06 UTC
++++ unix/povray.conf
+@@ -89,8 +89,8 @@ forbidden
+ [Permitted Paths]
+ ;read = "/this/directory/contains space caracters"
+ read* = %INSTALLDIR%/include
+-read* = %INSTALLDIR%/scenes
+-read* = %INSTALLDIR%/../../etc
++read* = @@EXAMPLESDIR@@
++read* = @@ETCDIR@@
+ read* = %HOME%
+ read+write* = /tmp
+ read+write = .
diff --git a/graphics/povray37/files/patch-vfe_unix_syspovconfig.h b/graphics/povray37/files/patch-vfe_unix_syspovconfig.h
new file mode 100644
index 000000000000..89aababf7ff1
--- /dev/null
+++ b/graphics/povray37/files/patch-vfe_unix_syspovconfig.h
@@ -0,0 +1,12 @@
+--- vfe/unix/syspovconfig.h.orig 2018-05-27 09:54:06 UTC
++++ vfe/unix/syspovconfig.h
+@@ -162,7 +162,8 @@ const int NULL=0;
+ #include <sys/param.h>
+ #if defined(BSD)
+ // BSD-style Unix detected.
+- #error BSD-style Unix detected, but not explicitly supported yet; proceed at your own risk.
++ #include <sys/wait.h> // for WEXITSTATUS
++ #define lseek64(handle,offset,whence) lseek(handle,offset,whence)
+ #else
+ // Not officially supported yet; comment-out the following line to try with default POSIX settings.
+ #error Unix detected, but flavor not identified; proceed at your own risk.
diff --git a/graphics/povray37/files/patch-vfe_unix_vfeplatform.cpp b/graphics/povray37/files/patch-vfe_unix_vfeplatform.cpp
deleted file mode 100644
index f4ad0e170623..000000000000
--- a/graphics/povray37/files/patch-vfe_unix_vfeplatform.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- vfe/unix/vfeplatform.cpp.orig 2011-01-02 14:43:05.000000000 +0100
-+++ vfe/unix/vfeplatform.cpp 2011-03-08 12:57:50.000000000 +0100
-@@ -97,6 +97,7 @@
- #include <pthread.h>
- #include <stdlib.h>
- #include <string.h>
-+#include <sys/wait.h>
-
- #ifdef HAVE_TIME_H
- # include <time.h>
diff --git a/graphics/povray37/files/patch-vfe_vfe.cpp b/graphics/povray37/files/patch-vfe_vfe.cpp
deleted file mode 100644
index e4a536ad7fa2..000000000000
--- a/graphics/povray37/files/patch-vfe_vfe.cpp
+++ /dev/null
@@ -1,40 +0,0 @@
---- vfe/vfe.cpp.orig 2012-06-19 11:29:39.000000000 -0500
-+++ vfe/vfe.cpp
-@@ -640,7 +640,7 @@ void vfeProcessRenderOptions::WriteError
- //
- ////////////////////////////////////////////////////////////////////////////////////////
-
--VirtualFrontEnd::VirtualFrontEnd(vfeSession& session, POVMSContext ctx, POVMSAddress addr, POVMS_Object& msg, POVMS_Object *result, shared_ptr<Console>& console) :
-+VirtualFrontEnd::VirtualFrontEnd(vfeSession& session, POVMSContext ctx, POVMSAddress addr, POVMS_Object& msg, POVMS_Object *result, boost::shared_ptr<Console>& console) :
- m_Session(&session), m_PlatformBase(session), renderFrontend (ctx)
- {
- backendAddress = addr ;
-@@ -747,7 +747,7 @@ bool VirtualFrontEnd::Start(POVMS_Object
-
- if (m_Session->OutputToFileSet())
- {
-- imageProcessing = shared_ptr<ImageProcessing> (new ImageProcessing (opts));
-+ imageProcessing = boost::shared_ptr<ImageProcessing> (new ImageProcessing (opts));
- UCS2String filename = imageProcessing->GetOutputFilename (opts, 0, 0);
- options.SetUCS2String (kPOVAttrib_OutputFile, filename.c_str());
-
-@@ -774,8 +774,8 @@ bool VirtualFrontEnd::Start(POVMS_Object
- opts.Set(kPOVAttrib_Declare, declares);
- imageProcessing.reset();
- if (m_Session->OutputToFileSet())
-- imageProcessing = shared_ptr<ImageProcessing> (new ImageProcessing (opts)) ;
-- animationProcessing = shared_ptr<AnimationProcessing> (new AnimationProcessing (opts)) ;
-+ imageProcessing = boost::shared_ptr<ImageProcessing> (new ImageProcessing (opts)) ;
-+ animationProcessing = boost::shared_ptr<AnimationProcessing> (new AnimationProcessing (opts)) ;
- options = animationProcessing->GetFrameRenderOptions () ;
- }
-
-@@ -1151,7 +1151,7 @@ State VirtualFrontEnd::Process()
- }
-
- // now we display the render window, if enabled
-- shared_ptr<Display> display(GetDisplay());
-+ boost::shared_ptr<Display> display(GetDisplay());
- if (display != NULL)
- {
- vfeDisplay *disp = dynamic_cast<vfeDisplay *>(display.get());
diff --git a/graphics/povray37/files/patch-vfe_vfe.h b/graphics/povray37/files/patch-vfe_vfe.h
deleted file mode 100644
index 84a57dd04e50..000000000000
--- a/graphics/povray37/files/patch-vfe_vfe.h
+++ /dev/null
@@ -1,24 +0,0 @@
---- vfe/vfe.h.orig 2012-06-19 11:29:39.000000000 -0500
-+++ vfe/vfe.h
-@@ -267,7 +267,7 @@ namespace vfe
- class VirtualFrontEnd
- {
- public:
-- VirtualFrontEnd(vfeSession& session, POVMSContext ctx, POVMSAddress addr, POVMS_Object& msg, POVMS_Object *result, shared_ptr<Console>& console) ;
-+ VirtualFrontEnd(vfeSession& session, POVMSContext ctx, POVMSAddress addr, POVMS_Object& msg, POVMS_Object *result, boost::shared_ptr<Console>& console) ;
- virtual ~VirtualFrontEnd() ;
-
- virtual bool Start(POVMS_Object& opts) ;
-@@ -298,9 +298,9 @@ namespace vfe
- POVMS_Object options;
- RenderFrontendBase::SceneId sceneId;
- RenderFrontendBase::ViewId viewId;
-- shared_ptr<AnimationProcessing> animationProcessing ;
-- shared_ptr<ImageProcessing> imageProcessing ;
-- shared_ptr<ShelloutProcessing> shelloutProcessing;
-+ boost::shared_ptr<AnimationProcessing> animationProcessing ;
-+ boost::shared_ptr<ImageProcessing> imageProcessing ;
-+ boost::shared_ptr<ShelloutProcessing> shelloutProcessing;
- Console **consoleResult;
- Display **displayResult;
- vfeSession* m_Session;
diff --git a/graphics/povray37/files/patch-vfe_vfesession.cpp b/graphics/povray37/files/patch-vfe_vfesession.cpp
deleted file mode 100644
index 60378ef159c7..000000000000
--- a/graphics/povray37/files/patch-vfe_vfesession.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- vfe/vfesession.cpp.orig 2014-04-21 07:36:50.000000000 -0500
-+++ vfe/vfesession.cpp
-@@ -602,7 +602,7 @@ const char *vfeSession::GetBackendStateN
- boost::shared_ptr<Display> vfeSession::GetDisplay() const
- {
- if (m_Frontend == NULL)
-- return (shared_ptr<Display>());
-+ return (boost::shared_ptr<Display>());
- return m_Frontend->GetDisplay();
- }
-
-@@ -640,7 +640,7 @@ void vfeSession::WorkerThread()
- m_BackendThread = povray_init (boost::bind(&vfeSession::BackendThreadNotify, this), const_cast<void **>(&pov::RenderThreadAddr)) ;
- POVMS_Output_Context = pov::POVMS_GUI_Context ;
-
-- m_Console = shared_ptr<vfeConsole> (new vfeConsole(this, m_ConsoleWidth)) ;
-+ m_Console = boost::shared_ptr<vfeConsole> (new vfeConsole(this, m_ConsoleWidth)) ;
-
- POVMS_Object obj ;
- m_Frontend = new VirtualFrontEnd (*this, POVMS_Output_Context, (POVMSAddress) pov::RenderThreadAddr, obj, NULL, m_Console) ;
diff --git a/graphics/povray37/files/patch-vfe_vfesession.h b/graphics/povray37/files/patch-vfe_vfesession.h
deleted file mode 100644
index d21812712b1e..000000000000
--- a/graphics/povray37/files/patch-vfe_vfesession.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- vfe/vfesession.h.orig 2012-06-19 11:29:40.000000000 -0500
-+++ vfe/vfesession.h
-@@ -1294,7 +1294,7 @@ namespace vfe
-
- static bool m_Initialized;
- static vfeSession *m_CurrentSessionTemporaryHack;
-- shared_ptr<Console> m_Console;
-+ boost::shared_ptr<Console> m_Console;
-
- virtual vfeDisplay *DefaultDisplayCreator (unsigned int width, unsigned int height, GammaCurvePtr gamma, vfeSession *session, bool visible);
- DisplayCreator m_DisplayCreator;
diff --git a/graphics/povray37/pkg-plist b/graphics/povray37/pkg-plist
index 900f5a1121ca..5442e0598892 100644
--- a/graphics/povray37/pkg-plist
+++ b/graphics/povray37/pkg-plist
@@ -1,7 +1,7 @@
bin/povray37
man/man1/povray37.1.gz
-%%ETCDIR%%/povray.conf
-%%ETCDIR%%/povray.ini
+@sample %%ETCDIR%%/povray.conf.sample
+@sample %%ETCDIR%%/povray.ini.sample
%%X11%%%%DATADIR%%/icons/file_inc_classic_16.png
%%X11%%%%DATADIR%%/icons/file_inc_classic_32.png
%%X11%%%%DATADIR%%/icons/file_inc_classic_48.png
@@ -30,7 +30,8 @@ man/man1/povray37.1.gz
%%X11%%%%DATADIR%%/icons/povray_32.png
%%X11%%%%DATADIR%%/icons/povray_48.png
%%X11%%%%DATADIR%%/icons/povray_64.png
-%%DATADIR%%/include/.directory
+%%DATADIR%%/include/Mount1.png
+%%DATADIR%%/include/Mount2.png
%%DATADIR%%/include/arrays.inc
%%DATADIR%%/include/ash.map
%%DATADIR%%/include/benediti.map
@@ -51,8 +52,10 @@ man/man1/povray37.1.gz
%%DATADIR%%/include/golds.inc
%%DATADIR%%/include/ior.inc
%%DATADIR%%/include/logo.inc
+%%DATADIR%%/include/makegrass.inc
%%DATADIR%%/include/marbteal.map
%%DATADIR%%/include/math.inc
+%%DATADIR%%/include/meshmaker.inc
%%DATADIR%%/include/metals.inc
%%DATADIR%%/include/mtmand.pot
%%DATADIR%%/include/mtmandj.png
@@ -68,6 +71,7 @@ man/man1/povray37.1.gz
%%DATADIR%%/include/screen.inc
%%DATADIR%%/include/shapes.inc
%%DATADIR%%/include/shapes2.inc
+%%DATADIR%%/include/shapes3.inc
%%DATADIR%%/include/shapes_old.inc
%%DATADIR%%/include/shapesq.inc
%%DATADIR%%/include/skies.inc