aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2003-05-04 06:01:27 +0800
committervanilla <vanilla@FreeBSD.org>2003-05-04 06:01:27 +0800
commit8fd0567f720df886705ff5cf0376b63a38a633d6 (patch)
tree87884d984c746dda6f09509882752b19b4230e92 /graphics
parentcabca1a1ac62f2ade998df06a6a0c6a640e1c2f5 (diff)
downloadfreebsd-ports-gnome-8fd0567f720df886705ff5cf0376b63a38a633d6.tar.gz
freebsd-ports-gnome-8fd0567f720df886705ff5cf0376b63a38a633d6.tar.zst
freebsd-ports-gnome-8fd0567f720df886705ff5cf0376b63a38a633d6.zip
Change to use: PTHREAD_LIBS and PTHREAD_CFLAGS.
Remove patch-configure. PR: ports/51452 Submitted by: maintainer
Diffstat (limited to 'graphics')
-rw-r--r--graphics/zphoto/Makefile5
-rw-r--r--graphics/zphoto/files/patch-configure11
2 files changed, 3 insertions, 13 deletions
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index 04da5d6a16cf..79e0591dc388 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -21,8 +21,9 @@ LIB_DEPENDS= ming.3:${PORTSDIR}/graphics/ming \
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-pthread -L${LOCALBASE}/lib" \
- CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/ming"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/ming \
+ ${PTHREAD_CFLAGS}"
USE_GMAKE= yes
USE_XLIB= yes
diff --git a/graphics/zphoto/files/patch-configure b/graphics/zphoto/files/patch-configure
deleted file mode 100644
index 59a64276cab4..000000000000
--- a/graphics/zphoto/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Thu Mar 27 15:57:05 2003
-+++ configure Tue Apr 22 01:54:16 2003
-@@ -5336,7 +5336,7 @@
- ac_save_CXXFLAGS=$CXXFLAGS
- ac_save_LDFLAGS=$LDFLAGS
- CXXFLAGS="$CXXFLAGS $AVIFILE_CXXFLAGS"
-- LDFLAGS="$LDFLAGS $AVIFILE_LDFLAGS $X_LIBS -lXv -lXxf86vm"
-+ LDFLAGS="-pthread $LDFLAGS $AVIFILE_LDFLAGS $X_LIBS -lXv -lXxf86vm"
-
- echo "$as_me:$LINENO: checking compilation of avifile test program" >&5
- echo $ECHO_N "checking compilation of avifile test program... $ECHO_C" >&6